We help IT Professionals succeed at work.

#5.5.0 smtp;550 relaying mail to xzy123.com is not allowed

bobdicksoncom
bobdicksoncom used Ask the Experts™
on
I now can not send mail to anyone.
Incoming SMTP works fine

SBS 2003 two NICS
Bellsouth ADSL

Server has been working fine for several months.  Tten ran into problem that prompted us to backup data format and reinstall.  I know it is something small but I can not figure out why I can not send mail.  I set about 10 servers like this one up including this one but this is the first time I have run into this

I the past I have has trouble with Bellsouth ADSL on an Exchange server using mail.bellsouhth.net as the smart host.

Learn a workaround  to create an a record on the server and point it to the IP of mail.bellsouth.net   then put that a record in the smart host and everything works fine.

Not this time though.  Everytime I try to send  mail from the network it comes back immediately with the following message

**************
our message did not reach some or all of the intended recipients.

      Subject:      test
      Sent:      10/23/2005 7:18 PM

The following recipient(s) could not be reached:

      bob@bobdickson.com on 10/23/2005 7:18 PM
            There was a SMTP communication problem with the recipient's email server.  Please contact your system administrator.
            <oconeeconstruction.com #5.5.0 smtp;550 relaying mail to bobdickson.com is not allowed>
********************

Realy it does not matter wheater I use a smrat host or DNS or what smarthost I put in it is always the same message.  
I really believe it is internally generated and not from the ISP because it happens to quick

I have read every article I can find on this subject and nothing  works yet

Any ideas would be greatly appreiciated
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
are u sure bellsouth would allow u to use their mailserver as a smart host without
authenticating first???
are u sure u are not blacklisted???? have checked ur domain name???
are u also sure bellsouth has not cut off communication on ur port 25?????
can u telnet to ur bellsouth mailserver??? can u relay through their server???

If it happened right after the rebuild AND it still happens with use DNS enabled then it probably is your Exchange server.  But only if the clients are using POP3/SMTP or IMAP4/SMTP to connect.  If they are, its probably the relay setting on the SMTP virtual server.  By default its set to allow users that authenticate to send mail.  So on the mail client, enable the option to authenticate to your SMTP server.  Or, on the properties of the SMTP virtual server on the relay section add your internal IP list to the list of machines that can relay.

Of course if you're connecting with MAPI its less likely Exchange is the problem.

Author

Commented:
Yea I think is is in Exchange But I can not figureout how to isolate.  I turned on SMTP log but is will create logs.

All clients and  are either oulook or OWA so they are all trying to send SMTP via the exchange server.

I setup adn OE client via pop and it sends just fine without SMTP authentication
I can telnet into the server ok
I have other custoers that with SBS2003 that already relay via Bellsouth so I know that is ok
I am not black listed.

Funny thing is is does not matter waht I pu in for smarthost I still ge the same error.  So I really thing is is in exchange somewhere.

Commented:
OK since u are sure it is exchange then take a look at this section

ADSIEdit\configuration\services\microsoft exchange\urdomain name\
first administrative group\servers\servername\protocals\smtp\CN=1
1 = ur first virtual server(i suppose u have one virtual server)  right click\click on
properties....then click on security tab .. ur  exchange server must have
"send as" allow permission...if not u will have  relaying problem....

Author

Commented:
Still not luck afer verifying Exchange server had send as "alllow

Also noticed that I can not get SMTP tp generate a logfile.

Any other ideas?

Bob
Commented:
this is a long shot but try it anyways to see if ur smtpserver is not screwedup..
http://support.microsoft.com/default.aspx?scid=kb;en-us;822939

Author

Commented:
Thanks a ton Vahik.
 

Test verified the somehting was screwed up in exchange.  uninstalled and reinstall and all is well now

BD