Scheduled Tasks problem on server

On our server theres a schedule task which runs the backup at 23:59 every nite.

The domain\Administrator account and password has been set up for it to run under.

But!!!!!!!!!

It works once, then you have to reinput the password again for it to work again. I know that you should not have to do this, so any ideas why ?

This is the command line in the batch file we have created and the scheduled task is set up to run it at 23:59 every nite.....

C:\WINNT\system32\NTBACKUP.EXE backup "@C:\backup.bks"  /v:yes /r:no /rs:no /hc:on /m normal /j "Job1" /l:s /p "4mm DDS" /UM
LVL 1
BarkersITAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jimmymcp02Commented:
Here are my 2 cents

i did that before created a batch file and the next day i had to input the password again, finally i deleted the task an created a new from task scheduler and that fixed my issue...try that and post back..
0
BarkersITAuthor Commented:
We have been scheduling the backup program to run the backup via the scheduled task schedular for a while now, I have tried recreating them many times, using batch files, linking the task schedular directly to the backup program, tried recreating users and adding them in the username and password boxes, everything. Bloody everything. lol. Well apart from reinstalling the OS, which is unrealistic at the moment.

Its strange the same problem is happening on both servers in the same office (domain, as our network consists of 4 domains all joined).

Ive also tried to change the username and password for the scheduled task service but it wont start up on any other username and password apart from the default one.

Grrr.
0
jimmymcp02Commented:
Do you have sql installed in one of those servers.. or any type os database server....Have you tried updating you OS to the lastest service packss
0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

BarkersITAuthor Commented:
Ones an exchange server and ones a file server mate, so no SQL datebases or any other databases. Both servers have the latest service packs also.
0
jimmymcp02Commented:
so lets get back to work....

let assume that you are running the schedule task with admin account
now have you tried running the task with the LOCAL ADMIN account? if not please try it... and post back
0
BarkersITAuthor Commented:
There is no local administrator account on the servers as they are both domain controllers.
0
BarkersITAuthor Commented:
Any updates please ? Thanks.
0
BarkersITAuthor Commented:
Id love to run it as a local admin account on our domain controllers lol. But the only way I could find out how to do it was specify log on locally in the domain poilcy. Which locked out all our users so had to set it back. Ill check the articles you have posted and see if they say any different.
0
BarkersITAuthor Commented:
Having read that, yet again microsoft ONLY offer help for THEIR way of doing things. lol.

I cant find anywhere on the microsoft website offering advice for running scheduled tasks on domain controllers with domain or even local admin accounts. Im gonna take this problem to my grave I think. lol.
0
jimmymcp02Commented:
hmm it sounds like your policies are conflicting with the schedule tasks.
0
BarkersITAuthor Commented:
Would you mind elaborating ? What policies would conflict with schedule tasks ? and why would they work for abit and then the password resets iself ? How ? Thanks.
0
jimmymcp02Commented:
hope this helps.

has explained in the article below if you change the accounts passwords
lets say today to the same password ie change it from pine to pine eventhough the password remained the same you still need to re-type the password for the scheduler now i know you dont change the admin password everyday so i can tell that your policies are confliting

here is the microsoft article

your user doesnt have the rights to "log on as batch job"
it doesnt matter if your account is an admin account you still need to set this permissions.
http://support.microsoft.com/kb/q222628/

i hope that this takes care of your issue


P.S. is not a good practice to run task under domain groups read the article below.
htttp://www.microsoft.com/technet/prodtechnol/windowsserver2003/library/ServerHelp/573a07f4-3fca-4e95-8c94-b3842b840273.mspx
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BarkersITAuthor Commented:
I think youve got it. Woohoooooo!!! Thanks bro.
0
jimmymcp02Commented:
anytime
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.