We help IT Professionals succeed at work.

Harddrive unallocated

Dashteifel
Dashteifel asked
on
Tower1
2.0 Mhz
1 gig ram
Win XP PRo Sp2

Tower2
2400 Athlon (i think)
1 gig ram
Win XP PRo Sp2

I have 2 towers.  I pulled a 200g harddrive (with 150 gigs of data in it!)  form Tower1 and moved it over to Tower2.
When I turned Tower2 on, the bios sees the 200g drive, but Windows doesn't.

I opened My Computer and the drive wasn't listed.

I went to Computer Management -->  Disc Management and it says that the 200g is unallocated.
I right clicked it and got it online, but I can not assign a drive letter to it.
I hummed and hawwed over it for awhile, did some reboots, changed the cable position and jumpers, but still no joy.

I took the 200g and put it back the same way into the original Tower1 and it is doing the same thing. Shows no data.

any ideas on how to retrieve the data?

Comment
Watch Question

Retired IT
Commented:
You DO have a problem.  If the system cannot assign a drive letter (and you have already checked that you have no drive letter conflicts) then the system does not recognize the drive as a valid memory device.  Tell me, how was the drive formatted:  NTFS or FAT32?  That may give us a hint which way to proceed.  If NTFS, you can try out NTFSPRO to see if the drive can even be mounted.  If FAT32, boot to a DOS disk and see if anything can be seen there.  

You mentioned "the bios sees the 200g drive, but Windows doesn't".  DOS can see drives that have not been formatted, windows can see them, but cannot assign a drive letter until they have been formatted in a way that is recognized.  Read up on "MBR /F" to see if that could help.  MBR "Master Boot Record" not only checks the boot spool on the HDD, but also checks the start/stop spools as well.  This will only work, however, if the DOS level can even assign a drive label (ie. D:) --  no drive letter, you can't use DOS commands.

Check out any utilities that are provided from the HDD manufacturer.  Many of these can repair or solve the problems you describe.  Unfortunately, since you mentioned you have the same problem with the same drive in two different PCs, it may also mean the drive itself is defective.  If still under warranty, you may want to get it replaced.

Hope some of this helps.

Rick
huntersvcsRetired IT

Commented:
One thing you forgot to mention:  IDE or SATA?  Also, check to see if the controllers are ACTIVE on both machines.  Re-reading your initial statement:

HDD in machine 1 working.
Moved to machine 2 - no joy.
Moved back to machine 1 - doesn't work any more?

Have I got it right??  Wierd!

Author

Commented:
IDE

I have used EasyRecovery to pull out all my data.
the 200g has been in both machines at one time or another.
Lee W, MVPTechnology and Business Process Advisor
Most Valuable Expert 2013

Commented:
Usually this is a problem with the MBR - tools like www.ptdd.com can often recover the table correctly and give you access to your data.

If you're feeling really adventurous, you can use a byte level editor such as winhex (www.winhex.com) to manually change the partition type and/or at least review the type the disk claims to be.

Another thing, less adventurous that can give you some insight, download a copy of Knoppix (www.knoppix.net) and burn it to a CD.  Then boot off it and run cfdisk from the linux console.  It should tell you what partition type it sees.

For some more info (not necessarily EXACTLY for this problem), check out a tip I put up on my site:  http://www.lwcomputing.com/tips/showtip.asp?tid=1
Eric BDirector of Information Technology

Commented:
Dont you have to "sign" the new disk? When disk management finds a new disks, it tries to attribute a signature on that disk to make it readable.
huntersvcsRetired IT

Commented:
The question was:

"any ideas on how to retrieve the data?"

Your later comment:

"I have used EasyRecovery to pull out all my data."

Did the MBR /F give you any results?  Have you tried any disk repair utilities -- PartitionMagic, PTD, etc?