mysql_fix_privilege_tables problem

I have the problem with MySQL or PHPMyAdmin under Windows XP :

When I want to see, with PHPMyAdmin, the privileges, it shows me the next error :
--------------------
Warning: Your privilege table structure seems to be older than this MySQL version!
Please run the script mysql_fix_privilege_tables that should be included in your MySQL server distribution to solve this problem!
--------------------

First, I haven't got any mysql_fix_privilege_tables.sql file, and even the "scripts" folder. So, after reading

http://www.experts-exchange.com/Databases/Mysql/Q_20853977.html

I created the ".../MySQL/scripts/mysql_fix_privilege_tables.sql" file. Then, I've executed the script through MySQL console. All's Ok, except PHPMyAdmin shows the same error...
What is the problem ?


PS. I have Windows XP, MySQL 5.0 and PHPMyAdmin 2.7.0-pl1
MainMaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MainMaAuthor Commented:
I've just tried to use the mysql_fix_privilege_tables.sql file from mysql-noinstall-5.0.17-win32.zip. It returns about 40 identical errors "ERROR 1046 (3D000): No database selected", and PHPMyAdmin shows always the same error.
todd_farmerCommented:
You may need to specify the "mysql" database before running the script.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MainMaAuthor Commented:
Ok ! Now, it works.

For all people having the same problem :

In MySQL documentation, you can find :
--------------------
On Windows systems, MySQL distributions include a mysql_fix_privilege_tables.sql SQL script that you can run using the mysql client. For example, if your MySQL installation is located at C:\Program Files\MySQL\MySQL Server 5.0, the commands look like this:

C:\> C:\Program Files\MySQL\MySQL Server 5.0\bin\mysql -u root -p mysql
mysql> SOURCE C:/Program Files/MySQL/MySQL Server 5.0/scripts/mysql_fix_privilege_tables.sql
--------------------



So it doesn't work (for me). The right way (which worked for me) is :
--------------------
mysql.exe --force mysql < C:/Program Files/MySQL/MySQL Server 5.0/scripts/mysql_fix_privilege_tables.sql -u root -p
--------------------
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
MySQL Server

From novice to tech pro — start learning today.