Itprosbsconsole.msc, et. al. fail. Checked all the solutions, none appear to work. What can I do?

Here's the problem.  A while back we had a full server crash with no full backup (inherited all this, relatively new on the job).  I got the 2003 Windows SBS backup and going as best I could, but now some of the MMC's won't work.  Many will, the ones that won't are the following:

Small Business Server Administrator Home Page (the one I need most!)
Small Business Server Advanced Management
Small Business Server Information Center
Small Business Server Internal Web Site
Small Business Server Internet and E-Mail
Small Business Server Licensing
Small Business Server Manager
Small Business Server Monitor and Reporting
Small Business Server Power User Home Page

When I attempt to use any of those I get the stock:

Snap-in Failed to Initilialize
Name: (Name from Above)
CLSID:{xxxxxxxxx yada)

Upon clicking ok I receive:

Snap-In Creation Failed.

The snap-in is not created, it may not be installed properly

Name: (Name from Above)
CLSID:{xxxxxxxx yada}

I have attempted the following suggested solutions, none of which worked:

1)Check the PATH environmental variable (was correct)
2)Reinstall Admin Tools (AdminPack.msi does not exist on the 2003 CDs I have, only Admin.msi -- drops into log that it was successfully installed, no change)
3) Delete old .MSC files and re-install (no change)
4) Copy itprosbsconsole.msc from CD (no change)
5) Ensure you have full administrative access (no question here -- doubled checked anyway)
6) Remove the snap-ins and reload them (this does not work as.. a: they aren't listed to be removed anywhere and b: even if I attempt to add them to a blank MMC console, it fails.  The snap-ins themselves have only a blank folder beside them, no icon like the rest).

Pretty time sensitive here, spent a decent chunk of two days working on this as I need to get our new employees in the system, and without using itprosbsconsole.msc adding them manually causes a lot of problems (not added to global address list, even after a rebuild, etc. etc. etc.).

Thanks for any help ahead of time.
LVL 16
AdamRobinsonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Bradley FoxLAN/WAN Systems AdministratorCommented:
I would reinstall adminpak.msi.  You can get it here.

http://www.microsoft.com/downloads/details.aspx?FamilyID=c16ae515-c8f4-47ef-a1e4-a8dcbacff8e3&DisplayLang=en

Also to buy yourself some time you can load admin.msi from the CD on your XP Workstation and administer from there as long as you are a domain admin.
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Hi AdamRobinson,

With SBS you need to remember that all of it's tools are installed and controlled by the INTEGRATED INSTALLATION.  So to repair the administrative tools, you need to go to add/remove programs > Windows Small Business Server > Change

(You must be logged in as the ADMINISTRATOR to do this - not just a member of the administrator's group)

Then, click through to the Component Selection screen and change "Server Tools" to MAINTENANCE mode.  You must then change Administration to REINSTALL if you haven't installed SP1 yet, and then continue through the wizard.  If you have installed SP1, you will change Administration to UNINSTALL, go through the wizard and then go back to it and again set Server Tools to MAINTENANCE and Administration to INSTALL.

Jeff
TechSoEasy

Good Luck!

Jeff
TechSoEasy

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
OWASP: Threats Fundamentals

Learn the top ten threats that are present in modern web-application development and how to protect your business from them.

AdamRobinsonAuthor Commented:
Apologies for the delay in responding.  I haven't had a chance to go through the solutions as we had a router issue pop up which consumed a good deal of my time over the last few days.  I will try the individual solutions sometime over the next day or so and see if we can get them to work.

To clarify, though, to do the SBS Administrative Re-Install will I need to reboot the server at any point?  Given our system layout, I can't take it down for a few days due to year-end inventory processes.

Thanks.
terrygreensillCommented:
This happens when the dll's for the snapin's are not registered, You need to register the dll's for the snap-in if the other sugestions do not fix your problem
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
I don't remember off hand if that particular reinstall requires a reboot... some do and some don't, so best to wait.

The registering of the snap-ins will be done by the reinstall.  Manually doing this in an SBS environment isn't advised due to interoperability issues (http://snipurl.com/itpro)

Jeff
TechSoEasy
AdamRobinsonAuthor Commented:
So far nothing has worked, but I'm going to try it all a second time.  

And stafi, that link is not so great.  I'm not trying to knock you, but a link that's first suggestion is "flatten the box and start over," is really bad advice for a problem like this, unless someone is running 2003 out of his or her bedroom and there's no consequence to doing so.

Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Actually if you read further down the page on that link it suggests the exact same thing I did... to reinstall the Administrative tools.

But the fact is that you recovered your server from a crash incorrectly.  The way it needs to be done is to reinstall SBS completely with all patches and service packs -- knowing that it's in working condition and then restoring a backup.  Since you had no full backup, you of course couldn't do this... but it's not too late to do it.  (Plus, it really is about the only way your going to get all this back... it's almost a "flatten the box" issue).

However, it can be done in under 4 hours or less if you're lucky (a lot more if you're not).  I would suggest that you now run a complete backup.  You can then do a full install making sure that you also install every patch that is currently on your machine.  Then apply a full restore on top of that -- making sure that the option to not replace any new file is selected, and you'll be back in business.  

Really... taking these few hours to do it right will save you many, many hours of troubleshooting in the future.  As an extra precaution, I would suggest that you either make a full image of your drives before the restore... or if you have a simple drive configuration, pull the drives and use new ones for your restore... that way you can pop the old ones back in if it doesn't work.

Wish I had easier news for ya...

Jeff
TechSoEasy
AdamRobinsonAuthor Commented:
Jeff,

I think perhaps the confusion above is where I accidently joined the words "back up" to "backup."  I completely reinstalled SBS with all patches and service packs and started over completely, following the directions of some very helpful people here after many hours of research.  No information was restored from the backup until after everything was installed.  It worked correctly.  What was backed up was then put back on the server.  It still worked correctly.  It was only recently that the administrative tools stopped working (nothing was changed/installed/patched/altered in that period -- guessing possibly something with AD replication?  Unsure.).

The person/people who had set up the backup, or someone who followed after, had it set to back up virtually nothing from the drive other than some user document folders.  I learned my lesson there on taking the word of people that things are actually doing what they're supposed to be doing -- triple checking everything now.

Perhaps I was not clear enough in my original post -- it's only a very few items in the MMC that aren't working.  98% of everything does.  It just happened to be those things I used most often previously.

Nevertheless, I may eventually go ahead and take your (plural) suggestions and flatten the box again, but it won't be for a while as this is the first time the system has run remotely correctly since I've been here, and I'm hesitant to do anything that would compromise its working now, as it's only a minor inconvenience for me to establish these things without the console.

I'll give ya both points on it for your help.  Appreciate it as always.
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
No problem... just to clarify then... had you installed Service Pack 1 on your SBS?

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.