VPN and printing to network printer

We have an odd situation with clients at a remote office being able to print
to a local printer while connected to the main site via VPN. We have a
Windows 2000 RAS server at the main site serving VPN. At the remote site we
have Windows XP machines on a LAN connected to the internet via DSL. The
Windows XP machines share one printer that is connected to one of the
machines and the rest print to it over the local LAN. Each Windows XP
machine connects to the main site using the built in MS VPN client and then
launches a remote desktop session to a Windows 2000 terminal server at the
main site. To enable each client to print while connected to the terminal
server, we setup the network printer at the local site as a local printer on
each machine by redirecting the lpt3 port to the printer network share. This
works and each client RDP session maps the printer to the session on the
terminal server. The problem we are having is that clients are losing their
connection to the local printer when the VPN session is active. I'm
wondering if this is because when the VPN connection is active on a client
machine, the connection to the local LAN is disrupted? Any thoughts of this
would be appreciated.
Colin
cbondiAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Erik BjersPrincipal Systems AdministratorCommented:
Most of the time when you connect to a VPN you are given a new default gateway the points to the router on the VPN,  therefor all traffic that would have been routed to the local network dosen't know where to go anymore.  You can create a static rout on the computer or disable the use of the remote gate way in the VPN.  

To disable the remote gateway;
Go to the properties of the connection,
Under networking select TCP/IP and go to properties,
Click the advanced button
Uncheck use default gateway on remote network

After you do this you should beable to access the printer on the local network, however some of the resources in the VPN may not be available, you will have to play with it to get it right.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.