Problem with mouse control while playing UT2004

Hi.  

While playing UT2004, the mouse seems to stop responding in the game, e.g. if I run around, I can't look using the mouse, but can strafe and jump using the keyboard.  I've tried lowering the graphics, but it doesn't help.  

I don't think it's that it's that the surface is too shiny (it's an optical mouse) as I've never had any trouble outside the game, and it only seems to be in UT2004.  

I have a Celeron 2.6ghz machine with 512mb RAM and a 128mb ATi Radeon 9200SE PCI graphics card, and an optical USB mouse.  It runs Windows Server 2003 SP1 with Direct X 9.0c.  


Any ideas?  



Paul.
LVL 1
W2k-UserAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

W2k-UserAuthor Commented:
If it helps, I have the average fps figures from various graphics settings:

Texture detail - Higher
Character detail - Higher
World detail - High
Physics detail - Normal
Dynamic Mesh LOD - High
Decal Stay - Normal
Character Shadows - Full
everything but trilinear filtering - ON

640x480@16bpp - avg ~12fps
1280x1024@32bpp - avg ~13fps


With everything at maximum setting, 1280x1024@32bpp avg ~13fps
With everything at minimum/off setting, 640x480@16bpp avg ~15fps


Paul.
☠ MASQ ☠Commented:
Mouse lag is usually due to VSync in your display settings. Try switching VSync off (and also switching Mouse Lag off as well).  At your fps you probally won't notice any deterioration in display quality but it should help with mouse control.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
W2k-UserAuthor Commented:
Thankyou ManqueRAID.  That helped quite a bit.  

It seems it also helps slightly when I changed the Processor Resource Allocation priority to Programs from Background Services as well.  


Paul.
W2k-UserAuthor Commented:
Why is it that VSync degrades performance so much?  It seems to make the graphics more stable when it's enabled.  
☠ MASQ ☠Commented:
Thanks for the points.  Hopefully to answer your supplemental question:

Vsync effectively limits the frame rate to your current refresh rate at any given resolution. Without it enabled frames are rendered as fast as they can be regardless of refresh rate, although with a higher fps you may experience image tearing and/or controller lag by doing this.  It is not particularly resource hungry but can make a big difference if you have a lower fps rate.  UT seems particularly prone to this. Changing resouce priorities is a good idea you could use that to improve performance in other games where vsync isn't an issue.

M :o)
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Computer Games

From novice to tech pro — start learning today.