share files and folders between linux and solaris

Dear all

I have completed a network of 3 servers: 2 solaris boxes for web/mail, database (192.168.1.2 and 192.168.1.3), and 1 linux box for ftp server(192.168.1.4).
my goal is letting clients outside to be able to connect the ftp server in order to upload/download files. I have done that.

my next goal is letting the ftp server share files with the web server. The webserver hosts 1   forum-like website that servers movies and musics.
Is there any way for me to "link" the files on the ftp server with the code in the webserver?

I've tried to install apache into the ftp server and have my codes point to the link http://192.168.1.4/folder/music.mp3 but it doesn't work?
Can you give me some ideas?

Thanks alot!!!!
valleytechAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jlevieCommented:
The easy way to do this is to NFS mount the relevant directories on the web servers.
valleytechAuthor Commented:
can you please be more specific. I am working on NFS  right now. When i do "sys-unconfig" on solaris, i did not chose NFS, is it ok?
jlevieCommented:
I'm a little confused as to where the files are kept an how you want them to be accessible (ftp or http?). If you can elaborate I'm sure I can suggest a solution.
Announcing the Winners!

The results are in for the 15th Annual Expert Awards! Congratulations to the winners, and thank you to everyone who participated in the nominations. We are so grateful for the valuable contributions experts make on a daily basis. Click to read more about this year’s recipients!

valleytechAuthor Commented:
ok..here is the command i was trying to do ( from the solaris box)

mount -F nfs 192.168.1.4:/home /hdd

here is the error:
nfs mount: 192.168.1.4: : RPC: Program not registered
nfs mount: retrying: /hdd

I don't know why the RPC is not registered! the linux is Whitebox version

thanks alot
valleytechAuthor Commented:
sorry for confusing:
the linux-ftp server is suggested to keep all the files
the solaris box is suggested to keep the code that read those files

thanks alot
XoFCommented:
> nfs mount: 192.168.1.4: : RPC: Program not registered

you have to have portmapper running on the linux box.
Try "/etc/init.d/portmap start".

Cheers,

-XoF-
valleytechAuthor Commented:
still..from the solaris box. i tried to mount nfs and i still got the error.
From the linux box, tried: mount 192.168.1.2:/hdd /home

and i got nothing..it seems to me that the proccess hang!!!
thanks alot
jlevieCommented:
What does /etc/exports contain on the Linux box? It should be something similar to:

/home    192.168.1(rw,sync)

Both portmap and nfs must be enabled and running:

chkconfig portmap on
chkconfig nfs on
/etc/init.d/portmap start
/etc/init.d/nfs start

Then you should be able to execute 'exportfs -v' and see the exported NFS share.

Oh yeah, if there's a firewall running on the Linux box it must allow all connections from the the solaris boxes. If in doubt as to the firewwall execute '/etc/init.d/iptables stop' before you try to mount an NFS volume from a solaris box.
xDamoxCommented:
Hi,

you said you install HTTPd on your ftp server but it would not let you download the files. What is your Linux machine?
valleytechAuthor Commented:
my linux machine is installed with apache, proftpd, connected to a router with 192.168.1.4
my "main" solaris weserver should be "getting" those files on linux. I'm sorry if i brought forth too many confuses.

Here is the plan...i came up with prior to knowing NFS
the linux will host media "large" files like movies, video . . .
the solaris will hsot the website. Within the the website's codes, which is PHP, i had it like this: http://192.168.1.4/musics/file.mp3 so that the code can "read" the file  name linux.

However, the linux machice seems to refuse the connection, eventhough, i have turned off iptables

thanks alot
i am working on nfs now
valleytechAuthor Commented:
hi..there is a "progess"
from the solaris box: mount -F nfs 192.168.1.4:/home /hdd

i did not get "RPC not register anymore" but "permission denied"
valleytechAuthor Commented:
by the way, the /etc/exports only has a "#" ---> do i have to add an entry for the folder i want to mound?

thanks very much
jlevieCommented:
On the Linux box you have to have an entry to export the NFS volume (see above). And after adding that entry restart nfs and then you should be able to mount the volume on the Solaris machine.

In your Apache config on Solaris you'll need to add a <Directory> stanza for the mount point (/hdd) and and you may want to create an Alias for that directory.
valleytechAuthor Commented:
dear,,,

i still got that same result...sill permission denied

here is what I got from exportfs -v

[root@web root]# exportfs -v
/home           192.168.1(rw,wdelay,root_squash)


thanks alot!!
I will be very grateful for your helps to guide me through this!

jlevieCommented:
My error. The line for exports should have read:

/home           192.168.1.0/24(rw,wdelay,root_squash)

That should work better.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
valleytechAuthor Commented:
dear,

this is awesome!!!!...

thanks alot!!!...u help me make a breakthrough
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.