network between 2 computers with no hub

I have 2 computers connected with a crossover cable.
I have been successfully networking them for several months.
   I had to switch computers recently so I tried to set the new computer's network card properties identical to the one I'm replacing but I can't seem to get the network to work the same way.
 I'm using a win 2k machine as a server so I can access my photo library which resides on the 2 hard drives in the win 2k machine. The connected machine is running winXP. When I ping the win2k from the winXP it sees the connection. When I ping the XP from the Win2k I get time out responses.
  When I run cmd prompt from the XP to call up the win 2k I am asked for a user name and password.
     Can anybody walk me through this.
       Thanks
slrzoomAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rob WilliamsCommented:
Where you have a "one way" connection when you ping it sounds like the firewall installed by SP2 on Windows XP is enabled. It will block the pings and file sharing unless you enable exceptions. For test purposes, try disabling it. This can be done by going to control panel | Windows firewall | off.
slrzoomAuthor Commented:
That's what I thought of at first but I'm running SP1 on the XP machine and there's no firewall. The previous machine did run XP SP2 and had a firwall that was simple to disable. My guess is I need to change some other security features here but I have no idea where to start. I mentioned that when I try to call up the win 2k machine with a cmd prompt from the XP, I get a user name password dialogue. I don't have any idea how to set that up either.
     Any other ideas?
         Thanks
Rob WilliamsCommented:
That would have been to easy wouldn't it. :)
-Can you verify the cable is OK? Try another if necessary
-On the XP machine since it doesn't respond try reseting the network card by entering at a command line:
  netsh  int  ip  reset  c:\reset.txt
-When asked for the username and password have you tried to enter a legitimate account name and password that exists on the server? If so does it connect?
-Have you tried to connect through a Windows Explorer window with \\ServerName\ShareName to see if it asks for credentials (username and password)
-Other things to double check on both machines, but would not have anything to do with inability to ping
  -Client for Microsoft networks enabled on the network card properties
  -File and print sharing enabled
  -Members of same workgroup (assuming not a domain)
  -A folder is shared on both machines
  -Exact same account on both machines, using same username and password (not blank) will allow you to connect without having to enter credentials when connecting

More questions than answers, but perhaps one will lead to an answer.
Become a CompTIA Certified Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

Fatal_ExceptionSystems EngineerCommented:
Just one other thing you may try, in addition to Rob's suggestions...

In device manager, under the NIC's properties window, try setting both NICs to the same link speed..  Start with 100 half duplex, then drop them down if you still cannot connect...

Also, I assume you are running static addresss..  ck to make sure they are both using the same subnet address, and are identical in every respect other than the last octet of the IP Address....

FE

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Fatal_ExceptionSystems EngineerCommented:
BTW:  you do understand that you will get a lot more functionality out of this if you go down and spend $20 on a switch, and just use it for sharing your network...  If the switch were 100Mbps full duplex, then your data transfer would increase also (vs. any half duplex setting..)
artofchoboCommented:
Do you have any firewall program installed? Norton internet security or norton antivirus which may block network connectivity. Or either zone alarm settings which may be set as untrusted network.

Regards,
chobo
sr75Commented:
SP1 and plain old vanila Windows XP comes with a Firewall, not just SP2.  SP2 is a much more hardier firewall then the one that came standard though.
slrzoomAuthor Commented:
OK I found I was changing settings to the wrong card on the XP machine. I can now ping in both directions. When I run>(the win 2k machine) from the XP machine I get a security dialogue box. I guess I need to set up passwords on each machine? I'm not using any administrator password (that I know of) on either machine right now. How do I go about doing this and will I need to log on with a password each and every time I boot up or try to access files?
    Thanks for the help - looks like I'm almost there.
Fatal_ExceptionSystems EngineerCommented:
If you create identical user accounts, with the same passwords, then you will not have to supply a password..  But regardless, you need at least one user account on each machine with a password so that you can access files.  This is a requirement.

If using XP Pro (and this goes for W2K too) Open computer management (right click My Computer > Manage) and drill down to Users Container.  In the right hand pane, right click the account (I suggest administrator) and choose Change Password.

If using Home edition, then you must go to the Control Panel > Users and set the password there..

FE
Fatal_ExceptionSystems EngineerCommented:
BTW:  you will get a warning about changing passwords..  this is only applicable if you have encrypted anything on your system.  If you have, decrypt it first!

FE
slrzoomAuthor Commented:
OK.
   I guess I'm getting somewhere. I can access my "shared" folder that resides on the Win 2k machine when I run>\\server on the replacement XP machine but I need to type in a password each time the machine is rebooted. I can not see the folder in "My Computer" tree. I cannot see the folder when I try to open photos through an application (Photoshop).
    On my old machine (the one I'm replacing) I was able to see both drives that reside on the Win 2k machine.
    I can't remember how I did it but I was able to see these drives with the old XP machine. I never needed a password either. What am I doing wrong?
Fatal_ExceptionSystems EngineerCommented:
Okay, you are close to resolving this.  You can map a drive and have it be 'persistent' if you wish.  I use the Net Use command for my networked mapped drives like this:

net use x: \\"servername"\"sharename" "password" /user:"administrator" /persistent

IE..  you need to fill in everything in parenthesis..  :)
Rob WilliamsCommented:
If the net use with a password doesn't eliminate the need for a password, as Fatal_Exception and I suggested above make sure you have identical user accounts on both machines. Same user name, and password. (not a blank password)
slrzoomAuthor Commented:
Things are looking better all the time.
   I have all the drives mapped. I can see them when I open "My Computer" window I can access them through the application I'm running (Photoshop).
   I'm stiil having the password issue though. It's really odd because I never had this problem with the first XP machine I set up.
  I have even ste the Win 2k machine up to access the drives in the new XP machine. There is no password issue on the Win 2k machine.
   I have set both machines with identical accounts and passwords. I have tried running
 net use x:\\"servername"\"sharename" "password" /user:"administrator" /persistent

I also put this in as a command prompt and got back a syntax error with a suggestion for correct syntax structure but I can't figure out the exact way this should be written.

  My computer Name is "Dell733" My account name is "KLM" password "KLM"
 The drive names (as expressed in the XP "My Computer" window are
 "c$ on 'Dell733' (Y:)" and
 "e$ on 'Dell733' (Z:)"

I guess I can live with the password issue but as I said I never had this probem with the other XP machine and I didn't run into it with the Win 2k machine.

I'm sure I'm not running the "persistent" command correctly. Can you try to type out exactly what I should key in with the account information I provided?

        Thanks very much

Rob WilliamsCommented:
slrzoom try connecting to a share other than C$ and see if you still have the password issue. "$" shares are hidden Administrator shares only, and are treated somewhat differently.  Also it is not a "best practice" to share the entire C drive. Try sharing a folder like "Data" and using the above suggestions. Example ( I added some spaces for clarity):
net use Y:  \\Dell733\Data  KLM  /user:KLM   /persistent:yes
Fatal_ExceptionSystems EngineerCommented:
Ditto!  :)
Rob WilliamsCommented:
slrzoom, any luck resolving as of yet?
--Rob
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.