DNS configuration SBS 2003 with exchange 2003

I'm a bit of a newbie and I am desperate for some assistance.

Setting up SBS 2003 with Exchange 2003 for mail to be hosted on our server.  Very small company, we only have 1 server that will be doing this all.

I have searched thru all the threads and can't get anything specific enough to help me out so hopefully someone can look at my specific situation.

I've up mycompany.local as the internal domain.

I want to configure Exchange to be our mail server for our employees.

However, when I run the Exchange Mail wizard setup tool - after I get to the part about whether I want to send and receive email - I click next and keep getting the message "To send Internet email the selected server cannot be a bridgehead server" then it won't allow me to do anything else.

I believe this MAY be a result of faulty DNS configurations (although I am not positive) The whole .local thing is confusing me in terms of configuring the DNS.  Our company website is hosted externally and we have a registered domain mycompany.com, yet I want to internally house the mail server on the SBS 2003.  We previously ran an inhouse mail server on Domino R5.

The DNS was automatically configured when I set up SBS2003

Forward lookup zone is mycompany.local
SOA is myservername.mycompany.local
NS is myservername.mycompany.local
myservername HOST (A) (my server's IP)

If I do NSLOOKUP I get "can't find server name for" "non-existant domain name"
server: unknown

If someone can please provide specifics on what I need to do to resolve this, it would be greatly appreciated.

Time is of the essence!

Thanks a million!


Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

on our sbs box, we have a forwardlookup zone called ourdomain.local, in that zone are an SOA record listing the server.ourdomaon.local
Also an NS record, but I don't see any mx records.

server manager, under advanced mgmt, first organization, servers, ourserver, protocols, smtp, properties -> delivery -> advanced tab we have our .com name as the fully qualified name

Also check
server manager, under advanced mgmt, first organization, Connectors and look at the connectors you are using - I think the default is small business smtp connector.
If memory serves, I had to change that so that it would pick up mail from a domain other than .local (I have an extra connector for a different domain right under it)
Right click the connector and choose properties -> then look at the address space tab
My address reads * but I think it might have been *.mydomain.local originally.
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Hi jiggamoose,

You should NOT be using the Exchange Mail wizard setup tool.  I'm guessing you found that by right clicking on the Exchange Node of the Server management console.  Unfortunately, Microsoft didn't disable that on SBS and it should be!

You should do all email configuration through the Internet & Email section of the Server Management Console.  Specifically run the Configure Email and Internet Connection Wizard (CEICW).  It is there that you will find all that you need to set this up.

Good Luck!

Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:

P. S.  This is also what will fix your DNS.

Exploring SharePoint 2016

Explore SharePoint 2016, the web-based, collaborative platform that integrates with Microsoft Office to provide intranets, secure document management, and collaboration so you can develop your online and offline capabilities.

Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:

And lastly... if you didn't know about this wizard to begin with, I'd HIGHLY suggest that you read http://sbsurl.com/start thoroughly so you can get a better understanding of how to manage the server.

jiggamooseAuthor Commented:
Thanks Jeff I'll try that.  Can you please give me the full link I clicked on that one and it came up with this : Sorry, that snipped URL is either not in our records, or private, or spam-protected. Let's snip another URL.

I hope it works I'm dying over here
jiggamooseAuthor Commented:
Another question if your there Jeff.

When I run the CEICW wizard - it gets to the part about creating a new web server certificate (enter the full name of your web server etc etc)  what am I suppose to put in here? I want my mail hosted by the SBS2003 server - my internet domain for our company is hosted externally - I am unsure of what to put here.


Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Sorry about that, wrong link:  http://snipurl.com/install  The full link breaks here because it's so long!

You will put the PUBLIC FQDN of your server here, ie, servername.domain.com.  You must have your ISP point the MX record for your domain to your server's IP address for this to work, though.

While this article is a bit in depth it does cover the topic of DNS so you can better understand it:

For a pictoral how-to on the CEICW:   http://sbsurl.com/ceicw

jiggamooseAuthor Commented:
I really feel like an idiot asking all these questions but this is my first experience with SBS2003 and I find it quite confusing.

I have done a great deal of reading on DNS etc. and the setup of SBS2003 but I can't get anything to work properly.

Here is a few more details.

I originally had a standalone Windows NT server running Domino R5.  We hosted our own mail server on it, everything worked adequately.

We then moved to a standalone windows sbs2003 with exchange.  I gave the new server the same static IP the NT Server used previously let's say so I didn't think our MX records would have to change with the ISP for our Domain.

I only have one NIC - so the CEICW only let's me choose the local router option not the broadband option.

My server is connected to a SOHO Firewall which is then connected to the ADSL router.

During initial setup of SBS2003 I followed the defaults and it created a domain called mycompany.local (the registered domain is actually my-company.com let's say.  The full computer name of my server became myserver.mycompany.local

So when it comes to the PUBLIC FQDN this is where I get confused.  I know the myserver.mycompany.local is an internal network thing so how can I tell what my PUBLIC FQDN is?

Sorry if I am not making much sense it's 2:30am here and I can't wrap my head around this.

All your assistance is really appreciated.


Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Your response makes total sense to me and I do understand how it can be confusing... no problem.

First, it matters NOT that your internal domain and external domain are different... the CEICW will take care of that.  Also, you will always find a "MORE INFORMATION" button on every wizard screen.  This button provides invaluable help info that can guide you should you get lost.

Here's what you need to do when you RE-run the CEICW (you can run that thing as often as you like, it just keeps fixing whatever it needs to):

1.  Make sure your router/firewall has a LAN IP address in the same subnet as your server so, it should be something like  If what you meant is that you have a FIREBOX SOHO router, then it doesn't have UPnP, so you need to manually configure the following ports to point to internally:

25 - SMTP
443 - HTTPS (for RWW and OWA)
444 - SharePoint
1723 - PPTP VPN
3389 - RDP for remote administration
4125 - Remote Web Workplace

If you have some other kind of router that does have UPnP, it should be enabled during the setup and can be disabled after for security reasons.  Having UPnP allows the SBS to automatically configure those ports.

Your router, I'm assuming is already making your connection to your ISP and is probably providing DHCP (although it's much better if you have the SBS do it... but leave that alone for now).  So it doesn't matter that the CEICW only gives you the router option... that's what you have.

2.  Enter your ISP's DNS servers as requested and the LAN IP of your router (if as I suggested above is right, then And tick the box that you only have one NIC so that you can be prompted to understand the rest of what I'm putting down in this post.  :-)

3.  On the web services screen, I suggest that you check all but the Business Web Site (port 80).

4.  Now, on the web server certificate you need to put your Public FQDN, OR your Public IP address if you don't have one registered.  I'd suggest that you use a registered domain name because that way users can remember how to access the server remotely (ie, http://server.domain.com/remote for Remote Web Workplace).  Wherever your DNS is hosted (usually your ISP or the registrar of your domain) is where your MX record is that points to your server.  You can just find out what that is by doing an nslookup on your PUBLIC (external) IP address not the internal one as you've stated above.  If it doesn't come back with anything, you don't have a PUBLIC FQDN so you'll have to use your IP address for now.

5.  On the next screens, you'll select USE Internet Email, USE DNS, and USE Exchange - delivered directly.

6.  On the Email Domain page, put in whatever is registered, ie, my-company.com.  Remember this does NOT matter that it's even close to what your internal domain is.  In my own system, I have a completely different domain name than my email domain.

7.  I'd suggest that you check the box to block attachments, and then click finish.  If you ever want to see the full settings of what you've done, just go to C:\Program Files\Microsoft Windows Small Business Server\Networking\ICW and you'll find a record of each time you've run the CEICW in both html and vbs formats.  (the vbs is in case you want to revert to those settings).

That should be all there is to it.

If you want to test your connection, go to http://dnsreport.com and use the box on the right to see how your email domain resolves.

Good Luck!


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jiggamooseAuthor Commented:
Thanks for all your help Jeff, I've got the situation all resolved!


Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Terrific!  Glad to help out.

Thank you so much for your clear answer TechSoEasy!!!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.