Sharing ADSL connection.

Hey guys,

I have a domain set up at home consisting of a Windows Server 2003 DC (running DHCP, DNS, AD) and about 5 WinXP machines. I have all of them connected to a Netgear switch. I HAD the switch connected to a Netgear router (which was connected to my ADSL modem)  but like with the many routers I had before, I wasn't happy with the performance (ie. slow internet speed, disconnects). I've decided to get rid of the router. My DC has 2 NICs and I currently have my ADSL modem plugged into 1, and the switch with the other PCs plugged into the other. What is the best way of "sharing" my ADSL connection, and how do I set it up?
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Um, your best bet is to use a router, lol.

ADSL has limited bandwidth which is more of a reason you are having slow speeds. I could be a jackass and tell you to get cable, it has more bandwidth, and is faster (depending on your area, and service provider of course. For the most part the statement is true though). You can use ICS through windows, but I don't recommend it for a 5 computer network.

So my answer?

By a new router. I never liked netgear, I've always been a Linksys man, which now merged with cisco. They put together some quality products, for cheap.

If you insist on using ICS, you can enable ICS through my network places. The easiest way might be by using the network wizard.
Luc FrankenEMEA Server EngineerCommented:
msabodachaAuthor Commented:
I went through 4 routers (2 netgear, 1 linksys, 1 d-link) and with all 4 I had the same problems, even when only 1 computer is using the internet. When I have the ADSL line connected directly to my DC the speed is constant.

I can't find ICS in network places...
Build an E-Commerce Site with Angular 5

Learn how to build an E-Commerce site with Angular 5, a JavaScript framework used by developers to build web, desktop, and mobile applications.

Did you search through the "Set up a home or small office network"? That's the easiest way to enable it.

Once you click that icon, it is self explantory, it guides you through sharing the connection, then it asks you to bridge connections. It's very easy.

Your computer will act as a gateway, the other computers need to put that computer's IP address as a gateway in TCP/IP Settings. Or you can just use the Set up a home or small office network wizard again, except this time the radio button they need to click is the "this computer connects through residential gateway...." etc etc.

Let me know if you need more help.
msabodachaAuthor Commented:
I'm running Windows Server 2003 and the only thing I have is the New Connection Wizard. When I launch it and select 'Set up an advanced connection' >> 'Accept incoming connections' >> the only connection device that is listed is Direct Parallel...
You are in the wrong place, that is the connection screen. You have it you just are having a hard time finding it.
msabodachaAuthor Commented:
Hmm, found this on Microsoft's site:

"Do not use ICS on a network that:

• Uses static IP addresses
• Has a Windows Server 2003 domain controller
• Uses other DNS servers, gateways, or DHCP servers

Because ICS creates a static IP address for your network adapter and allocates IP addresses to other computers on your network, you will lose your connection to the rest of the network if other network computers already provide those services. If one or more of these conditions exist in your network, you must use Windows Server 2003 NAT instead of ICS. For more information about NAT, see Windows Server 2003 Help."

I'll have to look into NATing.
Naser GabajE&P Senior Software SpecialistCommented:
Here is the link:

ICS in winxp and down level os, but for win2k, win2k3, use the integrated Routing & remote access, here is how:

I hope this help you out.

It's only saying that because it may create a duplicate IP address. You should be able to exclude IP addresses from your DHCP server.
the easest way is to config routing and remote acces in admin tools
i mean enable NAT
and on clinets give manual IP's as having same range u gave on servers nic card Internal network
use that ip as gateway and dns in clients
for example
server :
1st  NIC ===> ur ADSL IP
2nd NIC ===> ur internal net work IP
now config NAT and make 1st NIC as external Interface and 2nd as Internal Interface

IP address    ===> manually configured
getway add   ===>
DNS Address ===>

do same to all clients just change ther ips
msabodachaAuthor Commented:
Ok, when I ran the configuration I selected 'Network address translation' and selected the interface that connects to the internet.

I set my DHCP server scope options to assign the default gateway.

Unfortunately it's not working... any other advice?
msabodachaAuthor Commented:
I've since picked up a PIX 501 firewall and set it up on my LAN... works like a charm so I no longer need this...
PAQed with points (500) refunded

Community Support Moderator

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.