Exchange Email not receiving - "message was rejected due to the current administrative policy by the destination server" but none are in place.

I have just put in a brand new server running SBS 2003.  This isnt' my first.  My problem is with email.  We can send but not receive.  It's rejecting every email sent to it.  Emails will sit in the queue on the sending email server - I'm watching from my Exchange server for testing purposes.  We're sitting behind a PIX 501 and I've totally rebuilt it.  I have fixup protocol smtp turned off.  I can telnet to the mail server and it answers.  I can type a test email message through telnet and it will queue it.  HELP!  They are losing business even though it's over the New Year's weekend - I thought I would find the answer already here but it's not.  I've tried EVERYTHING I can think of.

Thanks - Sandi
sandibryantAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Chris StauntonCommented:
What SP are you running for Exchange?
Chris StauntonCommented:
Before I run off to my New Years Party... .Things to check if running SP2 for Exchange 2k3, go into the ESM and drill down to the Default SMTP Virtual Server | Right Click | Properties | click on the advanced button then edit, by default a bunch of filtering may be turned on that you might need to disable for the time being.  Getting your mail up is the most important thing at this moment I take it.  So uncheck all but Apply Recp Filter...

You will need to make sure that this filter is set up in your Global Settings Message Delivery properties...  Check the checkbox to filter out recipients that are not in the Directory.


Best of luck!

Chris
sandibryantAuthor Commented:
Thanks - I am running SP2, an the filtering is turned off for now.  And nothing is checked in the Global Settings - Message Delivery Properties.  Thanks!  Still need help.......
kristinawCommented:
do you have mx records set up for the domain? are they pointing to the right ip?

kris.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sandibryantAuthor Commented:
Well - I almost answered yes - but I went and tested them.  My ISP mispelled the domain name when they changed our IP on the MX record.  Nothing like double checking everyone - even if you trust them.  Thanks for your help!  Have a great New Year!  Sandi
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.