DansGuardian will not start with "error connecting to parent proxy" need help

I have just setup a new Fedora Core 4 Linux box with Squid and Dansguard.  These are new to me and I have followed what little documentation there is out there for this.  after setting the ACL's in squid and making a couple of changes to the dansguard.conf file, when I try to start dansguardian, I get the error stated above.  Any help on this would be greatly appreciated as I need to get this tested and fine tuned before next week.

chrismurrAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jar3817Commented:
did you start squid? did you grant localhost (127.0.0.1) access to squid?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
chrismurrAuthor Commented:
Here is the only thing I changed in the squid.conf file. I #'d out the recommended Access control settings and added mine after the acl CONNECT method CONNECT line:

#Recommended minimum configuration:
#acl all src 0.0.0.0/0.0.0.0
#acl manager proto cache_object
#acl localhost src 127.0.0.1/255.255.255.255
#acl to_localhost dst 127.0.0.0/8
#acl SSL_ports port 443 563
#acl Safe_ports port 80         # http
#acl Safe_ports port 21         # ftp
#acl Safe_ports port 443 563    # https, snews
#acl Safe_ports port 70         # gopher
#acl Safe_ports port 210                # wais
#acl Safe_ports port 1025-65535 # unregistered ports
#acl Safe_ports port 280                # http-mgmt
#acl Safe_ports port 488                # gss-http
#acl Safe_ports port 591                # filemaker
#acl Safe_ports port 777                # multiling http
acl CONNECT method CONNECT

acl localnet src 192.168.0.0/255.255.255.0
acl all src 192.168.0.0/255.255.255.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl SSL_ports port 443 563
http_access allow localnet
http_access allow localhost
http_access allow CONNECT SSL_ports
http_access deny all

#  TAG: http_access


I then started squid and it did not give me any errors.  
Tim_UtschigCommented:
Can you post your dansguardian.conf ?
chrismurrAuthor Commented:
Sorry gentlement, company scrapped that project.  here are some points for your efforts.

Thanks,

Chris
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.