BIND Kernel level errors

We're about to change our DNS system over from Win DNS to BIND. Our new DNS servers are finished, however, when going live these errors flood the log;

Feb  9 17:00:45 localhost named[1141]: socket.c:1120: unexpected error:
Feb  9 17:00:45 localhost named[1141]: internal_send: 217.xxx.xxx.xxx#4845: Invalid argument
Feb  9 17:00:45 localhost named[1141]: client 217.xxx.xxx.xxx#4845: error sending response: invalid file

I've found various posts on similar subjects, but none that fit (seem to point to the port used by DNS clients). This is URGENT as the system MUST go live today, reflected in point value.
Any feedback will be very welcome.
Thanks.
demonzzzAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

pablouruguayCommented:
which version of bind that you use?
tha stable version is http://www.isc.org/sw/dl/?pkg=bind9/9.3.2/bind-9.3.2.tar.gz&name=BIND%209.3.2

demonzzzAuthor Commented:
bind 9.3.1-14_FC4 which is stable release :/
pablouruguayCommented:
is the release without errors... please download this
ftp://fr.rpmfind.net/linux/fedora/core/development/i386/Fedora/RPMS/bind-9.3.2-4.i386.rpm

and do this
rpm -U bind-9.3.2-4.i386.rpm

this solve your problem..........

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CompTIA Network+

Prepare for the CompTIA Network+ exam by learning how to troubleshoot, configure, and manage both wired and wireless networks.

pablouruguayCommented:
oh/

and do that

service named restart
demonzzzAuthor Commented:
Right, ok.
This won't break my chroot or change any of my conf/zone's?
pablouruguayCommented:
supouse not. but backup the /var/named folder in other and /etc/named.conf and replace when you upgrade. for example

mkdir /home/named.backup
cp /var/named -Rf /home/named.backup
cp /etc/named.conf /home/named.backup
rpm -U bind-9.3.2-4.i386.rpm
cp /home/named.backup/named /var -Rf
cp -Rf /home/named.backup/named.conf /etc
service named restart

and that all.
Tim_UtschigCommented:
Is SELinux enabled?   (check /etc/selinux/config)
demonzzzAuthor Commented:
No SELinux.
I'll try the upgrade on Monday :)
demonzzzAuthor Commented:
Grrrr feckin deps!!
Wont let me install BIND because it needs openssl-0.9.8a, and won't let me upgrade openssl because just about everything has a dep linked to libssl.so.5 or libcrypto.so.5 (openssl-0.9.7f currently installed)

(and glibc is currently 2.3 but needs 2.4)

Whats the best way to go about this? I played "chase the deps" before and it's NOT fun!
pablouruguayCommented:
yep. you need to do that.... upgrade all package... or you can try

yum update bind

with yum all dependencies are satiesfied automagically with no human interact.

Tim_UtschigCommented:
9.3.1-14_FC4 is the latest Fedora update for the bind package.

And the latest FC4 update for openssl is still using version 0.9.7f.

You can compile from source like pablouruguay's first post suggested...

    service named stop
    yum install gcc glibc-devel openssl-devel glibc-headers glibc-kernheaders tetex-latex libxml2
    mkdir ~/install
    cd ~/install/
    # ftp.isc.org gives "Network is unreachable.", so use this mirror:
    wget http://ftp.bind.com/pub/bind9/9.3.2/bind-9.3.2.tar.gz
    tar zxf bind-9.3.2.tar.gz
    cd bind-9.3.2/
    perl -pi -e 's,/run/,/run/named/,g' ./bin/named/include/named/globals.h
    ./configure 2>&1 | tee log-configure
    make -j4 2>&1 | tee log-make
    su -c 'make install' 2>&1 | tee log-make_install
    su -
    cp -a /etc/init.d/named /etc/init.d/named.orig
    perl -pi -e 's,/usr/sbin,/usr/local/sbin,g' /etc/init.d/named
    service named start
demonzzzAuthor Commented:
Yeah i think im gonna have to go down that route. do I need any args to "make install" or something to installe to chroot?
Tim_UtschigCommented:
> do I need any args to "make install" or something to installe to chroot?

No.  Chroot setup is done after insallation.
demonzzzAuthor Commented:
Have installed and re-chroot'd. Testing after lunch :)
demonzzzAuthor Commented:
Sorry for stringing this thread on. Shoudl be ready to test tommorow.
Tim_UtschigCommented:
Not a problem.  Take your time.
demonzzzAuthor Commented:
My delay in responding was explained in an earlier post. thread NOT abandoned.
Thanks for your help guys, we now have no kernel errors, upgrading to the latest stable build sorted it.
Cyclops3590Sr Software EngineerCommented:
demonzzz,

Please remember that you need to update the post, not just as too if you are going to be away for awhile, but what you're results were so the experts know if they need to give more suggestions or not.  This is why I chose Delete with no refund.  I felt you had abandoned the question by not updating your question as to your trying out the experts suggestions.  And since I couldn't determine that a solution was presented, I recommended what I did.

Also, thank you for accepting an answer to close out this question.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.