Presentation Server 4 "Printer Management" properties option is grayed out, auto-created printers not working

All my servers have the printer driver loaded, printer auto-creation is not working and I believe it is because the "Printer Management" properties is grayed out for some reason which I cant figure out.  I have already tried the steps below but I still think that because the properties option is grayed out there is something else work.   Anyone's help is greatly appreciated.   (FYI: I have a Metaframe XPe farm that works fine and am build this PS4 Farm)

1. In Citrix Connection Configuration double click the ICA listener port, Select the Client Settings button, and ensure "Connect client printers at logon" is checked.

2. Also, ensure that the following boxes are not checked under the Client Settings Area:

Disable Windows Client Printer Mapping
Disable Client LPT Mapping

Both of these settings prevent client printers from being autocreated on the system, and prohibit the client printer from being manually added during the session.

3. If "Inherent User Config" is checked in step 1, ensure that "connect client printers at logon" is selected in the UserConfig button for each user account within User Manager for Domains or the Environment Tab within Active Directory Users and Computers/Computer Management-Local Users and Groups.
LVL 1
GlobalFaxAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JeffPitschCommented:
PS4 printer management is controlled through Citrix polciies, did you configure any citrix policies to enable autocreation?

Jeff Pitsch
GlobalFaxAuthor Commented:
Yes, I actually create a policy, enabled "Auto-create all client printers" and applied the policy to "Servers" and selected all my farm servers.  Still get none of my wokrstation printers auto-created.  The only printer that shows up as an option is "ActiveTouch Document Loader".

JeffPitschCommented:
what happens if you choose to only use the UPD only?  What errors, if any, are in the event logs on the server?

Jeff Pitsch
Become a CompTIA Certified Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

GlobalFaxAuthor Commented:
If you are referring to "Use universal driver only" within the policy, I just set it and still the same.   Do I need to restart server or services?   I had this to "Not Configured" prior to.

I am seeing printer errors in application log.

Source: MetaframeEvents
Category: Printer Management
Event: 1116

Description:  Printer auto-creation failure.  Reason: AddPrinter() failed with status 0x704.  Then it has more about sessin, printer name, driver name, etc.

GlobalFaxAuthor Commented:
But these errors are there from last night and this morning, and probably before, I just cleaned out event logs recently.
JeffPitschCommented:
From Citrix support site:

Event ID 1116 Printer autocreation failure. Reason: AddPrinter() failed with status 0x704
http://support.citrix.com/article/CTX107445&searchID=15105337

Jeff Pitsch

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
GlobalFaxAuthor Commented:
THe following already existed on all my servers, I did not need to add it.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\Client Printer Port
Value = Driver
Data = cpmon.dll

Gary
GlobalFaxAuthor Commented:
Could this be a bug, I installed hotfix PSE400W2K3R01 on 1/5 and I see that cpmon.dll has a date of 11/29/2005, vile version 4.00.2250.   The original file date prior to hotfix is 8/4/2005 file version 4.00.2198.   I can't say that it worked before because this a new farm to replace my existing XPe farm and I jsut started my testing finding my printer issue.

Does the "properties" option in PS4 no longer exist, i.e. normally grayed out?

Thanks!

Gary
GlobalFaxAuthor Commented:
I copied the old cpmon.dll prior to that specific hotfix and my printers now show up!


Thanks for your guidance!
GlobalFaxAuthor Commented:
What about the grayed out properties of "Printer Management", is that normal and no way around it?
JeffPitschCommented:
You should not be able to get to printer management properties anymore.  Everything is controlled through Citrix policies now.

I'm glad you found the problem.  This may very well be a new issue.  Goodness knows citrix has had problems with their hotifxes of late.

Jeff Pitsch
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Fonts Typography

From novice to tech pro — start learning today.