We help IT Professionals succeed at work.

IIS Sub Authenticator Problem, Please help.

Notcon
Notcon asked
on
389 Views
Last Modified: 2007-12-19
Hi All,

I have read a few things on this IIS Sub Authentication error but nothing has been of any help to resolve the problem. We are running iis 6 on a windows 2003 server SP2 . There is roughly a 160 sites on this box to which i think the error is occuring in the event logs for each site (Although i haven't counted).

The error is:

The registry key for IIS subauthenticator is not configured correctly on local machine, the anonymous password sync feature is disabled.

Which i gather refers to iis 6 not using Anonymous authentication anymore, that's one thing i picked up in a forum but have disabled anonymouspaswordsync in the absutil.vbs file which is what i was told would fix this problem, it obviously didn't.

Any help on this matter would be fantastic.
Comment
Watch Question

Pete LongTechnical Architect
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
what error?

run secpol.msc make sure that the IUSR_servername and IWAM_servername has the right to "log on locally" (in computer config > local policies > seciruty > user rights assignment

also ensure thet these two users and the everyone group has the right to "access this machine from the network" then reboot

Author

Commented:
The error in the vent log is:

The registry key for IIS subauthenticator is not configured correctly on local machine, the anonymous password sync feature is disabled.


We use helm to add websites, i do'kw f hishas any impact on what your saying but in the iis > directory security > anonymouse access panel the username is something like: serverame\website.com where website.com is the first 20 characters of the website address. I don't know much at all about iis security but do know that this username is some times IUSR_servername.

I checked the user rights asignment we didn't set this server up but the details are there none the less however the details aren't the servername, for example my server is called: NETSER112 i have a IUSR_NETSER001 and IWAM_NETSERXXX exactly like that. I have tried to add the IUSR_servername and IWAM_servername but these accounts do not exist.

I don't want to do anything heavy incase i mess up the system (I'd be in trouble then), any other ideas???
CERTIFIED EXPERT
Top Expert 2006
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.