BusinessObjects Enterprise XI: List of values trim

Hi,

The list of values has a long list so records get trimmed off. Only partial records are shown in the list. I did changed the registry key to 0 on the server and on my machine but nothing happened, can anyone tell me why. Do we need to restart the machine for changes to happen? Thanks

from business objects knowledge base:

A registry sub key value of zero will return all List of Values' values.
====================

Registry Entry Information
-------------------------------
Subkey: HKEY_CURRENT_USER/Software/Business Objects/Suite 11.0/Crystal Reports/Database/QPMaxLOVSize
Type: DWORD
Default Value: 1000
ebi168Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Kurt ReinhardtSr. Business Intelligence Consultant/ArchitectCommented:
You may need to restart the BusinessObjects Enterprise XI servers.

Also, are you using the Advanced DHTML viewer?  Similar issues have occurred with it with past versions of Enterprise.  In this case, BusinessObjects recommends using either the ActiveX or Java Viewers.

~Kurt
ebi168Author Commented:
Just to be more precise, restart the machine or restart the BO services. I am not sure what viewer used, do you know how to check.
Kurt ReinhardtSr. Business Intelligence Consultant/ArchitectCommented:
I would first stop and restart the services.  You shouldn't need to reboot, but if you decide to do so, I would keep it for last.

Unless you've locked down the viewer options, users can typically choose their own viewer.  The easiest way to check your viewer settings is to open Infoview, drill into the Crystal Report Preferences tab within Settings and see what it's set to.  Try the other viewers to see if you have the same issues.

~Kurt
ebi168Author Commented:
I just find the registry I should change is:

key HKEY_LOCAL_MACHINE\SOFTWARE\Business Objects\Suite 11.0\Crystal Reports\DatabaseOptions\LOV\MaxRowsetRecords

and set the value to the maximum number of values that you desire for your report.

The value of MaxRowsetRecords is 1000 by default so I changed it to a much larger value. Now the list gets extended but there are some alien numbers added to the list also, e.g. and still not all values are on the list. Do you know where the problem is.
Kurt ReinhardtSr. Business Intelligence Consultant/ArchitectCommented:
I would opine that it's not very good report design to allow a user to select from more than 100 options, much less >1000.  Performance can suffer and it's too easy to mess up.  If anything, since you're using Crystal Reports XI, I would take advantage of Cascading parameters to limit the number of list values based upon hierarchical criteria.

~Kurt

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Crystal Reports

From novice to tech pro — start learning today.