We help IT Professionals succeed at work.

Unable to launch a published application

richard_west
richard_west asked
on
3,196 Views
Last Modified: 2007-12-19
I have Presentation Server 4.0 and MS Terminal Services Licenseing installed on one server. On another server I have the Web Interface and Citrix Licensing installed. This is a brand new installation, and my first attempt at a Citrix install.

To start of simple I have created a single published App -- Calculater (calc.exe). I can see this published app when I log into the Web Interface or using the PN Agent. However, when I click on the app to launch I see a connection screen that stays up for about 30 seconds - which seems long to me -- then I receive an error window with the following message:

"Cannot connect to the Citrix MetaFram server. There is no Citrix MetaFrame server configured on the specified address"

I have reviewed the event viewer on the client, web server, and preentation server systems, but see nothing.

Can anyone help me figure out what the problem is?

Thanks...
Comment
Watch Question

Commented:
can you run "calc.exe" from the server?

I've never noticed this before (and don't know why) but I just checked on one of my 2003 servers and calc does not exist.. I even checked under /Windows/Sytem32/ and it's not there...

On another 2003 server it works fine so this may just be a very weird problem on this server I have.

Author

Commented:
Yes -- I have confirmed that I can run "calc.exe" from the Start --> Run command window in the Presentation server.
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Well --

Now whenever I try to go to the web page I receive a message telling me that me session has expired and I need to log in again. However, when I try to log in a gain I get the same message about my session being expired -- trapped in a circular error. This is something new -- but hopefully related to my original problem.

Any ideas? I have stopped and restarted the IIS service on the Web server with no change in behaviour.
Try clearing your cache.  What authentication mechanism do you have turned on?  If it's not on explicit give that a try.

Jeff Pitsch

Author

Commented:
Hmm...

I have tried loggin in Explicit and using pass through. I hae also tried this from several client workstations that have never connected to the web site before so I have removed the cache scenario as well.
What version of Web Interface are you using?  Would you check your farm configuration in WI to make sure all the settings are still correct as well.

Jeff Pitsch

Author

Commented:
I installed the Web Interface from the Citrix MetaFrame Components 4.0 CD -- so I am assuming it is verion 4.0, although I do not see this version number anywhere.

Can you tell me how to check the farm configuration settings?
Access Console, Web Interface site, manage farms.  

Jeff Pitsch

Author

Commented:
OK -- I uninstalled and reinstalled WI to make sure the setting were correct. I also see how to check these settings from within the Access Console.

OK, I am running verision 4.0.4.5083 of WI.

I am able to login to the WI now and see the published applications, however I'm still receiveing the same type of error from my original post.

Anything else I can check?
Did you save an ICA file to see what is being returned?  that's where we left off before.  ;)

Jeff Pitsch

Author

Commented:
Ok -- I think I see the problem.

I was able to save the ICA file to my desktop from the web site. When I look in it the server address is the wrong IP address. If I edit this I can double click on the .ICA file and .... drum roll ... the app launched!

The address that is in the ICA file, and what is displayed in the Access Console -> Presentation Server -> Farm -> Servers -> Server Name node  TCP Address is 169.254.33.89. This IP address does not exist on my network, and sounds like an address that would be automatically assigned to a disabled network port. The server that I am running Citrix on dos have 2 NIC ports, and right now I am only using one of them.

Is there a way that I can fix this? How can a make Citrix use one NIC port and ignore the other?
In the Citrix Connection configuration, you can assign ICA-TCP to a specific NIC.  or simply disable the other NIC if it's not in use.

Jeff Pitsch

Author

Commented:
It appears that in the x64 version of Presentation Server they have removed the Citrix Connection configuration app --

Quote:
Configuring ICA/TCP-IP Settings

The Citrix Connection Configuration utility is no longer included with this edition of Presentation Server. You can find the ICA configuration settings in the Terminal Services Configuration MMC snap-in (tscc.msc) under the ICA Settings and Environment tabs. [#105865]

-------

So I am looking in the MMC snap in, but do not see anything that will allow me to set, or change the IP address that is being used. I have already disabled the second NIC in windows but Citrix wants to keep issueing this address. Any other thoughts?

Author

Commented:
I have now even enabled the second network adapter, pluged it in to the network and allowed it to recieve a DHCP address.

However Citrix still wants to issue the invaild address as the server address.

Author

Commented:
In fact -- now with both NICs activated I see 2 invaild addresses being returned!

Is now see addresses:  169.254.33.89 and 169.254.119.229

In reality these addresses should be:  10.0.1.109 and 10.0.1.118

I have also preformed a system restart on the server.

Author

Commented:
Ok -- I have finnaly gotten it working.

The problem seems to occur if you allow the server to get it's address via DHCP. I know that this is not a good practice, and was not planing on using DHCP on this server in a production environment, however in the test lab I thought it would be ok -- I was wrong.

After mannually setting the IP address/subnet information the server appears to be working as expected.

Thanks Jeff for all of your help. I'm sure that I will have addtional questions in the future :-)
wow glad you found it.  I didn't realize DHCP would be that bad with Metaframe.  Glad you posted the feedback on that.

Jeff Pitsch
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.