FRS Fails To Replicate Domain Folders

Hi All


Here is the error message I am getting on my 2nd Domain Controller:


The File Replication Service is having trouble enabling replication from DC1 to DC2 for c:\windows\sysvol\domain using the DNS name DC1.Domain.com. FRS will keep retrying.
 Following are some of the reasons you would see this warning.
 
 [1] FRS can not correctly resolve the DNS name DC1.Domain.com from this computer.
 [2] FRS is not running on DC1.Domain.com.
 [3] The topology information in the Active Directory for this replica has not yet replicated to all the Domain Controllers.
 
 This event log message will appear once per connection, After the problem is fixed you will see another event log message indicating that the connection has been established.

For more information, see Help and Support Center at



I have edited the host file on both DC's to verify that it is not a DNS problem...
I recently took a DC offline DC0. Before I took DC0 offline I moved all FSMO rules to DC1. And made DC1 the global catalog Server. About 3 days later I wanted to bring up DC2. However it tells me that replication is failing.
I have tried several things to fix problem but cant seem to get this one...
one idea I have is that the FSMO rules did not transfer correctly from DC0 to DC1 and now that problem is causing this problem   Any ideas? Thanks
LVL 2
DiabloMillinAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MazaraatCommented:
Make sure their time is in sync
cmd prompt ->net time \\DC1 /set /y

How do you have DNS configured for DC1 and DC2 on the NIC_tcpip properties and in DNS->forwarders?
MazaraatCommented:
Verify that DC1 has the FSMO roles if not seize them -->  http://support.microsoft.com/?id=324801

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MazaraatCommented:
I keep clicking submit before I'm finished, When you say you took them offline, did you run dcpromo first to remove them from the domain controllers?  If not you may want to demote them, then re promote them.....I had that same situation...after several days I finally demoted/promoted it and the problem was solved =)
DiabloMillinAuthor Commented:
Yes the times are in sync. I want to try and seize the roles this sunday just incase the worst happens I have a full backup with noone working. Yes I ran dcpromo and took them down that way. I also did a dcpromo on DC2 to take it offline then dcpromo and brought it back up. I will let you know if the FSMO rule thing works sunday when I try it.


Thanks for your help
MazaraatCommented:
Received no feedback on the suggested solution...  Have a good night =)
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.