Exchange 2003: unable to bind to the destination server in DNS

On my exchange server I have messages in the Queue going to the same location, the message I'm getting from Windows Exchange 2003 when I highlighe the messages in the queue is:

unable to bind to the destination server in DNS

Can anyone tell me how to resolve or if the problem is on the receiving end.

Thank you,
Dave
gdmalnerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

IdeasUnknownSystem AdministratorCommented:
Hi Malner!

There are several things that can be working here.

If you are using a smarthost it could be an authentication issue.  But since the post you gave us points toward you using DNS to send e-mail we will start there.

You need to make sure that each of your workstations and the exchange server all point to your INTERNAL DNS server.  Your DNS server should also point to ITSELF.  You should not be setting up DNS through your SMTP Virtual Server, although you can do this it is not necessarily an industry best practice.

On the DNS server you then setup forwarding.  To do this follow these steps.  I am assuming you are using Server 2003 on your DNS server.

1. On your DNS server go to "Start" then to "Run".
2. In the "Open" box type "dnsmgmt.msc" (without the quotes) and press the "Ok" button.
3. In the left pane under the "DNS" root container right click your DNS server and go to "Properties"
4. In the dialog that opens select the "Forwarders" tab which is the second one from the left on the bottom row of tabs.
5. In the top section titled "DNS Domain" select "All other DNS Domains".
6. In the bottom section titled "Selected domain's forwarder ip address list" enter the ip address of your ISP's DNS server(s) and press the "Add" button.
7. Press the "Ok" button to close the dialog box.
8. Close the DNS Manager MMC Snap-in.
9. Restart the "DNS Server" service on the DNS server, or any other DNS servers you changed these settings on.*
10. Restart the "DNS Client" service on the DNS server, or any other DNS servers you changed these settings on.*
11. Restart the "DNS Client" service on the Exchange server.*

If you have more than one DNS server you really should do this for all of them.

Also check out this article:

http://support.microsoft.com/kb/291382

*To restart a service:
1. Go to "Start" then "Run".
2. In the "Open" box type "services.msc" (without the quotes) and press the "Ok" button.
3. In the right pane, right click the service that you want to restart and select "Restart" from the context menu.
4. Once the services restart without error close the Services Manager MMC Snap-in.

This should solve your problem, but if not post back!

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Operating Systems

From novice to tech pro — start learning today.