cannot get Alsa to work

Debian 3.1. New install. Everything seems perfect except no sound from audigy soundcard.

When I run alsaconf, it detects the proper card, apparently, and when I OK out of alsaconf I get this.


# alsaconf
Unloading ALSA sound driver modules: snd-emu10k1 snd-pcm-oss snd-mixer-oss snd-hwdep snd-util-mem snd-ac97-codec snd-pcm snd-timer snd-rawmidi snd-seq-device snd-page-alloc.
Building card database...

Running update-modules...
depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-586tsc/updates/alsa/snd-pdaudiocf.o
depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-586tsc/updates/alsa/snd-vx-cs.o
depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-586tsc/updates/alsa/snd-vxp440.o
depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-586tsc/updates/alsa/snd-vxpocket.o
Loading driver...
Setting up ALSA...amixer: error while loading shared libraries: libasound.so.2: cannot open shared object file: No such file or directory
amixer: error while loading shared libraries: libasound.so.2: cannot open shared object file: No such file or directory
......


Outputs of dpkg and apt-get check


# dpkg -l alsa-utils libasound2
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name           Version        Description
+++-==============-==============-============================================
ii  alsa-utils     1.0.8-4        ALSA utilities
ii  libasound2     1.0.8-3        ALSA library


# apt-get check
Reading Package Lists... Done
Building Dependency Tree... Done

More info:


# cat /etc/debian_version
3.1

# find / -name libasound.so.2

(nothing found)

I finally removed all alsa packages, restarted and then:

I installed, via Synaptic: (per article at  http://xtronics.com/reference/Debian-sound.html)

      
            
      
alsa-base       ALSA driver configuration files
alsa-modules    ALSA driver modules
alsa-oss        ALSA OSS-compatibility library
alsa-source     ALSA driver sources
alsa-utils      ALSA utilities
alsamixergui    graphical soundcard mixer for ALSA soundcard driver
alsaplayer      PCM player designed for ALSA
alsaplayer-com  PCM player designed for ALSA (common files)
alsaplayer-gtk  PCM player designed for ALSA (GTK version)
alsaplayer-jack PCM player designed for ALSA (jack output module)
alsaplayer-oss  PCM player designed for ALSA (OSS output module)
snd-gtk-alsa    Sound file editor (GTK+ user interface)
vlc-plugin-alsa ALSA audio output plugin for VLC
      
            
      
alsaplayer-jack PCM player designed for ALSA (jack output module)
jack            Rip and encode CDs with one command
jackd           JACK Audio Connection Kit (server and example clients)

Then:

# lspci | grep audi

0000:03:0a.0 Multimedia audio controller: Creative Labs SB Audigy (rev 03)

I put  

jack -d alsa &

in my .bash_profile as the article suggests

but the one line in that article that doesn't make sense is:

"Get module-assistant and run it and select the audio card from the list (you can fix an error here by running dpkg-reconfigure alsa-source)"

when I run module-assistant, I don't see a place to select an audio card. I can get an overview of packages, update cached packages, prepare the system, Select source packages
....

I even install alsa-source again from module-assistant and it is already the latest source...already exists, not rebuilding.

But, I don't have libasound.so.2...

I'm at a loss? Any suggestions?
ssalter2004Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Tim_UtschigCommented:
> depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-586tsc/updates/alsa/snd-pdaudiocf.o
> depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-586tsc/updates/alsa/snd-vx-cs.o
> depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-586tsc/updates/alsa/snd-vxp440.o
> depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-586tsc/updates/alsa/snd-vxpocket.o

Try running:

    depmod -ae

which should show you what symbols are missing.

> Setting up ALSA...amixer: error while loading shared libraries: libasound.so.2: cannot open shared object file: No such file or directory

Is it possibly a dangling symlink?

    ls -l /usr/lib/libasound.so.2

The package libasound2 version 1.0.8-3 definitely does install the above symlink (to libasound.so.2.0.0):

    http://pdo.debian.net/cgi-bin/search_contents.pl?searchmode=filelist&word=libasound2&version=stable&arch=i386&page=1&number=50

If you have the file /usr/lib/libasound.so.2.0.0 then just create the symlink like it should have been automatically:

    ln -s libasound.so.2.0.0 /usr/lib/libasound.so.2
ssalter2004Author Commented:

# depmod -ae
depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-586tsc/updates/alsa/snd-pdaudiocf.o
depmod:         pcmcia_get_configuration_info_R8551fe3c
depmod:         pcmcia_deregister_client_R609d99de
depmod:         pcmcia_request_io_R32b53b24
depmod:         pcmcia_request_irq_Ra75d6fa4
depmod:         pcmcia_release_io_R1be3b3e4
depmod:         pcmcia_get_first_tuple_R440fbd7b
depmod:         pcmcia_release_irq_Rd440dd2b
depmod:         register_pccard_driver_R1c442d6c
depmod:         pcmcia_release_configuration_R6b0239db
depmod:         CardServices_Re4eef0a4
depmod:         pcmcia_get_tuple_data_Rc2131918
depmod:         pcmcia_request_configuration_Rcfd96880
depmod:         pcmcia_parse_tuple_Rbb8dd80b
depmod:         unregister_pccard_driver_Rdb348cd2
depmod:         pcmcia_register_client_R4605df71
depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-586tsc/updates/alsa/snd-vx-cs.o
depmod:         pcmcia_deregister_client_R609d99de
depmod:         pcmcia_request_io_R32b53b24
depmod:         pcmcia_request_irq_Ra75d6fa4
depmod:         pcmcia_release_io_R1be3b3e4
depmod:         pcmcia_get_first_tuple_R440fbd7b
depmod:         pcmcia_release_irq_Rd440dd2b
depmod:         pcmcia_release_configuration_R6b0239db
depmod:         CardServices_Re4eef0a4
depmod:         pcmcia_get_tuple_data_Rc2131918
depmod:         pcmcia_request_configuration_Rcfd96880
depmod:         pcmcia_parse_tuple_Rbb8dd80b
depmod:         pcmcia_register_client_R4605df71
depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-586tsc/updates/alsa/snd-vxp440.o
depmod:         register_pccard_driver_R1c442d6c
depmod:         CardServices_Re4eef0a4
depmod:         unregister_pccard_driver_Rdb348cd2
depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-586tsc/updates/alsa/snd-vxpocket.o
depmod:         register_pccard_driver_R1c442d6c
depmod:         CardServices_Re4eef0a4
depmod:         unregister_pccard_driver_Rdb348cd2




# ls -l /usr/lib/libasound.so.2
ls: /usr/lib/libasound.so.2: No such file or directory
ssalter2004Author Commented:
more info:

# locate libasound

/usr/lib/libasound.a
/usr/lib/libasound.la
/usr/lib/libasound.so
/usr/share/doc/libasound2
/usr/share/doc/libasound2/changelog.Debian.gz
/usr/share/doc/libasound2/copyright
/usr/share/doc/libasound2-dev
/usr/share/doc/libasound2-dev/changelog.Debian.gz
/usr/share/doc/libasound2-dev/copyright
/usr/share/doc/libasound2-dev/NOTES
/usr/share/doc/libasound2/examples
/usr/share/doc/libasound2/examples/asound.conf_dmix
/usr/share/doc/libasound2/NEWS.Debian.gz
/var/cache/apt/archives/libasound2-dev_1.0.8-3_i386.deb
/var/lib/dpkg/info/libasound2-dev.list
/var/lib/dpkg/info/libasound2-dev.md5sums
/var/lib/dpkg/info/libasound2.list
/var/lib/dpkg/info/libasound2.md5sums
/var/lib/dpkg/info/libasound2.postinst
/var/lib/dpkg/info/libasound2.postrm
/var/lib/dpkg/info/libasound2.shlibs
PMI ACP® Project Management

Prepare for the PMI Agile Certified Practitioner (PMI-ACP)® exam, which formally recognizes your knowledge of agile principles and your skill with agile techniques.

Tim_UtschigCommented:
Something is screwy in your installation of libasound2.   Try:

    apt-get install --reinstall libasound2

And check if that created the proper symlinks:

    dpkg -L libasound2 | fgrep .so

If not, and you still only have /usr/lib/libasound.so, then create a symlink to it:

    ln -s libasound.so /usr/lib/libasound.so.2

> depmod:         pcmcia_request_irq_Ra75d6fa4
> depmod:         pcmcia_release_io_R1be3b3e4

Use module-assistant to install pcmcia.
ssalter2004Author Commented:
ok! Libasound is there now, the apt-get install --reinstall did the trick.

I tried to install pcmcia with module-assistant and the Build fails,,.here's the log.

test ! -x /usr/bin/po2debconf || \                                         #
                                       │   (po2debconf debian/pcmcia-cs.templates > \                               ▒
                                       │     debian/pcmcia-cs.templates.merged && \                                 ▒
                                       │    po2debconf debian/pcmcia-modules.templates > \                          ▒
                                       │     debian/pcmcia-modules.templates.merged)                                ▒
                                       │ test -f man/pcmcia.5 -a -f debian/rules                                    ▒
                                       │ test ! -x Buildlinks || ./Buildlinks .                                     ▒
                                       │ rm -f build build-modules                                                  ▒
                                       │ /usr/bin/make clean                                                        ▒
                                       │ make[1]: Entering directory `/usr/src/modules/pcmcia-cs'                   ▒
                                       │ make[2]: Entering directory `/usr/src/modules/pcmcia-cs/modules'           ▒
                                       │ rm -f core core.* *.o .*.o *.s *.a *~ .depend .depfiles/*.d                ▒
                                       │ make[2]: Leaving directory `/usr/src/modules/pcmcia-cs/modules'            ▒
                                       │ make[2]: Entering directory `/usr/src/modules/pcmcia-cs/clients'           ▒
                                       │ rm -f core core.* *.o .*.o *.s *.a *~ .depend .depfiles/*.d      
make[2]: Leaving directory `/usr/src/modules/pcmcia-cs/clients'            ▒
                                       │ make[2]: Entering directory `/usr/src/modules/pcmcia-cs/wireless'          ▒
                                       │ rm -f core core.* *.o .*.o *.s *.a *~ .depend .depfiles/*.d                #
                                       │ make[2]: Leaving directory `/usr/src/modules/pcmcia-cs/wireless'           ▒
                                       │ make[2]: Entering directory `/usr/src/modules/pcmcia-cs/cardmgr'           ▒
                                       │ rm -f core core.* *.o *.s *.a *~ .depend .depfiles/*.d                     ▒
                                       │ rm -f cardmgr cardctl  pcic_probe                                          ▒
                                       │ make[2]: Leaving directory `/usr/src/modules/pcmcia-cs/cardmgr'            ▒
                                       │ make[2]: Entering directory `/usr/src/modules/pcmcia-cs/flash'             ▒
                                       │ rm -f core core.* *.o *.s *.a *~ .depend .depfiles/*.d                     ▒
                                       │ rm -f ftl_format ftl_check                                                 ▒
                                       │ make[2]: Leaving directory `/usr/src/modules/pcmcia-cs/flash'              ▒
                                       │ make[2]: Entering directory `/usr/src/modules/pcmcia-cs/debug-tools'       ▒
                                       │ rm -f core core.* *.o *.s *.a *~ .depend .depfiles/*.d                     ▒
                                       │ rm -f dump_i365 dump_tcic dump_cis dump_cisreg pack_cis dump_exca lspnp  
make[2]: Leaving directory `/usr/src/modules/pcmcia-cs/debug-tools'        ▒
                                       │ make[2]: Entering directory `/usr/src/modules/pcmcia-cs/man'               ▒
                                       │ make[2]: Nothing to be done for `clean'.                                   ▒
                                       │ make[2]: Leaving directory `/usr/src/modules/pcmcia-cs/man'                ▒
                                       │ make[2]: Entering directory `/usr/src/modules/pcmcia-cs/etc'               ▒
                                       │ make[2]: Nothing to be done for `clean'.                                   #
                                       │ make[2]: Leaving directory `/usr/src/modules/pcmcia-cs/etc'                ▒
                                       │ rm -f .prereq.ok config.mk include/pcmcia/autoconf.h                       ▒
                                       │ rm -f include/linux/modversions.h                                          ▒
                                       │ make[1]: Leaving directory `/usr/src/modules/pcmcia-cs'                    ▒
                                       │ rm -f modules/linux/config.h modules/linux/version.h \                     ▒
                                       │   include/pcmcia/autoconf.h cardmgr/cardinfo cardmgr/scsi_info \           ▒
                                       │   debug-tools/dump_cis debug-tools/pack_cis config.out                     ▒
                                       │ rm -f debug-tools/dump_tcic debug-tools/dump_cardbus                       ▒
                                       │ rm -f -r */.depfiles    
rm -f -r *~ */*~ debian/tmp debian/tmp-modules debian/src debian/*~ \      ▒
                                       │   debian/files debian/control.tmp debian/substvars        \                ▒
                                       │   debian/KVERS debian/MODVERS                                              ▒
                                       │ cat debian/source.control debian/pcmcia-cs.control \                       ▒
                                       │   > debian/control                                                         ▒
                                       │ test -f man/pcmcia.5 -a -f debian/rules                                    ▒
                                       │ rm -f debian/files                                                         ▒
                                       │ for CONFLOC in ~/.kernel-pkg.conf /etc/kernel-pkg.conf; \                  #
                                       │ do test -f $CONFLOC && break; done; \                                      ▒
                                       │  /usr/bin/make -f debian/rules \                                           ▒
                                       │   MOD_DIR=/usr/src/linux CONFLOC=$CONFLOC \                                ▒
                                       │   clean-modules build-modules                                              ▒
                                       │ make[1]: Entering directory `/usr/src/modules/pcmcia-cs'                   ▒
                                       │ test -f man/pcmcia.5 -a -f debian/rules                                    ▒
                                       │ umask 022; /usr/bin/make DEB_MOD=yes clean  
make[3]: Entering directory `/usr/src/modules/pcmcia-cs/modules'           ▒
                                       │ rm -f core core.* *.o .*.o *.s *.a *~ .depend .depfiles/*.d                ▒
                                       │ make[3]: Leaving directory `/usr/src/modules/pcmcia-cs/modules'            ▒
                                       │ make[3]: Entering directory `/usr/src/modules/pcmcia-cs/clients'           ▒
                                       │ rm -f core core.* *.o .*.o *.s *.a *~ .depend .depfiles/*.d                ▒
                                       │ make[3]: Leaving directory `/usr/src/modules/pcmcia-cs/clients'            ▒
                                       │ make[3]: Entering directory `/usr/src/modules/pcmcia-cs/wireless'          ▒
                                       │ rm -f core core.* *.o .*.o *.s *.a *~ .depend .depfiles/*.d                ▒
                                       │ make[3]: Leaving directory `/usr/src/modules/pcmcia-cs/wireless'           ▒
                                       │ rm -f .prereq.ok config.mk include/pcmcia/autoconf.h                       #
                                       │ rm -f include/linux/modversions.h                                          ▒
                                       │ make[2]: Leaving directory `/usr/src/modules/pcmcia-cs'                    ▒
                                       │ rm -f build-modules                                                        ▒
                                       │ test ! -x Buildlinks || ./Buildlinks pcmcia-cs      
KVERS="2.4.27-2-586tsc" ./Configure -n --kernel="/usr/src/linux"           ▒
                                       │ --srctree \                                                                ▒
                                       │   --cardbus --sysv --rcdir=/etc --ucc=cc                                   ▒
                                       │                                                                            ▒
                                       │     -------- Linux PCMCIA Configuration Script --------                    ▒
                                       │                                                                            ▒
                                       │ The default responses for each question are correct for most users.        ▒
                                       │ Consult the PCMCIA-HOWTO for additional info about each option.            ▒
                                       │                                                                            ▒
                                       │ Linux kernel source directory [/usr/src/linux]                             ▒
                                       │ Linux source tree '/usr/src/linux' is incomplete or missing!               ▒
                                       │     The kernel header files are present, but not  the full source code.    ▒
                                       │     See the HOWTO for a list of FTP sites for current kernel sources.      ▒
                                       │                                                                            #
                                       │ Configuration failed.    
make[1]: *** [.prereq.ok] Error 1                                          ▒
                                       │ make[1]: Leaving directory `/usr/src/modules/pcmcia-cs'                    ▒
                                       │ make: *** [kdist_image] Error 2    

 
alsaconf still dumps this:

depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-586tsc/updates/alsa/snd-pdaudiocf.o
depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-586tsc/updates/alsa/snd-vx-cs.o
depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-586tsc/updates/alsa/snd-vxp440.o
depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-586tsc/updates/alsa/snd-vxpocket.o

ssalter2004Author Commented:
ok, after reading a post somewhere else, I removed those files  and alsaconf works fine with no errors...but still no sound.  *sigh*

I ran alsamixer and turned on almost everything, did an alsactl store after
Tim_UtschigCommented:
> ok, after reading a post somewhere else, I removed those files  and alsaconf works fine with no errors...but still no sound.  *sigh*
> I ran alsamixer and turned on almost everything, did an alsactl store after

What is the output this command?:

    aplay -l

If there is more than one card listed, then try alsamixer on an alternate one, e.g:

    alsamixer -c1
ssalter2004Author Commented:
After enabling pcmcia, things got ugly. Whenver I restarted, just after Appletalk started, my screen would fill up with [<F88xxxxx>]  over and over and over...

So, I reinstalled...with Debian it is so easy.

I'm starting over. The only thing I have done is set my screen res by running   dpkg-reconfigure xserver-xfree  so it isn't the standard 800x600

I have no sound.

Should I install alsa or maybe I should un-install some package first?  I want to do this right to start with in the beginning. I think things got screwed up before because I tried too many different things.

What is my first step to determine why I don't have sound?


Tim_UtschigCommented:
> What is my first step to determine why I don't have sound?

Run "lsmod" to see if any sound modules are loaded.

If so, try the mixer settings.  Use aumix if it's an OSS driver, or alsamixer if it's an ALSA driver (snd-*).

If not, get the PCI ID for your soundcard using "lspci -n" (match up the first part with the output from "lspci") and do some Google searches to find out what driver supports it.  The PCI ID is two pairs of four hex digits separated by a colon, for example "8086:24c5".
Tim_UtschigCommented:
Let me know what the PCI ID is and I'll figure out what it'll take to get it going on Debian sarge.
ssalter2004Author Commented:
# lsmod
Module                  Size  Used by    Not tainted
soundcore               3268   0  (autoclean)
apm                     8428   1  (autoclean)
appletalk              17796  12  (autoclean)
parport_pc             19432   1  (autoclean)
lp                      5540   0  (autoclean)
parport                21608   1  (autoclean) [parport_pc lp]
af_packet              11048   1  (autoclean)
mousedev                3604   1
hid                    19076   0  (unused)
input                   3040   0  [mousedev hid]
usb-storage            54496   0  (unused)
emu10k1-gp              1128   0  (unused)
gameport                1388   0  [emu10k1-gp]
ohci1394               21648   0  (unused)
ieee1394              178724   0  [ohci1394]
ehci-hcd               14764   0  (unused)
usb-uhci               19504   0  (unused)
usbcore                52268   1  [hid usb-storage ehci-hcd usb-uhci]
ide-scsi                8272   0
e1000                  57676   1
sd_mod                 10764   0  (unused)
scsi_mod               86052   4  [usb-storage ide-scsi sd_mod]
ide-cd                 27072   0
cdrom                  26212   0  [ide-cd]
rtc                     5768   0  (autoclean)
ext3                   65388   1  (autoclean)
jbd                    34628   1  (autoclean) [ext3]
ide-detect               288   0  (autoclean) (unused)
piix                    7784   1  (autoclean)
ide-disk               12448   2  (autoclean)
ide-core               91832   2  (autoclean) [usb-storage ide-scsi ide-cd ide-d etect piix ide-disk]
unix                   12752 214  (autoclean)


aumix and alsamix aren't found so I'm assuming they weren't loaded in the initial install.

lspci gives several but the sound card is a  (rev 3) so I am assuming that one of these is the one.

0000:03:0a.0 0401: 1102:0004 (rev 03)
0000:03:0a.1 0980: 1102:7003 (rev 03)

hmm,, and  lspci | grep audi gives me

0000:03:0a.0 Multimedia audio controller: Creative Labs SB Audigy (rev 03)  so the bottom one must be it?

Do I need to install alsa/jack  or isapnp?


ssalter2004Author Commented:
Alright...I did the following, keeping notes of what I am doing as I go along this time.

in synaptic I installed

alsa-base (also installs alsa-utils)

still no sound and  alsaconf doesn't find anything

in synaptic I install  alsa-modules-2.4-386 (also installs alsa-modules-2.4.27-2-386)

now alsaconf finds the sound card correctly



I get the
 depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-386/updates/alsa/snd-pdaudiocf.o
 depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-386/updates/alsa/snd-vx-cs.o
 depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-386/updates/alsa/snd-vxp440.o
 depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-386/updates/alsa/snd-vxpocket.o
errors  when alsaconf exits. Not sure if I should blow those away like I did before or not.


I ran alsamixer, made sure Audigy/Analog digital output jack was toggled on...(was off before)
no sound still.

lsmod now shows much  more.


# lsmod
Module                  Size  Used by    Not tainted
snd-emu10k1            62308   0
snd-pcm-oss            34048   0  (unused)
snd-mixer-oss          11000   0  [snd-pcm-oss]
snd-hwdep               4128   0  [snd-emu10k1]
snd-util-mem            1056   0  [snd-emu10k1]
snd-ac97-codec         48280   0  [snd-emu10k1]
snd-pcm                50216   0  [snd-emu10k1 snd-pcm-oss snd-ac97-codec]
snd-timer              12548   0  [snd-emu10k1 snd-pcm]
snd-rawmidi            11552   0  [snd-emu10k1]
snd-seq-device          3588   0  [snd-emu10k1 snd-rawmidi]
snd                    28260   0  [snd-emu10k1 snd-pcm-oss snd-mixer-oss snd-hwdep snd-util-mem snd-ac97-codec snd-pcm snd-timer snd-rawmidi snd-seq-device]
soundcore               3268   8  [snd]
snd-page-alloc          4296   0  [snd-emu10k1 snd-mixer-oss snd-hwdep snd-pcm snd-timer snd-rawmidi snd-seq-device snd]
apm                     8428   1  (autoclean)
appletalk              17796  12  (autoclean)
parport_pc             19432   1  (autoclean)
lp                      5540   0  (autoclean)
parport                21608   1  (autoclean) [parport_pc lp]
af_packet              11048   1  (autoclean)
mousedev                3604   1
hid                    19076   0  (unused)
input                   3040   0  [mousedev hid]
usb-storage            54496   0  (unused)
emu10k1-gp              1128   0  (unused)
gameport                1388   0  [emu10k1-gp]
ohci1394               21648   0  (unused)
ieee1394              178724   0  [ohci1394]
ehci-hcd               14764   0  (unused)
usb-uhci               19504   0  (unused)
usbcore                52268   1  [hid usb-storage ehci-hcd usb-uhci]
ide-scsi                8272   0
e1000                  57676   1
sd_mod                 10764   0  (unused)
scsi_mod               86052   4  [usb-storage ide-scsi sd_mod]
ide-cd                 27072   0
cdrom                  26212   0  [ide-cd]
rtc                     5768   0  (autoclean)
ext3                   65388   1  (autoclean)
jbd                    34628   1  (autoclean) [ext3]
ide-detect               288   0  (autoclean) (unused)
piix                    7784   1  (autoclean)
ide-disk               12448   2  (autoclean)
ide-core               91832   2  (autoclean) [usb-storage ide-scsi ide-cd ide-detect piix ide-disk]
unix                   12752 235  (autoclean)


#aplay -l   now gives me this:

# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Audigy [Sound Blaster Audigy], device 0: emu10k1 [EMU10K1]
  Subdevices: 32/32
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
..
..
..
 Subdevice #31: subdevice #31
card 0: Audigy [Sound Blaster Audigy], device 2: emu10k1 efx [EMU10K1 EFX]


So...it appears my system is recognizing the sound card properly. I'm not sure about the unresolved symbols but I dont have the libasound problem  this time.

Before I do anything else, I'm going to wait and see if there is a response here...do some googling and think. :)

Thanks for all the help so far, Tim.
Tim_UtschigCommented:
> I get the
>  depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-386/updates/alsa/snd-pdaudiocf.o
>  depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-386/updates/alsa/snd-vx-cs.o
>  depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-386/updates/alsa/snd-vxp440.o
>  depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-386/updates/alsa/snd-vxpocket.o
> errors  when alsaconf exits. Not sure if I should blow those away like I did before or not.

I suppose you can safely ignore those since they're not needed for your soundcard.  It sure isn't pretty though.   Or you could try:

    apt-get install kernel-pcmcia-modules-`uname -r`

> # aplay -l
> **** List of PLAYBACK Hardware Devices ****
> card 0: Audigy [Sound Blaster Audigy], device 0: emu10k1 [EMU10K1]
>   Subdevices: 32/32

Ok looks good.  Now all that should be left is dealing with the mixer settings.  Sometimes this can be tricky because one little mixer control or a combination of mixer controls may effectively mute everything.  You should try playing a sound in a loop, such as:

   while sleep 0.2; do aplay /path/to/some/file.wav; done

and then run alsamixer from another terminal and start tweaking controls until you hear something.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ssalter2004Author Commented:
I did this:  apt-get install kernel-pcmcia-modules-`uname -r`    and I can now play .au files from the command line!  Much progress!  CD Player doesn't work but i'm going to close this question and award you the points now...if I can;'t get the CD sound working, I'll open another question.

Thanks, Tim.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.