Speed of 2 connections is different

Here is a picture of how my computers are networked.  My cable comes in in my basement.  There is a splitter - one end go to TVs, the other to a cable modem.  The cable modem is plugged into my VOIP router.  The VOIP router is plugged into my WiFi router.  I have two PCs plugged into the WiFi router.  Each is about 6 feet from it, and use cat5 cables that are about 6' long.  When I go to speed test sites, one computer gets about 6500 kbps, and the other gets about 2000 kbps.  I've tried using a different cable for the slower computer, but that made no difference.  Any ideas why it is slower?

Here's a sketch of the setup.

cable in (coax)       (BASEMENT)
   |
   |
   splitter----- TVs       (BASEMENT)
   |
   |
   cable modem       (BASEMENT)
   |
   | cat5 cable
   |
   VOIP router       (BASEMENT)
   |
   |cat5e
   |  
   WiFi Router       (OFFICE)
   |              |
   PC1          PC2

LVL 39
Adam314Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

masnrockCommented:
I'd change the setup if I were you:


coax in
    |
    |
    |
splitter ---- TVs
    |
    |
    |
modem
    |
    |
    |
Wi-Fi router--------- VoIP
    |          |
PC1          PC2

Why would I do this? The VoIP units will always prioritize VoIP traffic over all other traffic, and sometimes (hopefully not in your case) causes a ton of headaches with speed, especially with the phone in use. (I had initially done your setup when I initially got VoIP)

But in regard to your actual problem that you've listed, I would try making sure that the card's set to Full Duplex on the slower machine, just to reduce that possibility. Secondly, have you checked the machine for any weird processes running, spyware, etc.?
fm250Commented:
Hi Adam314,
It doesn't seem to be a network problem. To insure it is not a network problem you can witch cables and ports between PC1 and PC2. if that is true as I think then the problem would be in the pc itself. So First thing to check is spyware, that is the first thing I alwas find with slow PC's.
Here are some tools for you:

http://www.microsoft.com/downloads/details.aspx?FamilyId=321CD7A2-6A57-4C57-A8BD-DBF62EDA9671&displaylang=en

stinger is another good one:
http://vil.nai.com/vil/stinger/

others:
http://www.softpedia.com/get/Internet/Popup-Ad-Spyware-Blockers/HijackThis.shtml

you need to know what you are doing with this HijackThis
rsivanandanCommented:
Yes, switch the cables and see if the speeds switch too. If so then there is nothing wrong with the networking part. Then you can drill down on the machine.

Cheers,
Rajesh
Become a Certified Penetration Testing Engineer

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

RobArdillCommented:
Check that you haven't got a ethernet duplex miss-match for the slower PC. Duplex can be either Full, half or auto. Just set them both to auto if you can? If there's no way to change it on the router then it will be fixed to auto. Just make sure the duplex is set to auto on the PC end.

Duplex is found under the Network connection properties -> Configure -> Adanced tab.

Rob


 
miloudiCommented:
I would definitely go with what Masnrock has suggested in terms of VOIP setup because you are creating an unecessary bottleneck in yout network.
As far as the speed issue, duplex is a good think to check, spyware and viruses and also the type of NIC you have. Hardware can go bad and can give you such behavior.
I remember i had to set the duplex to 10Mbps/ half duplex on one of those old computers to work with very old TDS router.

Hope this helps.
Adam314Author Commented:
I set it up this way based on advice from others on this site when I first got the VOIP.  I would rather the phone traffic get priority when I'm on the phone, as I don't want the phone to have delay or sound choppy - and a slower internet when I'm on the phone isn't a concern.

I swithed the ports on the router for PC1 and PC2, and nothing changed.  I check for spyware and virus... only minor things like cookies were found.  Removed them, and no change.

I'm using windows 2000.  In the advanced tab, I had these properties and settings:
  DelayTime            0
  MediaType           Auto_Config  
      (Other options were: 100BaseTX, 100BaseTX Full_Duplex, 10BaseT, 10BaseT Full_Duplex)
  NetworkAddress    Not Present
masnrockCommented:
As long as you're aware of the setup's potential pitfalls, that's fine. I have VOIP myself, and get relatively few bad moments except when my cable company wants to suck.

For MediaType, I'd try 100BaseTX Full_Duplex. After that, you can try 10BaseT (this is half-duplex) as miloudi mentioned. The first one will have the potential to increase the speed, where as the latter can sometimes be better in troubleshooting.

While I doubt this is affecting much, check the Power Management tab's settings and make sure that the machine is not allowed to turn off the device to save power. (This will sometimes just cause the card to act funny, but that's usually noted by a lack of connectivity)

These are all making the assumption your machine is clean of spyware, viruses, etc.
Adam314Author Commented:
I tried 100BaseTX Full_Duplex, and 10BaseT.  no change with either of them.

I also disabled the turn device off to save power.  No change.
RobArdillCommented:
Run up perfmon and add the NIC counters. See if you getting excessive Network errors on the trouble interface. The error count should be very low on a switched port. <5 perminute.


Too many errors can indicate a band component in the network. ie bad cable, bad nic, fault switch port.

Rob
miloudiCommented:


What about the NICS. WHat brands are they?
Adam314Author Commented:
The router is Linksys WRT54G and the NIC is built in to the motherboard.  Device manager says it is "SiS".  

In perfmon, I looked that the "Network Interface" device, these properties:  Packets Outbound Errors and Packets Received Errors.  The errors were steady at 0.
RobArdillCommented:
Was the perfmon test under load, or just normal conditions. Sometime errors only show under load. Like a big download.

SiS chipset aren't the best. It's would be the first time I've seen problems, related to driver quality. :)  I'd make sure you have the latest NIC driver installed. Is the Nic a SiS900 series?

Rob
Adam314Author Commented:
For perfmon, I did both with normal browsing, and with a speedtest (from broadbandreports.com) - which dowloads/uploads large amounts of data, and measures speed.  Errors were at 0 for both.

In device manager, the NIC is called "SiS 900 PCI Fast Ethernet Adapter".  I'll look around and see if I can find a newer driver.
RobArdillCommented:
Good. No errors is a sign the network hardware is okay.

You can focus you efforts now at a software fault. Start with the driver update and disable any firewall or anti virus programs running.

BTW how are you measuring the speed?

Rob
Adam314Author Commented:
I downloaded the latest driver, and no change.

I'm measuring speed using the speed test at broadbandreports.com  (aka dslreports.com)
http://www.dslreports.com/stest

I've tried several servers on both computers.  PC1 is consistently around 6000-6500, PC2 is around 1800-2100.

Is there another way to measure speed?  Between the two computers maybe?
RobArdillCommented:
Probably not the best test as there too many varibles.

You probably want to test locally first.

If you trasfer a file from one PC to the other, what speed do you get? Just copy a large file each way and count the seconds it takes.

Rob
IanThCommented:
have you tried removing the network adapter from the faulty pc by removing it from device management and then let the pc plug and play it again. It could be down to badly configured routing table and a re plug and play may sort that out
Adam314Author Commented:
I removed the device from device manager, and rebooted.  It was there when I rebooted.  I ran the same speed test as before, and no change.  I'll try coping a big file from the two computers and see what I get with that.

Should I just use windows explorer to copy the file?  Or use FTP?
RobArdillCommented:
ftp would be better as it gives you the actual rate and time taken at the end of the transfer.

Rob
Adam314Author Commented:
I setup an FTP server on PC2 (the slower connection), and using an FTP client on PC1 (the faster connection), get/put a file.

On PC1 downloading (PC2 -> PC1):  11288 KB/s
On PC1 uploading (PC1 -> PC2): 3814 KB/s

The file I used was about 8 MB.
RobArdillCommented:
Good. The problem is local to PC2 and not the cable modem or anything else.

on PC2 test the loopback speed. PC2 ->PC2
Adam314Author Commented:
Would I do that with FTP also?  FTP to 127.0.0.1, or to it 192.168.x.x address (the one it gets from the router)?
Adam314Author Commented:
Okay, I tried it with FTPing to the same computer.  I did a get and put, and used both IP addresses.  I did each twice.  Here are the results:


Using 127.0.0.1
   get: 3717 KB/s        3796 KB/s
   put: 4499 KB/s        4461 KB/s


Using 192.168.1.100
   get: 3796 KB/s        3744 KB/s
   put: 4461 KB/s        4461 KB/s
RobArdillCommented:
That definitely confirm the problem is software related an not HW.

What specs are the PC's? You might find it probably a limitation of the PC. 4MB/s is about 50% of a 100MB link. The speed over the LAN is no different to the speed of a local copy.

Rob
 
Adam314Author Commented:
It is a pentium 4, 2.4 GHz.  512 MB ram.  Gigabyte motherboard with SiS 661 FX chipset.  Onboard network card.

Windows 2000, service pack 4.
RobArdillCommented:
And what's PC1's spec?

SiS chipsest aren't really great performers but I would expect something better than the above.

Rob
Adam314Author Commented:
PC1 is a Pentium 4, 2GHz, 1GB RAM.  Dell, not sure on chipset.

Windows XP Pro, SP1.
RobArdillCommented:
I'm of the opinion that it most probably a HW limitation your hitting.

Check that your running the latest chipset drivers also.

The only way your going to determine the exact fault is to do a fresh install. That will eliminate any possible software settings. Alternative DL one of the linux live CD's like Ubuntu and do an ftp test with it.

Rob
adam20Commented:
Hi Adam314.
I would suggest going to http://www.speedguide.net/ and downloading the Windows 2000 receive window tweak. It is possible that your receive window is not set to an optimal value.
Rob's suggestion to test with a Linux distro would also determine if it is a registry issue in Windows or HW related at the NIC or chipset.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Adam314Author Commented:
Sorry for the delay... was away for a few days.

I'll download Ubuntu and give that a try.  I'll post the results, but probably won't get to it until weekend.


I went to the speedguide.net site, and looked for the win2k receive window tweak.  I saw some recommendations on registry settings, but didn't see a tool to help in setting them.  I can edit the registry manually, and check that my settings are as recommended.... but was there a tool that you know of?

Thanks for the continued help!!!
adam20Commented:
Hi there.
Since I have the tweaks already, I decided to post them to my web site to make it easier.
The following files are in zip format and you need to unzip them before using them. You can use the built-in zip folder manager in XP or get Winzip at http://www.winzip.com/

once the files are unzipped, all you do is double-click on the .reg file. Click ok or yes to import the registry values. I can't remember if it is ok or yes.

The following file will set your TCP settings to their optimal values, according to SpeedGuide.net
http://www.adamm.ca/sguide_tweak_2k.zip
The following file will reset the TCP settings back to their defaults:
http://www.adamm.ca/sguide_default_2k.zip

I hope this helps.

Adam
Adam314Author Commented:
I downloaded ubuntu, and ran a few speed tests. The one I ran before required java, and I couldn't figure out how to install java in ubuntu, so I used two different ones.  Here are my results:
cnet.com:  3100
TestMy.net:  6800

Running the same under windows, I get:
cnet.com:  2150
TestMy.net:  2440

Next, I'm going to check the settings as suggested by adam20.
RobArdillCommented:
The tweaks will probably heap, but not the the degree of 2x or more.

It definitely looks like its a software issue with the above results. Either a setting (reg) or a bad driver under windows.


My recommendation is to:

1. Get another NIC, set that up and do the above test to see if it improves performance.

2. Resetup Windows. Backup your old install. Just reinstall windows. Test. If it works, then resinstall all your apps and games etc. If it does make any difference, then it most probably a bad driver you're using. Restore your windows backup and test some older versions of the drivers (chipset and Nic)  

Rob
x_X_x_X_xCommented:
Yeah I would focus on MTU settings of the slow pc try dslreports.com for a quick test that can be performed from dos.
Adam314Author Commented:
I know it's been a really long time since you posted your last comments - I'm sorry it took so long to get back to you.

Anyways... I've tried the registry tweaks as recommended, and that seems to have fixed the problem.  Don't know why the settings weren't correct to begin with, but it works now.


Thanks to everyone who helped.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Broadband

From novice to tech pro — start learning today.