Small Business Server 2003 can't ping local IP addresses


I'm trying to set up and run SBS 2003 on my local network, which consists of only 3 or 4 computers apart from the one SBS is running on. At one point, after installing SBS for the first time, everything was working fine, and I was continuing to make changes to settings. Apparently I did something at some point, and now SBS can't connect to anything.

I have a D-Link router at I have my main machine at SBS is set up currently at -- that IP address is explicitly set (not DHCP). SBS can't ping or, or any other local computer -- but it CAN ping itself, by the IP address or the computer name, or localhost. It also can't ping anything on the internet, by hostname nor IP.

The other weird thing is that I can ping SBS either by hostname or by IP from my other local machines -- and I can also use Remote Desktop, etc. So everything else knows where SBS is -- which I would think means it's on the network just fine -- but SBS can't see anything else.

I don't know if it has to do with something simple in the domain setup, or if it's only seeing machines in its domain, or if it's something else in Active Directory, or what. Any help would be greatly appreciated. This is driving me nuts.

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Go to Control Panel -> Windows Firewall and disable it completely. Your D-Link Router has a firewall, too. Then try to access the computers again.
ProphasiAuthor Commented:
allocationerror -

Thanks for the advice -- Windows Firewall was in fact on, but turning it off didn't SEEM to help, although something is different now.

The difference is that the SBS box can now ping my main Windows XP machine (, as well as my TeraStation (which runs Linux) and my Tivo (also Linux). I'm not sure what made this happen, since in the process of making the change you recommended, I also rebooted the SBS machine a couple times just for good measure.

The reasons I can't yet attribute it all to Windows Firewall are a) when I turn Firewall back on, I don't lose ping access to those machines again; and b) I still can't ping my router, at It's quite an intensely frustrating problem. In light of that, I'm adding more points to this.

Thanks again for your help so far.

ProphasiAuthor Commented:
Okay, figured this out. The D-Link router was configured with mac address filtering, and the SBS machine wasn't one of the allowed addresses. That's why it was able to ping everything except the router itself. Now that I removed the mac address filtering, SBS has full access to both the Internet and the local network.

I'm still not sure what was causing the initial problems of not being able to ping the other machines, but it doesn't seem to have been the firewall issue, since reinstating the firewall doesn't introduce any problems. It must have gotten taken care of when I was fiddling with other services, or perhaps due to the restart.

Thanks for the help all the same.

PAQed with points refunded (350)

Community Support Moderator

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.