.Navigate method isn't working

Experts,

I'm absolutely lost as to the current problem I've run into.  I have a AxWebBrowser.  It works fine, except that the .Navigate function only seems to work the first time that my from loads.  I initially call a sub call LoadData which tells the Browser to open a file.  Any subsequent calls to that function do not seem to get the browser to do anything!

Here is my code:

        If task.getInfo(CStr(cmbInventory.SelectedValue)) = True AndAlso bDoneLoad = True Then
            Try
                wbInfo.Navigate(getAppDir() & "Info\info.html#" & CStr(cmbInventory.SelectedValue))
                wbInfo.Update()
            Catch ex As Exception
                MessageBox.Show(ex.Message)
            End Try
        End If

A few notes, cause I'm sure you'll ask...  Stepping through the code, the wbInfo.Navigate gets executed, and no exception is raised.  This has always worked for me before.  All of a sudden today it quit working.  I didn't change any of the code!!

The only thing that I can think of is that I did install the new "Microsoft Expression Interactive Designer January 2006 CTP" today.  I'm not sure if that is interfering, but the code executes fine on other machines.

Has anyone run into this?

Any ideas?

Thanks,

Jake
LVL 14
jake072Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

melmersSenior Software Deveolper/ArchitectCommented:
Have you tried to uncomment the wbinfo.Update function ?
jake072Author Commented:
Yes

I had just added that in, in hopes that it would remedy the problem.

Jake
melmersSenior Software Deveolper/ArchitectCommented:
have you updated your Internetexplorer ?
OWASP: Threats Fundamentals

Learn the top ten threats that are present in modern web-application development and how to protect your business from them.

jake072Author Commented:
Yes, I updated to IE 7 Beta... But the problem didn't arise after that installation...

Jake
melmersSenior Software Deveolper/ArchitectCommented:
Have you updated your references to the ActiveX file?
jake072Author Commented:
I have a macros that updates the references, and I ran it...

Is there a manual way to update the references?  I tried removing the reference to SHDocVw, but then I couldn't figure out how to get the reference to AxSHDocVw back...

Thanks,

Jake
melmersSenior Software Deveolper/ArchitectCommented:
Hi Jake,

delete the Refrence from your Project and delete the file Interop.AxSHDoc... from you bin files.
Add the Referenc from your Add Reference Dialog or insert the WebBrowser Component from the
Form Components Toolbar of your Visual Studio
jake072Author Commented:
That still didn't change anything... And I've deleted everything that I'd installed since the problem started...

Does anyone else have any ideas?

Thanks,

Jake
jake072Author Commented:
Un-installing IE 7 fixed the problem.

Sorry for wasting your time :)

Jake
melmersSenior Software Deveolper/ArchitectCommented:
No Problem,

have no IE 7 installed.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Visual Basic.NET

From novice to tech pro — start learning today.