Server not found. Firefox can't find server....

Dear Sir/Madam,

I have perused this site ever so briefly, so I apologize should this issue be old hat.

I have a home network with a Linksys Wireless-G broadband router (Model No. WRT54G).  My internet connection is via satellite, and I have the router hard-lined into my desktop, which I'll denote as computer 'A'.  All the other computers (two desktops and two laptops) on the system have wireless-G adapters.  All the computers except my desktop, 'A', work flawlessly on-line.  What I mean by this is that there is never an issue with time-out errors or server not found problems.

I cannot say the same thing about my desktop.  Just about every time I try to acquire a webpage I receive the "Server not found.  Firefox can't find"...blah,blah page.  If I hit the "try again" button at the end of the message, the same page is instantly returned.  I receive similar results using Internet Explorer.  My only recourse is to use the cmd.exe: ipconfig/flushdns.  If I use this I usually acquire the page immediately or after two or three attempts.  I should say that there are times when I am able to go to several websites without the error; however, I receive the server not found page more than the website I am trying to visit.

I use TrendMicro's firewall and antivirus protection.  I don't know what more I should add - except that I am not overly computer savvy, especially with networks.  Hence, should you feel obliged to assist, assume you are talking to a child and please use small words.

Thank you for your time and assistance.

Sincerely,
Mr_Ubiquitous
Mr_UbiquitousAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

smiffy13Commented:
Sounds like something is corrupting your DNS. Next time the PC can't connect, can you try running ipconfig /displaydns on both your working wireless PC and your non-working wired PC and see what the differences are.

It may be worth running hijackthis: http://www.spywareinfo.com/~merijn/downloads.html run it and save a log file, then post the log file here: http://www.hijackthis.de/ for analysis.
smiffy13Commented:
Can you also check your TCP/IP settings and make sure they are the same as your working PC's, check both TCP/IP properties and "Advanced settings"
smiffy13Commented:
The more I look at this problem!! Can you look at your hosts file, you'll have to make sure your folder settings to "show hidden files & folders", the hosts file is located in windows/system32/drivers/etc, open the file with wordpad, there should be a bunch of coments and only 1 entry: 127.0.0.1     localhost. If you've got more entries then, chances are they've been put there by spyware and should be deleted.

Assuming theproblem is caused by spyware, I'd install and run Microsoft's Antispyware program and Adaware SE - both are free.
Expert Spotlight: Joe Anderson (DatabaseMX)

We’ve posted a new Expert Spotlight!  Joe Anderson (DatabaseMX) has been on Experts Exchange since 2006. Learn more about this database architect, guitar aficionado, and Microsoft MVP.

Mr_UbiquitousAuthor Commented:
Let me begin by thanking you for your replies, smiffy13.

Okay, working backwards, I looked at my hosts file and there is only the one entry: 127.0.0.1.  By-the-by I have been using Spybot, Ad-aware, and Microsoft's Antispyware program for a very long time.

I checked the TCP/IP settings on my desktop, computer 'A', and my laptop, which functions just fine on the internet.  Both are set to obtain an IP address automatically and obtain DNS server address automatically.  Under the advanced settings, they are set-up exactly the same under each of the tabs: IP Settings, DNS, WINS, and Options.  For the IP Settings tab, both computers are DCHP Enabled and the Automatic metric box is checked.  I don't know if it would benefit you to know what the settings are for the remaining tabs, so I will leave those out unless you specifically ask to see them.

I ran ipconfig/displaydns when the desktop was unsuccessful at locating the server for a page I was trying to upload.  Actually, let me back-up.  I first flushed the dns for ipconfig and then attempted to visit www.majorgeeks.com.  I immediately received the cannot find server page for my desktop, so I promptly ran the displaydns.  Then I did the same process for the laptop, which had no difficulty loading the majorgeeks site.  I haven't the foggiest idea of what I should be observing between the two.  The desktop only had a few entries:
1.0.0.127.in-addr.arpa
Record Name.................:1.0.0.127.in-addr.arpa.
Record Type..................:12
Time to Live...................:446880
Data Length....................:4
Section..........................:Answer
PTR Record....................:localhost

www.majorgeeks.com
No records of type AAAA

www.majorgeeks.com
No records of type A

localhost
Record Name.................:localhost
Record Type..................:1
Time to Live...................:446880
Data Length...................:4
Section..........................:Answer
PTR Record....................:127.0.0.1

The laptops output is far too long to list; however, it too has the 1.0.0.127.in-addr.arpa heading, which is the same as for the desktop - except in the Time to Live, which is 603281 for the laptop versus 446880 for the desktop.  The same applies for the localhost listing, which is different in the Time to Live listing with the same values.  I don't know if any of this helps.

I will have a look at the hijackthis site and see what they have to say.  In the meantime, should you need further information, I will be happy to provide it.

Again, thank you for your assistance with this matter.
smiffy13Commented:
I'm not sure what I expected to see between the 2 dns files either, except I was hoping to find an entry there that looked suspicious, like an entry for majorgeeks with an incorrect ip address. I don't think the "time to Live" differences are important, they only indicate when the entry should be refreshed by the system. What happens if you ping www.majorgeeks.com?, mine times out - the majorgeeks site doesn't allow you to ping it, but it does reveal the ip address: 67.19.72.101, can you access majorgeeks if you put 67.19.72.101 in the Firefox address box?

There was a similar problem here: http://www.experts-exchange.com/Networking/Q_20793845.html This turned out to be a rogue hosts file. Can you do a search for host files on your PC to make sure you don't have the same issue.

Assuming it is a bad entry in your DNS cache, I guess it wouldn't harm anything if you were to do a flushdns on your laptop, so that you've got a similar cache to compare to.
Mr_UbiquitousAuthor Commented:
Okay, so I placed 67.19.72.101 into the the Firefox address box, and I was immediately taken to the majorgeeks website - they have some excellent downloads.  Also, I read the thread  you referenced, and I don't quite understand everything that was going on; however, I used the start > search command to look for hosts folders and found a couple:

c:\windows\system32\drivers\etc
c:\cygwin\etc   (this is just a shortcut to the above folder)

As I noted in my prior email, the only entry in the hosts files is 127.0.0.1.

Lastly, when I attempted to contact majorgeeks using both the desktop and laptop, I flushed the dns just prior to hitting "go".  So, I believe I had similar cache with which to compare.

smiffy13, thank you for your continued assistance with my issue.  If you should have any other thoughts or need further information, please let me know.  Oh, one last, last thing is that I ran hijackthis and found one item that was suspect: RSEDNClient.exe, which is a mechanism used by web sites to allow one to download from those sites quicker.  It was tagged as "Nasty," so I removed it.  Other than that executable, the rest were "Safe" or "Unknown" and for the unknown ones I believe I know what they are.
smiffy13Commented:
I think that the fact that you can connect to majorgeeks by ip address continues to point to a DNS issue.

It may be a long shot but you could try running the XP Winsock fix: http://www.softpedia.com/progDownload/WinSockFix-Download-15337.html 

If that didn't fix it, try:

Start > Run > type in cmd and hit enter.

type ipconfig /all [enter]  Does it list a DNS server?  Can you run the same commands on a laptop, is the same DNS server listed?

Mr_UbiquitousAuthor Commented:
I didn't have much time before school today to address the suggestions you provided.  A quick scan of the ipconfig/all demonstrated that both the desktop and laptop had the same DNS Server; however, there were three extra entries in the desktop's DNS Server list.  I apologize, but I cannot recall exactly what they were - I will let you know when I arrive home later this evening.  I did not have time to download the XP Winsock fix, so I will do that upon my arrival home.  Thanks as always for the suggestions and support.
Mr_UbiquitousAuthor Commented:
Strange.  I downloaded the XP Winsock fix and executed the program.  Now my desktop's internet connection is solid.  I have been visiting sites that always gave me the server cannot be found error and now, well I actually receive the page for which I was looking.  I have received an abnormally large number of time out errors but that could just be the loss of bandwith from the other users on the network.

Now the strange part is that earlier this morning when I did the ipconfig/all command, I was given the DNS Servers as 6#.##.#.#, which was the same one the laptop had but there were three others listed by the desktop.  I can't remember what they were, something of the form of fff0:....:%11, fff0:....:%12, and fff0:....:%13.  Now that I've run the XP Winsock fix where the other three DNS Servers were listed are now just three question marks.  Also of interest is the existence of a listing after the Ethernet adapter Local Area Connection listing: Tunnel adapter Teredo Tunneling Pseudo-Interface (this listing was there prior to the execution of the fix, I just find its existence interesting).  In place of a Physical Address is a string of FF's, the IP Address is a question mark, and there is no value given for the Default Gateway.  Any ideas of what the Tunnel adapter Teredo Tunneling Pseudo-Interface is or why the DNS Servers values switched after running XP Winsock fix?

Actually, I don't mean to burden you with further enquiries considering you have spent so much time solving my issue; however, should you have a spare moment to address the last question I asked, I would greatly appreciate it.  Also, smiffy13, how do you receive credit for solving my dilemma?

I truly appreciate all the assistance and time you provided me.

Best wishes,
Mr_Ubiquitous
smiffy13Commented:
Hmm - well it's great to hear that the fix seems to have fixed the problem.

The winsock fix reset's corrupted or missing registry entries used for your internet connection. The fact that it worked implied that you have had spyware on this PC that corrupted the registry entries in the first place. The DNS server entries that are now missing implies to me that the winsock fix has cleared registry entries but hasn't deleted them, therefore you've now got 3 invalid DNS entries. I suspect that the IP addresses that were there were causing your DNS lookup for majorgeeks to fail. One way to remove these entries would be to edit the registry, find these entries and delete them, however, this course could also make windows unusable. A sure way to fix it properly would be to clean re-install windows. You could also try a registry cleaner program that may fix it, but once again, if it corrupts your registry then you could face re-installing windows. I've used Registry Mechanic and found it quite good, but it's not free, and there's no guarantee's that it'll fix this problem. I think you download and do a scan for free: http://www.pctools.com/ If it finds entries that look like the invalid entries then you may want to stump up the $29.95.

The Teredo tunnelling adapter is a weird one, it's installed by Microsoft to facilitate host-to-host tunnelling, full description here: http://www.microsoft.com/technet/prodtechnol/winxppro/maintain/teredo.mspx I don't have it installed on any of my PC's, but then I don't use host-to-host comms. If you use tunnelling to get through your router's firewall then it could have been installed as part of that. I see from a Google seach, a few people have this adapter installed and have been advised to remove it. I can't answer whether you need it or not, you may have installed something that uses it.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
foadCommented:
Also, smiffy13, how do you receive credit for solving my dilemma?

on his reply, there should be a link saying "accept answer", once you click this, the questions points will get awarded to him.
Mr_UbiquitousAuthor Commented:
Thanks again for the information, smiffy13.  You are a wealth of information, and I have learned quite a bit with your assistance.  I know that I do not want to delete the registry entries, so I will look into Registry Mechanic.  It probably wouldn't hurt to do a clean re-install of windows, regardless.  I will need to research the Teredo tunnelling adapter before I determine whether it stays or go.

Thanks for the information, foad.

Again, smiffy13, I greatly appreciate all the time and assistance you provided.  Good luck with other folks' issues.

Best wishes,
Mr_Ubiquitous
smiffy13Commented:
Thanks Mr_Ubiquitous
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.