Deploying DirectX 9.0c with GPO

Hello,


I'm trying to figure out a way I could deploy DirectX 9.0c using the software installation option of active directory.

Since DirectX 9.0c is not available in .msi format, I tried doing a package.  I used a clean WinXP SP1 workstation and WinInstall LE 2003.  The packaging went fine but when I try to install it, I get at least 50 of the following event in the event viewer:

Source: MsiInstaller
Type: Error
EventID: 11931

Description: Product: DirectX 9.0c -- Info 1931. The Windows Installer service cannot update the system file C:\WINDOWS\System32\dpnhupnp.dll because the file is protected by Windows.  You may need to update your operating system for this program to work correctly. Package version: 5.3.0.901, OS Protected version: 5.1.2600.1106



Obviously, the installation of DirectX 9.0c fails as it seems I am unable to replace/update system files.  Is there any way to create a working .MSI package for DirectX 9.0c?

Thanks for your help.
sylvain_langloisAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TheCleanerCommented:
Have you looked here:

http://www.appdeploy.com/packages/detail.asp?id=169

DirectX 9.0c Redistributable is available:
http://download.microsoft.com/download/8/1/e/81ed90eb-dd87-4a23-aedc-298a9603b4e4/directx_9c_redist.exe

It looks like this version of dxsetup.exe supports
/silent
/packageinstall
/opk
/windowsupdate
/installmanageddx

I’ve only tried /silent and initial findings show it produces no dialogs and doesn't reboot.

Above Entry Provided by jasonclamb
 

--------------------------------------------------------------------------------
If you use WIWW (Windows Installer Wrapper Wizard) you can specify the the /silent switch for the DX 9.0c install and then you have a fully Active Directory Software Installations GPO friendly MSI.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sylvain_langloisAuthor Commented:
I did look at that solution but I had some problems with WIWW (COMCTL32.OCX not working properly or something) and I dismissed it quickly.  I will try to solve that problem and I'll keep you posted...

TheCleanerCommented:
the COMCTL32.OCX file may need to be updated.  You can download .net framework 2.0 and get the update I believe.
PMI ACP® Project Management

Prepare for the PMI Agile Certified Practitioner (PMI-ACP)® exam, which formally recognizes your knowledge of agile principles and your skill with agile techniques.

sylvain_langloisAuthor Commented:
I managed to get WIWW to work and I successfully packaged DirectX 9.0c.  I tried the package on a computer and it installed without any errors.

I'm facing another problem though:  I created a new policy and I assigned the package in Computer configuration/Software settings/Software installation.  I linked the new policy to an OU.  I did a gpupdate/force on the workstation, I rebooted.  The package won't install, as if the policy didn't exist or didn't apply to that workstation.  There's no error in the event viewer, just an event from Application Management saying that the new parameters were applied successfully.
TheCleanerCommented:
It takes time on the DC's to replicate the GP's as well.

I bet if you tried it again in about 90 minutes and did the gpupdate /force on the workstation it would probably work fine.
sylvain_langloisAuthor Commented:
It still doesn't work.  I tried running gpresult on the workstation and according to the result, my new GPO is applied correctly to the workstation...  Still, DirectX 9.0c is not installed when the computer boots up.
TheCleanerCommented:
Did you see 'Installing Directx9" or similar during boot but before the CTRL-ALT-DEL screen?

That would tell you if it is at least trying to install it.  It will also show in the application log (I think, maybe system) if it tried to install and failed.


You may look here as well:

http://technet2.microsoft.com/WindowsServer/en/Library/b7c2efc1-207e-4089-8490-0d002daf8b6c1033.mspx

Just in case you are a little unfamiliar with how to correctly assign the app, etc. in GPO's.

If there are event log errors, let me know, and I should be able to help.

sylvain_langloisAuthor Commented:
There was no message before the CTRL-ALT-DEL.  No message regarding DirectX in the event log.

I found the problem though.  I had "." in my path to my package and in the package name.  I removed them to see if it would do any good...  \\Server\packages\directx_9.0c\pkg_directx_9.0c.msi became \\Server\packages\directx_90c\pkg_directx_90c.msi.  I deleted the old MSI package, did a new one.  I deleted the old GPO, did a new one and placed it exactly at the same place and it worked.

Thanks again for your hepl!
TheCleanerCommented:
Thanks for the points...glad it is working well.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.