how do i share a printer on a wireless network

systems ,2 pc's xp pro sp2 fully up to date.1 Advent notebook xp home sp2 upto date.
netgear wireless network using  2x 108mbps wireless usb 2.0 adapters. 1x 108 mbps wireless pc card for notebook. 1x 108 mbps wireless firewall router "WGT624 v3 .connected to cabel modem 10mb Service telewest.
ALL 3 have internet connection and each pc/laptop can ping each others ip address.
but i just cannot config printer sharing even though i have done all that has so far been told to do,i have dissabled firewalls and enabled "Epson rx500 usb" sharing,but i am at my wits end trying to sort this out.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

So, how far have you gotten?

if you right click on the printer, and click on sharing, what happens?
On the computer that the printer is connected to: go to properties>security tab--make sure "Everyone" is allowed permission to the printer.
This site sells some autoswitches...........

Announcing the Winners!

The results are in for the 15th Annual Expert Awards! Congratulations to the winners, and thank you to everyone who participated in the nominations. We are so grateful for the valuable contributions experts make on a daily basis. Click to read more about this year’s recipients!

Sorry.........wrong post.....oops!!!
CLINTONAuthor Commented:
wirthr...If i right click on printer and select sharing i get the usual little hand showing sharing.

dreamcomputers..which security tab are you refering to ?
ok, so you just can't see it from the other computers?
maybe you can see it, but can't map to it?
or you can map to it, but it won't print?
CLINTONAuthor Commented:
wirthr..just cannot enable sharring even running network setup wizard.

I thought you said you get the little hand under the printer?  That would mean that it is shared.
CLINTONAuthor Commented:
yes the hand is there,but that only means that it is ready to be shared,but no matter which pc i use the add network place wizard on when i browse my MSHOME the printer is not showing on any off them
the security tab I am referring to: start>settings>printers--right click printer in question, sharing>security
ok, from another pc, try to do this

click on start>run




and see if you can access the shares
CLINTONAuthor Commented:
dreamcomputer, thanks for you reply,but that option is not available.

wirthr, already done all that m8 as you will see in my original post. cheers anyway.
if you guys come up with any other solutions i would be very grateful,,i will be back in the morning as i have to go out now, thanks so far.
I dont see anywhere in the post where you tried to access a remote share like that.  i see that you can ping the other pc's, but that's not what I am trying to get you to do.  What happens when you try an access a computer that way?  does it just time out or...

Here's what I did.  Went to Newegg, but Staples would do.  Buy a print server appropriate for your printer and tastes, that is... Wireless or wired, for a USB printer or parallel or whatever you have... then connect it to your printer.  Give the new print server a static ip and set up IP printing on your PC's.
CLINTONAuthor Commented:
WGhen, i will check that out, but this network setup cost me a few bob,so i cant realy aford that mutch at the mo. cheers
I forgot to mention that my wired print server from Newegg cost something like 40 bucks.
Here's a link.  They start at $35.99

Don't use the "add a network place" wizard unless it is a standalone printer. You will need to use the "Add a Printer" wizard and install the drivers on each workstation for a shared printer that is connected to a single computer.
You should not have to buy anything.  This is what I would do.

1:Ensure you can ping both machines both ways via IP Address and via name. Your wireless router should act as a router for your so you don't need to mess with the host files on your machines, since your IP addresses are dynamic.

2: Ensure you share the printer and you have ANY firewall services disabled on the computer with the printer locally attached.

3: To add the printer, go to Control Panel, Printers, Add Printer Wizard, Network Printer, then select the middle option.
    This should be the [Connect to this printer (or to browse to a printer, select this option and click NEXT)] radio button


If its a newer computer the drivers should automatically install.

Its important that all FIREWALLS are turned off

Steps 3 and below should be done on the other computer

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CLINTONAuthor Commented:
Thanks Dunkman,it seems i had overlooked the the network group option,had pc with printer in "WORKGROUP".and others on " MSHOME".
Awesome. Well done!  Have a good day!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.