Installing And Configuring Samba On FreeBSD

Note: I AM Fairly New To Unix And FreeBSD.

I did a minimal install of FreeBSD (at my home) and tommorow I will need to install it at work. I didnt configure anything on the machine at work so almost everything will be new to me. I need to get internet access, install lynx, and apache. (http://www.experts-exchange.com/Operating_Systems/FreeBSD/Q_21736617.html)  Also I will need anything that would be required in order for me to install Samba.

I Am Using FreeBSD 6.0. Work Machine Has 5.4.
LVL 4
sof_combatAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sof_combatAuthor Commented:
Can anyone give me a step by step guide that will explain how to do everything?

I have found these so far:
http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/network-samba.html

http://www.us-webmasters.com/FreeBSD/Install/Samba/


Are There Guides That Will Tell Me Almost Exactly What To Type?
Tim_UtschigCommented:
   cd /usr/ports/net/samba3
    make install && make clean

You only mentioned Samba in your pointer question, does that mean you figured out Lynx and Apache? (hint: it's very much the same)

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Fundamentals of JavaScript

Learn the fundamentals of the popular programming language JavaScript so that you can explore the realm of web development.

sof_combatAuthor Commented:
I did figure out lynx (i didnt configure anything)
I just finished installing apache (now I need to configure that)
if you want to help with apache:
http://www.experts-exchange.com/Operating_Systems/FreeBSD/Q_21736617.html
sof_combatAuthor Commented:
I Dont have apache configured correctly (at least it gives me errors when i do #apachectl start)

I Have Installed samba, copied smb.conf and enabled inetd.
I have logged onto localhost901:
#lynx http://localhost:901

But I Do Not Know What To Do From there

I am looking at:
http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/network-samba.html
David PiniellaCommented:
http://freebsdwiki.net/index.php/Samba_Configuration will give you some insight on configuring it (and http://freebsdwiki.net/index.php/Samba_Installation for installing it but since you seem to have figured out how to get that far, i doubt you'll need that...)
sof_combatAuthor Commented:
Since I Need This For Tommorow I Will Post The Directions I Made For Myself (I Am Only Posting From Where I Dont Think/Am Unsure On If I Am Right Or Not Because I Couldnt Get It To Work):

This Starts Off With:
# lynx localhost:901 logging as root, and going to global

Change:
workgroup  MYGROUP
      to
workgroup workgroup
      Change:
server string  Samba Server
      to
server string  <hostname> (Or A Description)

      Change Encypt Passwords From No To Yes:
            Encrypt passwords [Yes]

      Under Hosts Allow:
            hosts allow 172.20.

Go Back To Commit Changes And Press Enter:


#  vi /usr/local/etc/smb.conf

It Should Contain:
      #Comments
      #Global parameters
      [global]
            //All the things configured with SWAT
Next Is What Needs To Be Changed:
      [homes]
      comment = Home Directories
      read only = No
      browseable = Yes //Changed from No to Yes
      writeable = Yes //Add this line
      path = /usr/home/%u //Add this also


Create Files Used For Samba To Authenticate Clients:
# grep -v "^#" /etc/passwd | make_smbpasswd > /usr/local/private/smbpasswd
# chmod 600 /usr/local/private/smbpasswd



Kill The Process:
      #  Kill –HUP `cat /var/run/inetd.pid`

Add Samba T rc.conf:
      #  vi /etc/rc.conf
      
      samba_enable=”YES”
      mmbd_enable=”YES”
      smbd_enable=”YES”
      winbindd_enable=”YES”

Reboot The System:
      #  shutdown –r now
            Or
      #  reboot

Adding Users:
      #  smbpasswd –a <username>

Please Tell Me If Anything Is Wrong Because I Don't Want To Go To Work Unprepared.

- Thank You Everyone Who Has Helped (And Hopefully Everyone Who Will Before I Go To Work)
David PiniellaCommented:
rebooting the system shouldn't be necessary -- you may need to restart the process or send it a "HUP" signal to re-read the configuration file
(to restart, run /etc/rc.d/samba restart .... to HUP it, find the process id by running "ps aux | grep samba" to get the pid and then running "kill -HUP [pid # here]")
sof_combatAuthor Commented:
Other than the unecessary reboot will everything work correctly?

Is there anything I am missing?

- This Is My Final Post, Because I Am Heading For Bed, G'Night Every1
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.