Troubleshooting Remote Desktop

I'm having a problem connecting to Remote Desktop from outside my local network.  Within my local network, connecting say from my laptop to my desktop, it works fine -- I just remote to the static IP I've assigned to myself within my local net (192.168.1.x).  But outside my network, say at a friends place, a coffee shop, school, work, etc.  it doesn't work.  I try to remote to the IP I've been given by my broadband company and I just the message:

"The client could not connect to the remote computer.  Remote connections might not be enabled or the computer might be too busy to accept new connections.  It is also possible that network problems are preventing your connection.  Please try to connect again later.  If the problem continues to occur, contact your system administrator."

I'm trying to troubleshoot this systematically to locate the problem -- any help on what steps to perform and in what order would be greatly appreciated.

Here's my setup:

- Linksys BEFW11F4 v2 Router
- Desktop: Windows XP Pro SP2 running Windows Firewall
- Laptop same

I've tried turning the firewall on and off, doesn't make a difference.  I've also checked the port forwarding on the router, seems to be correct.  Any idea how I can trace this problem?

Thanks!!
Philly_CAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rob WilliamsCommented:
On the BEFW11S4, have you enabled port forwarding to your PC? If not you can find specific directions for your router at:
http://www.portforward.com/english/routers/port_forwarding/Linksys/BEFW11S4/Remote_Desktop.htm
grsteedCommented:
Is your Port Forwarding set using TCP port 3389?  

Gary
Kevin CrossChief Technology OfficerCommented:
So you do have port forwarding turned on to send 3389 requests to the Desktop?

Also, the palces you are coming in from do they have router/firewall that could possibly be blocking Remote Desktop?

Saw this issue on a few machines myself while was logged in to VPN on router.  Found there that I had to update the firmware and reset router.  Not sure if something like that is happening here...
Rowby Goren Makes an Impact on Screen and Online

Learn about longtime user Rowby Goren and his great contributions to the site. We explore his method for posing questions that are likely to yield a solution, and take a look at how his career transformed from a Hollywood writer to a website entrepreneur.

Kevin CrossChief Technology OfficerCommented:
AH, you guys beat me to it...was rambling too much. :)
Kevin CrossChief Technology OfficerCommented:
Nice post RobWill, if forwarding is setup properly already, it is most likely the "Block WAN Request" option that needs to be set...
KhalidJCommented:
Connect to your network via VPN and then try RDP.  Does it work?
xcromxCommented:
Go into your router and under applications and gaming add the port 3389 and forward it to 3389 and make you put in the IP Address

Next if you are running Windows firewall in XP then you have to add that port in the settings also..Real easy setup..

sounds like you router is blocking the port 3389..
Rob WilliamsCommented:
Thanks mwvisa1.
I don't think "Block WAN Request" option should have anything to do with it. That is just a security feature that should be enabled. It blocks ICMP (ping) requests.
Philly_CAuthor Commented:
I'd already fixed the port forwarding option after reading a previous post by RobWill -- so that's done.  Any other possibilities?
Philly_CAuthor Commented:
To clarify -- the port forwarding was set correctly even before posting this question, and even with it set Remote Desktop still doesn't work from external sites.  Anything else in the router that could be blocking it?

Rob WilliamsCommented:
From the site you are trying to connect to,  verify the port is open/visible. It is possible your modem, if performing NAT, could be blocking. To do so go to:
  http://www.canyouseeme.org
and test for port 3389. Also while on this site, it will display your WAN/Public/Internet IP. Verify this is the one to which you are connecting.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Philly_CAuthor Commented:
That helped, showed the port wasn't showing.  Ended up being a VOIP adapter between the modem and the router that I had forgotten about, and when removed it worked like a charm.  Now to figure out why the adapter is blocking ports . . .

Thanks!
Rob WilliamsCommented:
Thanks Philly_C,
--Rob

Can the VoIP unit sit on the inside of the router or on the DMZ?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.