Cisco 3005 Concentrator and Linksys BEFVP41 - NETBIOS

Hello IT folks

I have Cisco VPN 3005 concentrator behind T1.  For the 10 remote offices with two computers each, I have data T1 with Linksys BEVP41 routers. The Cisco concentrator and Linksys router can establish the site-to-site tunnels with static IP addresses on both sides, but can not pass the NETBIOS traffic as if I wanted to set up a folder share on the remote computer from the company’s server.   Cisco said that the shares can not be passed through.  If I use Linksys routers on both side as site-to-site tunnels, then the shares would work.  I have tried the LMHOSTS file: it’s not pingable by the computer name everytime.

Setting up a Windows server running WINS at the remote office is not an option.  

Can anyone help me out with the share problem? Am I missing somewhere?

TIA
scottkhAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rob WilliamsCommented:
Can you set up the share using the IP rather than the NetBIOS name?
  net  use  z:  \\192.168.123.123\ShareName
Many VPN’s do not pass NetBIOS names so IP, LMHosts, WINS and DNS are the basic options.
Also try adding the remote DNS server to your local DNS servers in your network card's TCP/IP configuration
Test if you can connect with the full computer and domain name as  \\ComputerName.domain.local  If so, add the suffix DomainName.local to the DNS configuration of the network adapter used for the connection.
scottkhAuthor Commented:
Thanks for the answer.  This is what I thought.

For the LMHOSTS file, I realized that the suffix #PRE must be capitalized.   How do I know if the LMHOSTS is working? by pinging?

Please clarify what you mean by remote DNS server to your local DNS server in the TCP/IP config?  Suppose, the local DNS is 192.168.0.3, so do i plug this number in the remote computer's TCP into DNS as secondary or tertiary DNS?

Thanks again.
Rob WilliamsCommented:
>>" #PRE must be capitalized."
Yes there are a couple of oddities.
-PRE has to be capitalized, however you do not need it, though should give you faster resolution where it is "pre-loaded".
-you must hit the return key after entering a line, before saving
-and #'s are comment lines
-not sure but it may be case sensitive as well ( I have read LMHosts entries are case sensitive, but I didn't know NetBIOS names were, so you may want to verify the remote computers name case to play it safe)
-after adding entries to the LMHosts file save it without an extension. Has a .sam (sample) extension prior to this

To check your LMHosts file entries are accepted at a command prompt enter
  nbtstat  -R
to purge and reload the local name cache
then enter
  nbtstat  -c
to display the current name cache which should include your LMHosts file entries.
Note; the nbtstat "switches" R & c are case sensitive.

"remote DNS server" ....Do you have your own DNS server, such as a Windows Active Directory Server running at the site you are connecting to? If so add it's IP address in the DNS servers list in your NIC's TCP/IP properties.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Introduction to R

R is considered the predominant language for data scientist and statisticians. Learn how to use R for your own data science projects.

Rob WilliamsCommented:
Scott, a couple more items to assist with name resolution:
-under the WINS configuration on the network adapter make sure NetBIOS over TCP/IP is selected
-verify your router does not have a "block NetBIOS broadcast" option enabled
-test if you can connect with the full computer and domain name as  \\ComputerName.domain.local  If so, add the suffix DomainName.local to the DNS configuration of the virtual private adapter/connection [ right click virtual adapter | properties | TCP/IP properties | Advanced | DNS | "Append these DNS suffixes (in order)" | Add ]

--Rob
Rob WilliamsCommented:
scottkh, how did you end up making out with the name resolution?
--Rob
scottkhAuthor Commented:
I forgot about this posting.  Yes, it is working and thanks to Robwill.  Please award him full points.

Scott
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VPN

From novice to tech pro — start learning today.