How do I test if my web service got copied correctly?

Greetings,

I FTP'ed my project to a new directory on my website, and need to test it.  What's the correct format for the URL??

I see files with the following extensions:

.asax
.resx
.webinfo
.asmx
.config

But shouldn't there be a wsdl file?  If so how do I get my project to create one?

Thanks for the help.
Bob



 
ba272Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

LordPhoenixCommented:
Hi Bob,

You will access the .asmx file to test your webservice. http://www.yoursite.com/webservice.asmx

For an explaination of .asmx and wsdl see the following site:

http://www.dotnetbips.com/articles/displayarticle.aspx?id=41

Cheers,

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ba272Author Commented:
When you say access, do you mean I'd simply enter that into the browse?

http://www.yoursite.com/webservice.asmx  <ENTER>


I did this with my service:

http://www.yoursite.com/Greetings/Service1.asmx <ENTER>

and here's what I got...

Line 43: by Microsoft that offers a single logon and core profile services for member sites.
Line 44:     -->
Line 45:     <authentication mode="Windows" />
Line 46:
Line 47:       <!--  AUTHORIZATION
 
So I changed the config to:
Line 45:     <authentication mode="None" />
recompiled the web service and updated all the files, again by FTP.  And it still had the same error??

What can you suggest?

Thanks for the help.

Bob
ba272Author Commented:
I just verified that "None" got changed back to "Windows" before I copied it to my domain.
Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

ba272Author Commented:
When I try and create a web referecne in my Windows client [which uses the web service successfully on my desktop] I get the following error:

There was an error downloading 'http://www.texselogic.com/Greetings/Service1.asmx'.

The request failed with the error message:
--
<html>
    <head>
        <title>Configuration Error</title>
        <style>
              body {font-family:"Verdana";font-weight:normal;font-size: .7em;color:black;}
              p {font-family:"Verdana"
ba272Author Commented:
Actually I used the correct domain name "pizzapilot.com" and got the same error.
ba272Author Commented:
Changed it and got the same error:

Line 43:            by Microsoft that offers a single logon and core profile services for member sites.
Line 44:     -->
Line 45:     <authentication mode="None" />
Line 46:
Line 47:       <!--  AUTHORIZATION
 
LordPhoenixCommented:
Hi Bob,

On your website, did you create an application name for the virtual directory within which the webservice resides? This is what your error message suggests.

Read this: http://dotnetjunkies.com/WebLog/shaunakp/archive/2005/03/25/61363.aspx

--------------------------------

A word on authentication:

Setting <authentication mode="None" /> will make sure that none of the security provides processes the request, i.e. Windows, Passport or Forms. 'None' will perform no authentication at all. When you make any changes to the web.config file, you must restart the IIS application for the changes to take affect.

There are so many settings that can be configured for authentication. I would recommend visiting MSDN and reading up on the possibilities.

Hope this helps.
ba272Author Commented:
LordPhoenix,

Thanks for the link.  It is the exact same error.  But I think my problem may be different than his problem.

When I went into IIS I saw my application did not have the folder icon like his.  And mine did not have a Create button, as in his example.  Mine said Remove.  So I removed it, and FTP'ed the files but that didn't change anything.  I went into IIS again and this time could select Create, which I did.  I tested that on the site and it failed.

As far as possible authentication setting, this is a hello world application, and I am not in a position to event understand what I about these settings.  Could this problem have been caused by me FTP'ing the web service rather than uploading it through Visual Studio?

Thanks for the help,
Bob

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
C#

From novice to tech pro — start learning today.