We help IT Professionals succeed at work.

Exchange 2003 RPC over HTTP (Exception 1722)

sclam
sclam asked
on
1,592 Views
Last Modified: 2010-05-18
Scenario & Settings
=============
Front end server @ DMZ
Back end server and AD @ private network
ValidPorts Registry on FE server is set to "BE:6001-6002;be.xxx.com:6001-6002;BE:6004;be.xxx.com:6004;"
CISCO PIX allows all ports between FE, BE and AD.
SSL published by the FE CA to the FQDN fe.xxx.com (OWA works fine)
RPC folder on FE IIS is set to use basic authentication

Everything's working fine for months (POP, IMAP, OWA, etc) except RPC over HTTP.

outlook.exe /rpcdiag shows local outlook are still using tcp/ip and remote outlook is unable to connect.

rpcping result in Exception 1722.

with the -E option
============
(ping from the front end server fe.xxx.com)
RPCPinging proxy server fe.xxx.com with Echo Request Packet
Checking IE setting...
The proxy setting is disabled.
Sending ping to server
Response from server received: 200
Pinging successfully completed in 94 ms

(ping from client PC in private network)
RPCPinging proxy server fe.xxx.com with Echo Request Packet
Checking IE setting...
The proxy setting is disabled.
Sending ping to server
Error 12175 returned in the WinHttpSendRequest.
Ping failed.

I think I have mess up a bit on the registry following the solution searched from the Internet. Once created the MSExchangeDSAccess and  LdapKeepAliveSecs but removed already.

Is there a way to sort out where the problem is? Thanks a million!
Comment
Watch Question

CERTIFIED EXPERT
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
the CA is the FE server itself. Is that trusted?

Author

Commented:
Thanks Matt! just managed to add the cert to trusted root CA in a client PC (located in private network).

the "Error 12175 returned in the WinHttpSendRequest" error is gone. but the proxy setting is still disabled. any idea?

(ping with -E from client PC in private network) - after trusted the root CA
RPCPinging proxy server fe.xxx.com with Echo Request Packet
Checking IE setting...
The proxy setting is disabled.
Sending ping to server
Response from server received: 200
Pinging successfully completed in 261 ms

Commented:
if your client use windows xp, there was a hotfix for this issue but i cant remember the exact KB, search microsoft site & u will find it

Author

Commented:
Thanks tshalim for ur suggestion, I've already done that at the beginning.

I gave a try on outlook (even it says proxy setting is disabled) and surprisingly it worked. Thanks Matt!

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.