We help IT Professionals succeed at work.

eclipse with jdk1.5

kuching
kuching asked
on
833 Views
Last Modified: 2008-03-10
dear all, i am trying to run the JSp with eclipse.. but then when i start up the eclipse, i have this error.. and i can not sovled. Any ideas? I can see the reply after i type " echo $JAVA_HOME "

please help..

this is the error log..

!SESSION Feb 15, 2006 12:15:31.356 ---------------------------------------------
eclipse.buildId=200409161125
java.version=1.5.0-p1
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=freebsd, ARCH=x86, WS=gtk, NL=en

!ENTRY org.eclipse.update.configurator Feb 15, 2006 12:15:31.358
!MESSAGE Could not load from shared install
!STACK 0
java.lang.Exception
      at org.eclipse.update.internal.configurator.ConfigurationParser.processConfig(ConfigurationParser.java:299)
      at org.eclipse.update.internal.configurator.ConfigurationParser.startElement(ConfigurationParser.java:105)
      at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(AbstractSAXParser.java:533)
      at com.sun.org.apache.xerces.internal.parsers.AbstractXMLDocumentParser.emptyElement(AbstractXMLDocumentParser.java:220)
      at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scanStartElement(XMLNSDocumentScannerImpl.java:316)
      at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl$NSContentDispatcher.scanRootElementHook(XMLNSDocumentScannerImpl.java:773)
      at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(XMLDocumentFragmentScannerImpl.java:1794)
      at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:368)
      at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:834)
      at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:764)
      at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:148)
      at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1242)
      at javax.xml.parsers.SAXParser.parse(SAXParser.java:375)
      at org.eclipse.update.internal.configurator.ConfigurationParser.parse(ConfigurationParser.java:69)
      at org.eclipse.update.internal.configurator.PlatformConfiguration.loadConfig(PlatformConfiguration.java:979)
      at org.eclipse.update.internal.configurator.PlatformConfiguration.initializeCurrent(PlatformConfiguration.java:667)
      at org.eclipse.update.internal.configurator.PlatformConfiguration.<init>(PlatformConfiguration.java:80)
      at org.eclipse.update.internal.configurator.PlatformConfiguration.startup(PlatformConfiguration.java:621)
      at org.eclipse.update.internal.configurator.ConfigurationActivator.getPlatformConfiguration(ConfigurationActivator.java:323)
      at org.eclipse.update.internal.configurator.ConfigurationActivator.initialize(ConfigurationActivator.java:108)
      at org.eclipse.update.internal.configurator.ConfigurationActivator.start(ConfigurationActivator.java:71)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:958)
      at java.security.AccessController.doPrivileged(Native Method)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:954)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:937)
      at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:421)
      at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:366)
      at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:999)
      at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:577)
      at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:488)
      at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:273)
      at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:444)
      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:186)
      at org.eclipse.osgi.framework.eventmgr.EventThread.run(EventThread.java:104)

!ENTRY org.eclipse.core.runtime Feb 15, 2006 12:15:31.393
!MESSAGE Product org.eclipse.platform.ide could not be found.

!ENTRY org.eclipse.osgi Feb 15, 2006 12:15:31.428
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
      at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:313)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:273)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:129)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.eclipse.core.launcher.Main.basicRun(Main.java:185)
      at org.eclipse.core.launcher.Main.run(Main.java:704)
      at org.eclipse.core.launcher.Main.main(Main.java:688)
Comment
Watch Question

Author

Commented:
i dont know how.. now it's sovled..

but when i startup my eclipse after install the plugin.. i have this error...


Feb 15, 2006 1:18:57 PM org.apache.catalina.startup.Catalina load
WARNING: Can't load server.xml from /usr/local/tomcat/apache-tomcat-5.5.15/conf/server.xml
Feb 15, 2006 1:18:58 PM org.apache.catalina.startup.Catalina load
WARNING: Can't load server.xml from /usr/local/tomcat/apache-tomcat-5.5.15/conf/server.xml
Feb 15, 2006 1:18:58 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 0 ms
java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:275)
      at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
Caused by: java.lang.NullPointerException
      at org.apache.catalina.startup.Catalina.await(Catalina.java:615)
      at org.apache.catalina.startup.Catalina.start(Catalina.java:575)
      ... 6 more

My God.. what is happending....
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
i have restarted the eclipse.. even rebooted the entier freebsd machine...

Author

Commented:
cant figure out why it's say cant load the server.xml

I have succesfully configure everything, include the JAVA_HOME, the CATALINA_HOME and also the respectively compulsory package.
Manikandan ThiagarajanSenior consultant

Commented:
could you able to start the server in tomcat.
check in tomcat seperately.
that says configuration problem.

give me the environment variable and value for Java_home and Catalina_home

Author

Commented:
I can start the tomcat seperately. Below is the console...

********
foong@ /home/foong#echo $JAVA_HOME
/usr/local/jdk1.5.0
foong@ /home/foong#echo $CATALINA_HOME
/usr/local/tomcat/apache-tomcat-5.5.15
foong@ /home/foong#tomstart
Using CATALINA_BASE:   /usr/local/tomcat/apache-tomcat-5.5.15
Using CATALINA_HOME:   /usr/local/tomcat/apache-tomcat-5.5.15
Using CATALINA_TMPDIR: /usr/local/tomcat/apache-tomcat-5.5.15/temp
Using JRE_HOME:       /usr/local/jdk1.5.0
foong@ /home/foong#tomdown
Using CATALINA_BASE:   /usr/local/tomcat/apache-tomcat-5.5.15
Using CATALINA_HOME:   /usr/local/tomcat/apache-tomcat-5.5.15
Using CATALINA_TMPDIR: /usr/local/tomcat/apache-tomcat-5.5.15/temp
Using JRE_HOME:       /usr/local/jdk1.5.0
foong@ /home/foong#
***********

When i start my Eclipse and start my tomcat, bundle in the with the tomcat-sysdeo-plugin, i will have the error message that i shown on my previous post.

In the eclipse, this the setting
Tomcat Version : 5.X
Tomcat Home : /usr/local/tomcat/apache-tomcat-5.5.15
Manikandan ThiagarajanSenior consultant

Commented:
in ecclipse setting tomcat 5.5.option is there

Author

Commented:
no, it's only with option 5.x?

i am running this tomcat 5.5.15 with my eclipse 3.1

and my FreeBSD is tomcat 5.5.15 with eclipse 3.0
So you are suspecting its' bug?

Commented:
I'm using SYSDEO tomcat plugin 3.1.0 with Eclipse 3.1.2 and having no problem.
Can you describe the steps you've following to configure your project as a Tomcat project?

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.