troubleshooting Question

WMIC invalid class error

Avatar of jmdowling
jmdowling asked on
Windows Server 2003
4 Comments1 Solution7363 ViewsLast Modified:
I am trying to use WMIC to obtain a list of all installed software on numerous Windows 2003 Standard Edition Servers and some Windows XP workstations. I am Logged in as administrator from the domain controller, The command I am using is WMIC - which enters me into interactive mode.  At the wmic:root\cli> prompt i am typing /node:"server-name" PRODUCT.  For some of my servers i get the information i want, for others i get the following error:

Node - server01
ERROR:
Code = 0x80041010
Description = Invalid class
Facility = WMI

My initial though was that i needed to log into server01 and run the wmic command so it goes through the installing phase.  I did that but it did not change the outcome I am receiving.  I am still receiving the same error.  I also receive this error when I log into server01 and run the wmic product command.  I am logging in as a domain administrator.  I tried both interactive and non-interactive mode but still get the same results.

Any ideas would be helpful...........


thanks,

jmdowling
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 4 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 4 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros