troubleshooting Question

Control files are corrupted

Avatar of at999
at999 asked on
Oracle Database
10 Comments1 Solution3139 ViewsLast Modified:
Hello All,

I have a database - oracle 8i setup on a system. Somehow the control files of the database has been corrupted.

When I tried to connect the database, I got the error - "ORA-01033: ORACLE initialization or shutdown in progress"
When I checked oradim.log, I found that there is inconsistency with the control files -
ORA-00214: controlfile 'E:\ORACLE\ORADATA\TEST\CONTROL01.CTL' version 17230 inconsistent with file 'D:\ORACLE\ORADATA\TEST\CONTROL02.CTL' version 17216

How can I recover those control files.

I tried -
"Recover database until cancel "  - I got error that database is not mounted. !! How can I mount the datbase if the Control files are corrupted?????

Please help
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 10 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 10 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros