troubleshooting Question

"500 Internal Server Error" running a whois script

Avatar of shekharbasnet
shekharbasnet asked on
Scripting Languages
12 Comments1 Solution416 ViewsLast Modified:
Hello all,

I downloaded two simple scripts cc_whois.cgi and cgi-lib.pl from http://www.icthus.net/CGI-City/download.shtml and installed as per http://collindi.tripod.com/whois/installation.html. This will output the whois replies from the server to a web client. Both are in the /usr/local/httpd/cgi-bin folder. I have some other cgi scripts under the same folder running smoothly. But I get Internal Server Error while trying to access it,, by doing http://localhost/cgi-bin/cc_whois.cgi. I tried from other PCs in the LAN with the same results. The files mod are 777 and I have changed the owner but with exactly the same error. The error_log shows:

[Mon Feb 20 14:41:57 2006] [error] [client 127.0.0.1] (2)No such file or directory: exec of '/usr/local/httpd/cgi-bin/cc_whois.cgi' failed
[Mon Feb 20 14:41:57 2006] [error] [client 127.0.0.1] Premature end of script headers: cc_whois.cgi

I don't have any experience in cgi or perl. I wonder what is wrong. The files are quite long. One is 945 lines and the other is 133 lines. Should I paste here, that would be quite long here.

TIA.
S


Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 12 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 12 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros