troubleshooting Question

PIX 506e VPN Problem

Avatar of quinnwyo
quinnwyoFlag for United States of America asked on
Software FirewallsCisco
5 Comments1 Solution696 ViewsLast Modified:
We just changed ISPs from a cable provider to a full T1.  I reconfigured the PIX with WRITE ERASE, running setup to apply IP, then TFTP-ing the updated config with the new IPs added.  I was assuming the VPN that was already in place would continue to work - OOOps!??  All seems to work except for the VPN.  I even ran the PDM wizard again and it still does not work??  I use it for remote users to access our network using the Windows VPN client.  Can someone look at this config and advise me?   Im not too sure about the PAT-ing??  Also, feel free to tidy up this config for me if you would?

ISP Router is setup for passthrough...
x.x.x.2 = PIX External Int.
x.x.x.3 = Email Server 1
x.x.x.4 = Web Server
x.x.x.5 = Email Server 2
x.x.x.6 = Web Server 2

192.168.6.x/24 = Internal Lan
192.168.6.9 = Email 1
192.168.6.9 = Web 1
192.168.6.8 = Email 2
192.168.6.10 = Web 2


Building configuration...
: Saved
:
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 10baset
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxxxxx encrypted
passwd xxxxxxxxx encrypted
hostname PIXPELHAM
domain-name mydomain.com
clock timezone CST -6
clock summer-time CDT recurring
fixup protocol dns
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list inside_outbound_nat0_acl permit ip any 192.168.6.0 255.255.255.0
access-list outside_access_in permit icmp any any
access-list outside_access_in permit udp any host x.x.x.2 eq 3389
access-list outside_access_in permit tcp any host x.x.x.2 eq 3389
access-list outside_access_in permit tcp any host x.x.x.3 eq smtp
access-list outside_access_in permit tcp any host x.x.x.3 eq pop3
access-list outside_access_in permit tcp any host x.x.x.4 eq www
access-list outside_access_in permit udp any host x.x.x.4 eq 20
access-list outside_access_in permit tcp any host x.x.x.4 eq ftp
access-list outside_access_in permit tcp any host x.x.x.4 eq ftp-data
access-list outside_access_in permit tcp any host x.x.x.4 eq https
access-list outside_access_in permit udp any host x.x.x4 eq 21
access-list outside_access_in permit udp any host x.x.x.4 eq domain
access-list outside_access_in permit tcp any host x.x.x.5 eq smtp
access-list outside_access_in permit tcp any host x.x.x.5 eq pop3
access-list outside_access_in permit tcp any host x.x.x eq www
access-list outside_access_in permit tcp any host x.x.x.6 eq https
pager lines 24
logging on
logging timestamp
logging trap informational
logging facility 22
logging host inside 192.168.6.7
icmp permit any inside
mtu outside 1600
mtu inside 1600
ip address outside x.x.x.2 255.255.255.248
ip address inside 192.168.6.2 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool VCTInside 192.168.6.70-192.168.6.74
pdm location 192.168.6.10 255.255.255.255 inside
pdm location 192.168.6.0 255.255.255.0 outside
pdm location 192.168.6.64 255.255.255.240 outside
pdm location 192.168.1.0 255.255.255.0 inside
pdm location 192.168.2.1 255.255.255.255 inside
pdm location 192.168.6.6 255.255.255.255 inside
pdm location 192.168.6.7 255.255.255.255 inside
pdm location 192.168.6.8 255.255.255.255 inside
pdm location 192.168.6.9 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface ftp 192.168.6.9 ftp netmask 255.255.255.255 0 0
static (inside,outside) udp interface 21 192.168.6.9 21 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface ftp-data 192.168.6.9 ftp-data netmask 255.255.255.255 0 0
static (inside,outside) udp interface 20 192.168.6.9 20 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface https 192.168.6.9 https netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 3389 192.168.6.6 3389 netmask 255.255.255.255 0 0
static (inside,outside) udp interface 3389 192.168.6.6 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface www 192.168.6.9 www netmask 255.255.255.255 0 0
static (inside,outside) tcp interface smtp 192.168.6.9 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface pop3 192.168.6.9 pop3 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface domain 192.168.6.9 domain netmask 255.255.255.255 0 0
static (inside,outside) udp interface domain 192.168.6.9 domain netmask 255.255.255.255 0 0
static (inside,outside) x.x.x.3 192.168.6.9 netmask 255.255.255.255 0 0
static (inside,outside) x.x.x.5 192.168.6.8 netmask 255.255.255.255 0 0
static (inside,outside) x.x.x.6 192.168.6.10 netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 x.x.x.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
ntp server 207.177.51.228 source outside
http server enable
http x.x.x.2 255.255.255.255 outside
http 192.168.6.2 255.255.255.255 inside
http 192.168.1.0 255.255.255.0 inside
http 192.168.6.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-pptp
sysopt connection permit-l2tp
crypto ipsec transform-set TRANS_ESP_3DES_MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set TRANS_ESP_3DES_MD5 mode transport
crypto dynamic-map outside_dyn_map 20 set transform-set TRANS_ESP_3DES_MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet 0.0.0.0 0.0.0.0 outside
telnet 192.168.6.0 255.255.255.0 inside
telnet 192.168.2.1 255.255.255.255 inside
telnet timeout 15
ssh 0.0.0.0 0.0.0.0 outside
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 30
management-access inside
console timeout 0
vpdn group PPTP-VPDN-GROUP accept dialin pptp
vpdn group PPTP-VPDN-GROUP ppp authentication mschap
vpdn group PPTP-VPDN-GROUP ppp encryption mppe auto required
vpdn group PPTP-VPDN-GROUP client configuration address local VCTInside
vpdn group PPTP-VPDN-GROUP client configuration dns 192.168.6.6 192.168.6.21
vpdn group PPTP-VPDN-GROUP pptp echo 60
vpdn group PPTP-VPDN-GROUP client authentication local
vpdn username andy password *********
vpdn username dick password *********
vpdn username lgodwin password *********
vpdn username jhurd password *********
vpdn username sfrey password *********
vpdn username dmahaffey password *********
vpdn username itc password *********
vpdn enable outside
username andy password FRRPjYpY5xezkSZo encrypted privilege 15
terminal width 100
banner exec ...
Cryptochecksum:88310991f01743c7cde404a5d39486d4
: end
[OK]

Thanks,

Andy Quinn
ASKER CERTIFIED SOLUTION
jjoseph_x

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Join our community to see this answer!
Unlock 1 Answer and 5 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 5 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros