Form using mailto pops up email address but does not send information

I have a form I created some time ago in Front Page 4.0  The server has the front page extensions on it and they are working correctly because that form is still working fine.  I opened it again in front page 2003 as my software has been upgraded.  The only thing I changed is the mailto address and then re-saved it.  Now when I try to use I.E. to submit the form I get a message box about folks will see your email address and then I hit continue. It opens the mail client and it let's me submit but it does not send the form values.  The other form is still working fine with either browser.  I can't get the data to come through using the same set up.
a182612Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

coreybryantCommented:
It seems you did not create the FP form correctly.  It is probably using mailto: as the action.

When you right clicked on the form - you chose form properties?  And then Sned to - you entered the email address - saved & published?

-Corey
Tina ClarkeCommented:
Could we have the url of the form?

Tina
a182612Author Commented:
I can't provide the URL as it is behind the company firewall and you won't be able to get to it due to security.  
Learn Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

coreybryantCommented:
When you right clicked on the form - you chose form properties?  And then Send to - you entered the email address - saved & published???

Or how about the source code n the opening form tag?

-Corey
a182612Author Commented:
I made the changes using the properties menu and when I try to publish it to the site it says conflict. and will not publish it.  I am not very familiar with front page 2003.  How can I publish and individual page without having to do an entire site?
coreybryantCommented:
>>How can I publish and individual page without having to do an entire site?
Right click on the file & hit publish

In the lower right hand corner you can also sync the files.  but if you are using FTP or another method to put files on your Frontpage website you run the risk of corrupting the FPSE and the form will not work

-Corey
a182612Author Commented:
Here is the code  it's now openeing the email client again and not sending the form data.

<FORM ACTION  =
"mailto:jidaughe@yahoo.com?subject =Specialist Survey"   METHOD  = POST ENCTYPE = "text/plain" name="specalist survey" id="specalist survey" webbot-action="--WEBBOT-SELF--">

  <!--webbot bot="SaveResults" S-Email-Address="jidaughe@fedex.com" S-Email-Format="TEXT/PRE" startspan -->
a182612Author Commented:

Here is the code  it's now openeing the email client again and not sending the form data.

<FORM ACTION  =
"mailto:jidaughe@yahoo.com?subject =Specialist Survey"   METHOD  = POST ENCTYPE = "text/plain" name="specalist survey" id="specalist survey" webbot-action="--WEBBOT-SELF--">

  <!--webbot bot="SaveResults" S-Email-Address="jidaughe@yahoo.com" S-Email-Format="TEXT/PRE" startspan -->

coreybryantCommented:
Just as I suspected - you are not relying on FP to process the form - you are wanting the client's default email browser.

I'll ask this question again: When you right clicked on the form - you chose form properties?  And then Send to - you entered the email address - saved & published???

-Corey
a182612Author Commented:
It won't let me use the publish.  Are you saying if I use ftp to put the document on the server it would work.. Go from my local directory and ftp it up to the server?
a182612Author Commented:
When I change the property I get this error message.

This form cannot be configured to send results via email.  The web site may be located at a disk based location or on a server that has not been configured to send email. contact your system admin.

I set up a local directory and put my files from the server in the local directory then I edited the local file and get this message.

I know the server works fine because the old form is working fine that I created some time agon  in FrontPage 4.0.  

coreybryantCommented:
>>Are you saying if I use ftp to put the document on the server it would work
No I am saying if you use FTP - it wil corrupt the FPSE
coreybryantCommented:
>>This form cannot be configured to send results via email.  The web site may be located at a disk based location or on a server that has not been configured to send email. contact your system admin.
This is a normal repsonse.  Just hit no so you will keep the address and then publish with FP - do not use FTP

Check out http://www.frontpageforms.com/form_wizard.htm on how to create a form in FP and to use FP to process the form

>>It won't let me use the publish.
Contact your SA or hosting provider and check to see if they have FPSE installed: http://support.microsoft.com/default.aspx?scid=kb;en-us;828909&Product=fp2003

-Corey
a182612Author Commented:
I downloaded the new server extensions and installed them successfully.  The existing forms that send emails work fine on the server.  I tried using the form wizard and get the same results as above when I try to publish.  Is there some where in the Front Page 2003.  Could I have the site set up wrong. I am using a local folder and when I do publish and save I get the extension error message.  I have it set up to go to a remote folder but it's a mapped drive on my local pc.  Should I change that and go directly to the IP address.  It has to be something from the local software to publishing on the server that is the problem because I don't have any problems with all the forms already running on the server.
coreybryantCommented:
>> I tried using the form wizard and get the same results as above when I try to publish.
how about the source code n the opening form tag?

>>Could I have the site set up wrong.
Yes it seems that way .

>> I am using a local folder and when I do publish and save I get the extension error message.
What extension error message??

>> I have it set up to go to a remote folder but it's a mapped drive on my local pc.
What do you have mapped?  Your FP website needs to be on the server with the extensions installed

>>Should I change that and go directly to the IP address.
If it is above - yes.

-Corey
a182612Author Commented:
MY web site is on my web server but on my local pc I have a mapped drive set up that allows me to view all the web site files as if they were local to my PC.

You do that by right clicking 'my network places' and then mapping to the server using the IP address of the server and the wwwroot file.

On my PC it's listed as the G: drive because that is what I mapped it to.

This may be the problem not sure.  Do I have to have a site set up to just create a form and save it to the server.  I can't seem to figure out how to update the settings once a site is set up.
coreybryantCommented:
Yes I understand what a mapped drive is but it is not used hen publishing with FP.  You should be publishing to http://www.example.com

>> I tried using the form wizard and get the same results as above when I try to publish.
how about the source code n the opening form tag?

-Corey
a182612Author Commented:
Corey I used the http://www.server.com and also tried it with the IP address and it allowing me to publish the document to the server using the IP address.  The problem is still on the local folder where I copied down the files from the server.  I edit that document then when I save I get the error message

This form cannot be configured to send results via email.  The web site may be located at a disk based location or on a server .....

Can I edit the document from the remote site and then just publish it to the remote site without having to use a local folder?
coreybryantCommented:
>>>The problem is still on the local folder where I copied down the files from the server.    I edit that document then when I save I get the error message
Is this the form that is using the email client to process?  You cannot copy files into the FP web site if you have extended the web.  You should copy the file - and then extend the web.  And then publish with FP thereafter.

>>The web site may be located at a disk based location or on a server .....
The link above explains this is a notmal response.  Ignore it choose no to keep the email and hit save and publish.

>>Can I edit the document from the remote site and then just publish it to the remote site without having to use a local folder?
If you do this - there is no need to publish to the remote site


-Corey

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
a182612Author Commented:
Ok, I tried it that way and I still get the same message.  I really don't know what to do from here.  I appreciate your hanging in there trying to help.  I just can't understand why all the forms on the server work fine and send the email but when I try to put a new one up there using this new Frontpage 2003 software it gives me that error message both locally and on the server.  Could there be a bug in this version?

I am giving you these points as you have been so great ..Thanks.

coreybryantCommented:
The code is incorrect.  Try this - can you try following the example on the page that I sent yu on your web & publish?  Or create a simple one input form?  If you look @ the form tag - the code - you will see the difference, but you cannot create this code, FP has to do it.  

Or let's do something simple - when you right click on the form & choose form properties - you see send to?  What is in those two fields?

-Corey
a182612Author Commented:
I tried it with just one form field element and the same problem.

Where to store results:
     file name:  order.asp
     email address:  tg@yahoo.com

The only other field on that page filled out is the form name.
coreybryantCommented:
If this is an ASP file - FP is not going to work.  You have to use something like ASPMail, JMail, ASPEMail

Go and recalculate the web to check the FPSE.

Ok try this....
Open a new page - go to insert form.  
Not got to insert form - text box

right click on the form & choose form properties - enter your email address in there and delete whatever is in the file name.

Now save it - choose no when you are aksed to remove the email recipient.  **PUBLISH**

Copy and paste what is in the opening form tag here ...

Go to the website and test it.

Does it work??

-Corey
a182612Author Commented:
I am getting this error message on the server side but the front page extensions are installed and the file _vti_inf.html is there giving the new version.

FrontPage Run-Time Component Page
You have submitted a form or followed a link to a page that requires a web server and the FrontPage Server Extensions to function properly.

This form or other FrontPage component will work correctly if you publish this web to a web server that has the FrontPage Server Extensions installed.

Click the <Back> arrow to return to the previous page
coreybryantCommented:
It sounds like your FPSE are not installed properly.  As you have read thru my other responses and you have learned - FPSE can be very delicate at times.  Accessing a website with FTP / or thru your "network" can be detrimental.

Dod you go to IIS and drill down to your website and go into the FPSE control panel to check the extensions?

-Corey
a182612Author Commented:
The file is located under Inetpub\wwwroot and here are the contents

<html>

<head>
<meta http-equiv="Content-Type"
content="text/html; charset=iso-8859-1">
<title> FrontPage Configuration Information </title>
</head>

<body>
<!-- _vti_inf.html version 0.100>
<!--
      This file contains important information used by the FrontPage client
      (the FrontPage Explorer and FrontPage Editor) to communicate with the
      FrontPage server extensions installed on this web server.

      The values below are automatically set by FrontPage at installation.  Normally, you do not need to modify these values, but in case
      you do, the parameters are as follows:

      'FPShtmlScriptUrl', 'FPAuthorScriptUrl', and 'FPAdminScriptUrl' specify
      the relative urls for the scripts that FrontPage uses for remote
      authoring.  These values should not be changed.

      'FPVersion' identifies the version of the FrontPage Server Extensions
      installed, and should not be changed.
--><!-- FrontPage Configuration Information
    FPVersion="5.0.2.2623"
    FPShtmlScriptUrl="_vti_bin/shtml.dll/_vti_rpc"
    FPAuthorScriptUrl="_vti_bin/_vti_aut/author.dll"
    FPAdminScriptUrl="_vti_bin/_vti_adm/admin.dll"
    TPScriptUrl="_vti_bin/owssvr.dll"
-->
<p><!--webbot bot="PurpleText"
preview="This page is placed into the root directory of your FrontPage web when FrontPage is installed.  It contains information used by the FrontPage client to communicate with the FrontPage server extensions installed on this web server.  You should not delete this file."
--></p>

<h1>FrontPage Configuration Information </h1>

<p>In the HTML comments, this page contains configuration
information that the FrontPage Explorer and FrontPage Editor need to
communicate with the FrontPage server extensions installed on
this web server. Do not delete this page.</p>
</body>
</html>
coreybryantCommented:
Did you go to IIS and drill down to your website and go into the FPSE control panel to check the extensions?

-Corey
a182612Author Commented:
Corey, I used IIS, right click on web site and go to all tasks and I see the server extensions are listed there.  There was an option that said to check server extensions but when I tried to run that I got the message that the server administration programs and the server extensions are not compatible.  The administration program is to old for this server.  It's a windows 2000 server.  Can I download a new admin program or is there somewhere else I can look in the interface for the FPSE control panel?
a182612Author Commented:
See note above but it still ran the check and gave me this message on the server
extensions.
 No problems found
 End check 3/8/2006 6:46:42 AM
coreybryantCommented:
>>There was an option that said to check server extensions but when I tried to run that I got the message that the server administration programs and the server extensions are not compatible.  
This is usually what happens if you copy the files form one server to another.

You have to go thru - delete all the _vti folders.  Now apply the FPSE.

-Corey
a182612Author Commented:
If I delete those files will the other forms on the server that are working sending
email stop working?
coreybryantCommented:
Well you cannot copy the _vti folders from oner server to another.  You have to publish via FP.  I do not think you did that.  You have to delete the _vti, then install the FPSE - that is how you can properly get the FPSE installed because right now they are not installed

-Corey
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development Software

From novice to tech pro — start learning today.