SMTP service is stuck in "starting" mode

How can I restart my SMTP service when it is stuck in "starting" mode.

We are having trouble sending and receiving emails, and then I noticed this service is stuck.

Tried rebooting the server, that didn't help.

Suggestions?
andrefortier7Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rakeshmiglaniCommented:
have to tried setting the service to disable and then doing a reboot
if that works and the server comes up with the smtp service as disabled then rename the vsi 1 folder and then start the smtp service
MCPJoeCommented:
I suggest using Process Explorer from sysinternals.com, you can kill the service process and attempt to restart.  ALso check the credentials its running under.
andrefortier7Author Commented:
rakeshmiglani
-> Kind of hard to diasble the process when you can't even stop the process to begin with in the Services

MCPJoe
-> Process Explorer did not see the smtp process running, but I know from Services in Control Panel, its stuck in "Starting" mode
rakeshmiglaniCommented:
try using safe mode and then disable the service

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.