troubleshooting Question

Trouble compiling and testing libapreq2

Avatar of kareed
kareed asked on
Apache Web Server
2 Comments1 Solution256 ViewsLast Modified:
Hi,
I am trying to install libapreq2 on an osx server running apache2.2 and when I run make test I get the following errors

version....ok                                                                
cookie.....ok                                                                
params.....ok                                                                
parsers....ok                                                                
        3/542 skipped: skipping ELF-dependent tests (parsers.c:134)
error......ok                                                                
util.......FAILED tests 36-37                                                
        Failed 2/89 tests, 97.75% okay
Failed Test Stat Wstat Total Fail  Failed  List of Failed
-------------------------------------------------------------------------------
util.t                    89    2   2.25%  36-37
3 subtests skipped.

I searched the web and I found what appears to be a solution but I don't know what it means.  Below is what I found.

          Thanks for the excellent tools, I don't know what I'd do without  
          Apache2::Request.

          I'm packaging libapreq2 for the Fink distribution (http://
          fink.sf.net), and I ran into a small bug. It appears that the library  
          test 'util' fails (test 36 and 37). This appears to be a result of  
          bad (?) optimization by GCC, compiling util.c with -O0 works fine.  
          Could you please modify the CFLAGS for that target accordingly?


Could someone please tel me what it means and how to implement the solution.  As usual I'm in a hurry to find the solution
Thanks
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 2 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 2 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros