samba NT_STATUS_ACCESS_DENIED

I have a shared folder /shared/berndwhere /shared and /shared/bernd both are read/write enabled for everyone. I can mound the directory under WindowsXP. XP tells me it is a NTFS file system. Now my problem: I can't create files/folders etc because I have no rights.

What do I have to do to get write permissions?????


testparm smb.conf gives the following output.

Load smb config files from smb.conf
Processing section "[homes]"
Processing section "[printers]"
Processing section "[bernd]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

# Global parameters
[global]
        workgroup = ROTHMAN
        server string = Samba Server
        username map = /etc/samba/smbusers
        log file = /var/log/samba/%m.log
        max log size = 50
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        printcap name = /etc/printcap
        dns proxy = No
        idmap uid = 16777216-33554431
        idmap gid = 16777216-33554431
        cups options = raw

[homes]
        comment = Home Directories
        read only = No
        browseable = No

[printers]
        comment = All Printers
        path = /var/spool/samba
        printable = Yes
        browseable = No

[bernd]
        path = /shares/bernd
        valid users = adm, bernd
        read only = No
BAJ05Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

grsteedCommented:
Is that the entire output?  What Samba version do you have. When I issue that command I get over 250 lines for the Global section alone.

It doesn't show what "security" setting you have. From the manpage for smb.conf (Samba 2.2.5)

"If  your  PCs use usernames that are the same as their usernames on the UNIX machine then you will want to use security  =  user. If  you  mostly  use  usernames that don't exist on the UNIX box then use security = share.

You should also use security = share if you want to mainly setup shares without a password (guest shares). This is commonly used for a shared printer server. It is more difficult to setup guest shares with security = user, see the map to guest parameter for details."

Gary
grsteedCommented:
Also, your settings,

[bernd]
        path = /shares/bernd
        valid users = adm, bernd
        read only = No

This is limited to only users adm and bernd. Is that the user that you're using?

Gary


BAJ05Author Commented:
I am using FC4, freshly installed with a complete install, updated through GUI such that no more updates are possible. SAMBA version is 3.0.14a-2.
Please let me know if you need any further information (also maybe provide how I could get that information). The output from testparm is complete. I used the GUI to modify the samba settings. The security level is user. Password encryption is on. Permissions are Read/Write.
Why Diversity in Tech Matters

Kesha Williams, certified professional and software developer, explores the imbalance of diversity in the world of technology -- especially when it comes to hiring women. She showcases ways she's making a difference through the Colors of STEM program.

grsteedCommented:
Have a look at this link and see if it helps.

http://www.fedoraforum.org/forum/showthread.php?t=14324

basically he ran the "smbclient -e <username>" command and added the "smb passwd file = /etc/samba/smbpasswd" line in his smb.conf file.

Gary
BAJ05Author Commented:
So this didn't work, maybe I can attract more information with more points???
grsteedCommented:

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BAJ05Author Commented:
Ok that did the trick: to be more specific the last entry in the above link states that SElinux is the cause of the problem.
Under Desktop->System Settings->Security Level there are entries for SELinux and SAMBA. Once they are changed it is working....
grsteedCommented:
Great!!!  Good to hear!!

Gary
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.