"Access is denied. Make sure the disk is not full or write-protected and that the file is not currently in use." I cannot rename/copy/delete/move files STILL, although Windows has been re-installed!

I have 4 MP3 files in a folder on my D drive, this is a totally seperate disk drive.
(not a partition of the drive Windows is on)

It is a single partition and seperat, a slave on the other IDE.

The system is denying me access to these files although
I removed every single account except "Administrator".
I even removed the guest account, still someone somewhere
was denying me access to the files! HOW?

I opened up ERD Commander 2003 Explorer, can you believe,
even in that I get "Access denied" errors? I went on properties
of the file in ERD Commander and reset the permissions. First
time it said no, so I tried again and got the classic XP eror sound
but a message saying "Successful". I have scanned with HijackThis,
believe me I have, read how many posts I have recommended that and
Hitman Pro 2... nothing can fix this.

I can go download these MP3 file again and get this - if I open the file
from within the BitTorrent client it plays the file. I seed the file in
a BitTorrent client and it plays, also, I can remove the file from
the BT client and for a few hours, if I am lucky, the file will open
in Winamp or whatever I play it in, but then, I will go to try again
later and "Access denied" as if the file is in use but look, I have
RE INSTALLED WINDOWS, not upgraded - a complete wipe out
and start again so how can these files still have permission denied
to them and why can't something as good as ERD even do it?

It all leads to to a corrupted hard disk doesn't it?

Yeah, it WOULD if it were not for the fact that I can re-download and
open it! I can't believe it. Some AVI files did the same recently.
I renamed them in ERD Commander and they would not even
play after that! I burned these renamed AVI's to DVD and they
should have taken up the full disc, they took up half and on all
the file properties it says 0bytes. Hmmm, Nero also said "Access denied"
as it burned off a coaster!

I'm glad I can laugh about it and these files are not important.

I could check for a rootkit, but it can't be, its gotta be a corrupted disk.
I knew I should have got Western Digital but I had to get the first one
I saw (Maxtor) damn it!

What REPAIR TOOLS can I use for corrupted hard drives?
Please don't say a new hard drive, please! With FAT you could
actually fix the disk with software tools but on NTFS what
(free if possible) freeware is known to be good? I am not
after recovery of data because the data is there I just
cannot access it.

Is it possible this disk is very very very fragmented and that
could be the cause?

I have a PE disc - that has stuff like ERD on it, but I know
that wont allow me to do much, something has tampered
with the files to make the system always think they are
in use or something.
LVL 3
EE33Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

allocationerrorCommented:
[...Is it possible this disk is very very very fragmented and that could be the cause?...]
Fragmentation would never cause this kind of problem.

Did you try to run "chkdsk d: /f"? This could be a filesystem error.
pelejabCommented:
Try starting up in safe mode and then enter through the administrator account and see if it is possible to get to the files that way.
scrathcyboyCommented:
These files must be on NTFS volume, you not have this problem otherwise.

Need to recreate exact login name and password you used to make these files.  Then login to your machine as this "new" (ie original) account.  Then take ownership of file and give permission to all user, all logins.  To do this you must UNCHECK "simple" file sharing in windows explorer.  Once "simple" gone you can now set permissio on any object including file, but NTFS will stop you from changing unless you can remember the original login name and PW you used to first create these files.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Fundamentals of JavaScript

Learn the fundamentals of the popular programming language JavaScript so that you can explore the realm of web development.

EE33Author Commented:
I ran CHKDSK and it did fix 2 bad sectors but that wasn't to do with the MP3 files.

Oh my - Simple File Sharing and the security tab of COURSE!

I just went into the security tab and indeed, another "owner" had
exclusive rights to the file.

I must explain - I always have XP installed so "Simple File Sharing"
is DISABLED by default. I only just tweaked it, or so I thought,
to install back how XP does by default and allow Simple File Sharing.

But indeed it must be this that has caused it?

Re-installing in this case can only makes matters worse then!

This is insane though - I never told these MP3's to ever be "owned" in the first place.

So, because I was downloading the EXACT same MP3 it was not allowing access,
I get it now.  I only have to reset these permissions but how can I stop this happening
again? By never using "Simple file sharing"?

I am glad scrathcyboy sorted this, as I thought something really nasty was happening!
EE33Author Commented:
The simple answer then:

Take over the file by unticking "Simple File Sharing"
under Folder Options.

Then remove ALL accounts associated with the file.

Add yourself back in again.
scrathcyboyCommented:
EE33 -- the problem is not necesarily file sharing, but NTFSs way of tying file access to the original "file owner".  In theory, no matter how many login you create, you should be able to get your own files.  But NTFS supposed "security" of file access actually turn out to be user-antagonistic.  We try to explain to MS the problem, but they very ignorant.

If you think this problem bad, try files on USB shared drive, moving between one computer and other.  All files disappear with new login, and MS say this is "how they intended it", but it hurts most users, really.

Anyway, glad you got files back, hope they are good.  Bye
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.