[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 665
  • Last Modified:

Can't send or receive email using Exchange 2003 server

Hi,

I need to know why I can't send email or receive email using Exchange 2003.  It's been fine until now.  The MTA or SMTP won't release messages coming in or going out.  When I look into the queues i can see my test messages but they are not being delivered to any mailbox recipients.  The MTA was very full earlier but I was able to flush the queues and I'm still having the problem.  My event logs keep referring to erro 9297 "Calling client does not have permisions to access MTA RPC...."  I have checked the x.400 connectors and resupplied the password for both my mail servers.

Also my remote mail server can send with no problems but can't recieve as well.  But my local exchange server will not allow outgoing or incoming mail.  There have been no changes to our firewall and we have a Spam filter running Symantec Mail xx.  Any clues and help would be greatly appreciated.  Thanks.
0
kwhite34
Asked:
kwhite34
  • 17
  • 9
  • 4
1 Solution
 
Irwin SantosComputer Integration SpecialistCommented:
Expand your FIRST STORAGE GROUP to PROTOCOLS, look for POP3 Server make sure that is started.

Microsoft update has been applied, and one of the "features" is to not start the POP service. If the above works.. great!  if Not,

then make sure in SERVICES that you have all MS Exchange services running.
0
 
SembeeCommented:
Dunno what you are thinking there irwinpks - this is an SMTP issue, nothing to do with POP3. I have POP3 disabled on most of the servers that I administrate!

kwhite34 - you seem to have missed some information out.

You mention X400 connectors. Does that mean you have multiple servers?
You have also mentioned a remote mail server. Is that another Exchange server or a straight SMTP server?

It sounds like classic blocking of the SMTP ports - have you tested inbound and outbound SMTP traffic with telnet?

Simon.
0
 
Irwin SantosComputer Integration SpecialistCommented:
@sembee.. he mentioned that he cannot receive as well.. recently, MS Windows update set on automatic will download a security update (i have figured out which one).. but it will auto reboot the server and not start the pop3 service. As for the other elements of the question...will have to wait and see what response we get from kwhite324 as my comment was also a fishing question...

but I'm following your comment too as being the #1 Exchange Server guy in the house..not to mention the head honcho on EE.
0
Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

 
kwhite34Author Commented:
I can telnet on port 25 to both servers and the remote server allows me to send mail out but I can not get email back on neither system.  the company mx is systemlinkinc.com if you would like to investigate further.  I have been getting errors about MSexchangeDSaccess and MSexchangeTransport.  I have rebooted both servers and no change the incoming mail will attempt to come in on mailhost.systemlinkinc.com which is a DC and exchange but message just sit in SMTP under queues or MTA.  I can send locally and cant send externally nor can I get anything in.
0
 
kwhite34Author Commented:
I also get a "RPC can not communicate..." to my remote exchange server but they can ping each other with no issues.  It appears I'm having an issue possible with LDAP and Keberos time out.  Any thoughts.
0
 
SembeeCommented:
POP3 still plays no part in receiving email. All Exchange comes in via SMTP unless you are using a POP3 relay.

http://www.dnsreport.com/tools/dnsreport.ch?domain=systemlinkinc.com

One of your mail servers isn't responding, and the other is announcing itself as something else. The name announcement shouldn't cause email delivery to fail.

RPC unable to communicate etc seems like domain issues.
Make sure that your domain controllers are working.
Check that Exchange is pointing at the domain controllers correctly for DNS. No external DNS servers should be in the network configuration.
You have Exchange on a dc (bad idea) - make sure that everything is ok with the domain roles on there. The machine should be a global catalog.

Simon.
(That's my last post tonight as it is getting towards 1am here).
0
 
kwhite34Author Commented:
Domain controllers are working;  I can send out email fine but can not get email in.  The firewall rules haven't changed and I can telnet to smtp.  I have two exchange servers with a SMTP connector on each.  Maybe this is where my problem is; please advise.  Ther internet mail connector has both servers indicated as bridgehead servers.
0
 
SembeeCommented:
I cannot connect to the server listed in your MX records.
If you can telnet to port 25 internally, then the traffic is being blocked somewhere.

SMTP Connector will not be the issue as those are for outbound email only.

Check the firewall. Pay particular attention to any NAT rules to ensure that they are going to the right IP address.
Check that you haven't placed any restrictions on who or what can connect to the SMTP Server.
ESM, Servers, <your server>, Protocols, SMTP. Right click on the default VS and choose Properties.

Simon.
0
 
kwhite34Author Commented:
Did you try mailhost.systemlinkinc.com 25?  Thanks
0
 
SembeeCommented:
I can connect to that one now.

However it is announcing itself as something other than that name...

MAILHOST.systemlinkinc.com claims to be host gollum.slna.com [but that host is at 64.202.167.129, not 207.7.223.163].

That is a bit of a mess.
You need to change it so that it announces itself as mailhost.systemlinkinc.com

ESM, Servers, <your server>, Protocols, SMTP. Right click on SMTP VS and choose Properties. Click on the tab Delivery and then advanced and type mailhost.systemlinkinc.com in the box labelled Fully Qualified Domain Name. Don't bother with Check DNS as that will probably fail.

Simon.
0
 
kwhite34Author Commented:
OK done.  You can test now.
0
 
kwhite34Author Commented:
I also did a zoneedit.com Smtp test and received the mail but when i tried to send from my pop3 address (earthlink.net) i still couldn't get mail.  I just tried again and couldn't receive to test1@systemlinkinc.com.  Any ideas?
0
 
SembeeCommented:
If you have just changed your MX records then that can take a while to propagate round the Internet - anything up to 48 hours.
Do the messages actually bounce back with an NDR or just disappear in the ether?

dnsreport.com now comes back clean except for the SPF record. You would need to ask whoever is looking after your domain name about how to setup the SPF records.  

Simon.
0
 
Irwin SantosComputer Integration SpecialistCommented:
Hey guys...

I'm following this question to learn... and @sembee... I know you are discounting my Pop3 service suggestion, but it wouldn't hurt to just take a look-see right? @kwhite34 can you report back on the status on my first comment please?

Thanks in advance.

Irwin
0
 
kwhite34Author Commented:
The messages disappear with no NDR..................um actually checking the queues of the MTA the message are sitting in the queues as though they don't know where to go.  This is incoming by the way.  There's no issue sending mail out at this point just getting them in through the SMTP Virtual or MTA.  Thanks.
0
 
SembeeCommented:
The messages are sitting in the Exchange server?
If you look at the messages in the Queues, what does it say for the status?
Are they the new messages in the queues?

Simon.
0
 
kwhite34Author Commented:
Irwinpks,

We use POP3 service externally but not internally.  Our Outlook is configured specifically to use MS Exchange so SMTP would be the indicator in this one but just the same the POP3 service is running an operational.  No errors in the log.  I get the MSexchangeMTA error 9318 speaking about RPC communication to my remote and Symantec Mail Security message error
0
 
kwhite34Author Commented:
Ok I have 608 Internet Mail SMTP connector domain name addresses that are queued.  The SMTP Mailbox store is Active with 0 message and nothing in local delivery.  My x.400 Exchange MTA on my remote server is retrying message from yesterday that never got delivery.  Not sure what's up here.
0
 
kwhite34Author Commented:
I shut down my content filter and still not receiving. No ndr either and can see it sitting in the MTA nor SMTP
0
 
SembeeCommented:
Lets try something different.

Stop the SMTP Virtual Server service.

Then use Windows Explorer to look at

\Exchsrvr\Mailroot\vsi 1\Queue

Take the entire contents of that folder (which should be all of your email) and move it to the pickup directory.

Then restart the SMTP virtual server service.
That should force Exchange to process the messages again.

Simon.
0
 
Irwin SantosComputer Integration SpecialistCommented:
@kwhite34....thank you for confirming that.
0
 
kwhite34Author Commented:
ok I did that and still waiting for reciept of email
0
 
kwhite34Author Commented:
Question, are you allowed to have to bridge servers indicated in the Internet mail connector? And could this also relate to possible problems with Active directory?
0
 
kwhite34Author Commented:
I just got 1 email from 5 hours ago 12:33 that I sent from my pop account.  Should I just clear the old mail out?
0
 
SembeeCommented:
What happened to the messages after you moved them? Have they gone back in to the queues?

Not sure what you mean by the second question.
An SMTP Connector needs to have your backend Exchange servers listed as the bridgeheads. If you are then using another server to route email through then this is listed as a smart host.

What I have seen done in the past (which is wrong) is the smart host is set to the server (ie routing back on itself) and the only domain listed in the address space is the internal domain.

Simon.
0
 
kwhite34Author Commented:
The message spooled back over to the queues area and just stayed there with no movement.
0
 
kwhite34Author Commented:
I have another piece of mail that came in 20 minutes late on my remote but I'm not getting anything on my local server to the test account i set up.  Can you try to email me at test1@systemlinkonline.com.  I'm also getting MSExchangeTransport errors stating that mail couldn't be scanned error 348.  Should I be concerned about the unable to bind over RPC message that I get every hour?
0
 
SembeeCommented:
To diagnose event log errors the full event log errors need to be posted.
It looks like the email might be flowing, but very slowly.

Is the domain working correctly?

Simon.
0
 
kwhite34Author Commented:
The domain appears to working well.  I just can't figure this latency in email and/or non-receipt of email.
This is one error that's repeating itself in my application event logs.
An RPC communications error occurred. Unable to bind over RPC. Locality Table (LTAB) index: 25, Windows 2000/MTA error code: 9297. Comms error 9297, Bind error 9297, Remote Server Name GANDALF1 [MAIN BASE 1 500 %10] (14)

MSExchangeTransport error
A message could not be virus scanned - this operation will be retried later. Internet Message ID  <000001c64c66$b6917900$0100007f@LAPTOP>
From: "Peter" <gilbert@pellicano.biz>
To: <mayfield@systemlinkinc.com>
Subject: Men Health
Date: Mon, 20 Mar 2006 22:39:06 +0100
MIME-Version: 1.0
Content-Type: multipart/related;
      type="multipart/alternative";
      boundaryýy0x0, Error Code 0x0.

0
 
kwhite34Author Commented:
Mail is flowing now. Hurrrayyyy!!!!!!  Thanks for you all your help.  I know this was a weird one
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

  • 17
  • 9
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now