We help IT Professionals succeed at work.

XP no longer recognizes CD drive, except in Safe Mode!

digitron
digitron asked
on
Medium Priority
1,034 Views
Last Modified: 2012-08-13
My CD drive was running perfectly until I installed a utility to RIP audio. It's called ExactAudioCopy, and I've used it in the past. It ripped one cd perfectly and then the CD device was no longer recognized by the system. Before ripping the CD, it ran its own uitlity to check the performance of the drive and perhaps stored that somewhere.

I've uninstalled that utility, but have the same problem, which is:

The CD drive IS recognized and works perfectly in SAFE MODE ONLY. As soon as a normal boot is done, the drive does not show anywhere, including the device manager. Attempts to "add new hardware" don't work. At wits end (several hours trying things) I ran the XP automatic repair and reinstall, and updated from Microsoft again. Reinstalled all the motherboard drivers and devices.  STILL, it doesn't see the drive except in safe mode.  Note that I booted from the CD drive and reinstalled Windows from it!

Scanned with all kinds of anti virus and adware. Uninstalled the drive in safe mode, hoping that the normal boot would find it. No way. Reinstalled it in safe mode. Still not recognized under normal boot.

Clearly the drive works, but it appears that something is keeping it out of commission.  This sort of thing is why I have so much less hair than a few years ago.

Help, help, help.

JS
Comment
Watch Question

Irwin SantosComputer Integration Specialist

Commented:
go to MSCONFIG, START-RUN-type MSCONFIG <enter> then located any programs you recognize that you can turn off. Note your changes as you may need to re-enter them.  Restart your machine

Commented:
I would use system restore to roll the machine back to the way it was before you installed the application.  Go to start-programs-accessories-system tools- system restore. Then just set the date to before the application was installed. Your data eg mydocs etc will NOT be deleted.

Author

Commented:
Still trying to disable all programs that are not needed. We'll see.

Have already tried using system restore, but Mr. Computer says that there was not restore point, even though the pop up date picker showed two. So I could not restore. Boy, if I could, that would make life easy. Maybe you know how I could get it to recognize a restore point.

JS
Irwin SantosComputer Integration Specialist

Commented:
have you run my comment yet?
Some utilities change the DMA settings of your CD, and it's possible that your CD isn't compatible with that, or it's also possible that the driver for your IDE interface was somehow modified.  1st thing I would try is checking with the Motherboard Manufacturer's website, and see if there's an update for the IDE.  If that doesn't work, try changing the DMA setting on the installed IDE interface.  Here's the steps:

1.  Click Start->Control Panel and choose System.
2.  Click on the Hardware tab
3.  Click on the Device Manager Button
4.  Click the + to expand the IDE settings
5.  Choose either the first or secondary controller (the one that corresonds to the CD Drive)
6.  Click on the Advanced Settings Tab
7.  Choose either 0 or 1 and change the Transfer Mode Setting

Commented:
Ditto the MSCONFIG comment.  As another clarification point, click on SERVICES, click on HIDE ALL MICROSOFT SERVICES, and of what's left, I'd say start with disabling (unchecking) everything that's there, rebooting, and seeing if the problem is resolved.  Then Add services bit by bit until you find the culprit.  If that doesn't resolve it pls let us know.
Try doing this, some cd writing software places what are called upper and lower filters on cd drive and these "filters" tend to cause a lot of problems with windows recognizing cd drives.  Roxio and Nero are known for causing this issue.

Copy and paste this into notepad and save it as a ".reg" file.  The execute it.  It will delete the appropriate filter if applicable.

Copy below here================

Windows Registry Editor Version 5.00

;NOTE: you may have to reinstall burning software after this fix is applied.

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}]
"UpperFilters"=-
"LowerFilters"=-

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}]
"UpperFilters"=-
"LowerFilters"=-

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}]
"UpperFilters"=-
"LowerFilters"=-
Sorry for the poor grammar in my post above....

Commented:
I'd suggest going into the above keys with regedt32 and telling us what's in there, so we can see if it's important.  Removing what's there without at least quickly looking first isn't terribly wise, IMHO.

Commented:
Sometimes it is merely a matter of DRIVER Conflict. Make sure the CD drive is confirmed in your BIOS. I had the same problem last year. What I did was to change my CD jumper from Master to Slave and then set it to AUTO in the BIOS. Lucky me, it worked.

Commented:
You are right. The CD Drive is fine. The problem might still be with the CD DRIVER. Some CD drives are driver specific. These drives happen to warnout. If you have already copied that specific drive to your systems files, in the appropriate command line, then the problem could be a matter of drive sequence and termination. That means, a terminating drive might be the one that loads first and then blocks the CD driver from seeing the CD Drive. If this happens then the CD drive will be without a driver and wont be driven. Should this be the case, go back to your decice manager in the safe mode and check if there is any device conflict which may perpetuate driver conflict. Indeed, something might be wrong with the drivers.
CERTIFIED EXPERT

Commented:
Try downloading and installing this:

http://www.adaptec.com/worldwide/support/driverdetail.jsp?sess=no&filekey=aspi_v471.exe&language=English+US

If that doesn't work let me know, I have a fix for this that should do the trick. Just don't have access to it right now though...
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:

Commented:
Please just tell us what is in the upper and lower filter values for these keys:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}]
"UpperFilters"=-
"LowerFilters"=-

Commented:
I had a similar problem once.
Here's what I did:
- In Safe Mode I removed all CD drives  (in hardware manager)
- I removed also all IDE/Ata/Atapi controllers
After reboot the computer found new hardware, intalled drivers and everything was fine again.

I saw quite a nice program which was showing all hidden and previously installed devices even if they were
no longer in the system but their drivers were still present. It was made by HP I believe. I'll let you know what was
the name I find it.

Author

Commented:
To irwinpks: Tried that, but same result.  Have also tried the download drivers, with no luck. Still working...

Commented:
You've established it isn't a service or a driver.  Can you check the registry and post what's there?  Chances are fairly good that it's a filter driver.

Again, while in a normal boot:
Please just tell us what is in the upper and lower filter values for these keys:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}]
"UpperFilters"=-
"LowerFilters"=-
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
did you try my suggestion?

Commented:
that zeros out the section of the registry in question.  That's not wise if we don't know what is in there already, hence my request that the OP supply that information by simply looking first, before making any changes.

Commented:
looks like the software screwed up windows internal CD Drivers. safe mode will use different drivers so will be ok.

i would recommend going to device manager (under controll panel,system) and selecting your cdrom drive. once selected do a search to try to update the drivers and see if windows lets you fix it.

if this does not work deleate the CDROM icon from device manager and reboot, and windows will reinstall the CDROM drive.

whilst in device manager its worth checking what the state of the drive is, check if thier is a cross or excliamation mark on the device, and check whether windows believes it is working properly when you select it.

try this and let us know what happens

Commented:
None of the above will change the filter drivers, which several of us believe to be the problem.  Is the OP around to try this?
Mohammed HamadaSenior IT Consultant
CERTIFIED EXPERT

Commented:
Have you tried to reinstall this software once again, this might fix your problem, if my guessing is right that this software was installed incorrectly which caused you to lose CD room in normal mode.

Try to install the same version that you have uninstalled, this will fix the registry values which might be broken or sit to not work correctly as it was before installing it the first time.

I also suggest that you try and do system file check..,
Start --> run --> sfc/scannow
Please read this article and refer to reg file which I posted above.... this problem is not uncommon and I have seen it a few time before.

MS: http://support.microsoft.com/kb/314060/EN-US/
Commented:
Exactly, BL.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Commented:
I agre with BLundahl1987 my past experence also.


"Please read this article and refer to reg file which I posted above.... this problem is not uncommon and I have seen it a few time before.

MS: http://support.microsoft.com/kb/314060/EN-US/ "
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.