[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

MX record is returned when doing a nslookup, however, I've already deleted this MX record

Posted on 2006-03-20
18
Medium Priority
?
663 Views
Last Modified: 2008-01-09
I'm having DNS issues.  I deleted a MX record on my Win 2003 DNS server, however, when doing a nslookup set type=mx command on the mail domain it still returns.  I've deleted this record, how is it still being returned?
0
Comment
Question by:gopher_49
  • 7
  • 6
  • 4
  • +1
18 Comments
 

Author Comment

by:gopher_49
ID: 16236621
below are the results of the nslookup.......  This record doesn't exist.

C:\WINDOWS\system32>nslookup
Default Server:  drexel_1.drexel.com
Address:  192.168.1.250

> set type=mx
> drexchem.com
Server:  drexel_1.drexel.com
Address:  192.168.1.250

Non-authoritative answer:
drexchem.com    MX preference = 10, mail exchanger = mail.drexchem.com

mail.drexchem.com       internet address = 192.168.1.2
>
0
 
LVL 7

Expert Comment

by:Giuseppe "Pino" De Francesco
ID: 16236948
Hiya,
Non-authoritative answer means that is not an info stored in the SOA DNS, so... I think that you have more than one DNS server,so just force the replica.

Cheers
Pino
0
 
LVL 11

Expert Comment

by:bwalker1
ID: 16236971
First, clear the cache from DNS management on your server, and also run ipconfig /flushdns on your client.
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 
LVL 33

Expert Comment

by:NJComputerNetworks
ID: 16237037
below are the results of the nslookup.......  This record doesn't exist.

C:\WINDOWS\system32>nslookup
Default Server:  drexel_1.drexel.com
Address:  192.168.1.250

> set type=mx
> drexchem.com
Server:  drexel_1.drexel.com
Address:  192.168.1.250

Non-authoritative answer:   <---- THIS RECORD WAS NOT FOUND ON YOUR LOCAL WINDOWS 2003 DNS SERVER.
drexchem.com    MX preference = 10, mail exchanger = mail.drexchem.com

mail.drexchem.com       internet address = 192.168.1.2
0
 
LVL 33

Expert Comment

by:NJComputerNetworks
ID: 16237046
if it was, it would have said AUTHORITATIVE Answer...
0
 

Author Comment

by:gopher_49
ID: 16237293
Pino,

How do I force a replica to each DNS server?
0
 
LVL 33

Expert Comment

by:NJComputerNetworks
ID: 16237370
from my location, i get this:

drexchem.com    nameserver = ns02.worldspice.net
drexchem.com    nameserver = ns01.worldspice.net
mail.drexchem.com       internet address = 216.37.73.243
0
 

Author Comment

by:gopher_49
ID: 16237384
I've cleared the cache, I also took away the external DNS server from it's DNS server settings on it's control panel.  Whether I have a MX record in my DNS database, or, if one is not there, I get the same results as listed above.
0
 
LVL 7

Accepted Solution

by:
Giuseppe "Pino" De Francesco earned 100 total points
ID: 16237483
From the DNS server where you have the secondary zone, right click on the zone and choose "Reload From Master"

Cheers
Pino
0
 
LVL 33

Expert Comment

by:NJComputerNetworks
ID: 16237498
You get this too?

drexchem.com    nameserver = ns02.worldspice.net
drexchem.com    nameserver = ns01.worldspice.net
mail.drexchem.com       internet address = 216.37.73.243

...and you want to change this IP address? if so, you need to make the change on the Internet...not on your local internal DNS servers...

Goto worldspice.net and change your MX record.
0
 
LVL 7

Expert Comment

by:Giuseppe "Pino" De Francesco
ID: 16237531
Er... Assuming that your SOA is on your servers...
0
 
LVL 33

Expert Comment

by:NJComputerNetworks
ID: 16237536
Looks like you need to go to http://www.dotster.com/ to change this DNS record...
0
 

Author Comment

by:gopher_49
ID: 16237583
Pino,

I have two DNS servers.  Both replicate via Active Directory.  The primary DNS server is called drexel_3, and secondary is called drexel_1.  Both of these DNS servers are providing DNS for the domain drexel.com (My local domain), however, I'm created a local MX record for my mail domain, which is called drexchem.com.  This record is only accessed from the computer in my local network.  Now, I right click on my secondary server's (drexel_1) drexel.com zone and left click on 'reload'.   It let me do this once, however, it later said 'Failed to reload zone.  The zone is locked for zone transfer or update.'   Both zones within each server seem to have the same records.  I only have one MX record and they both have the same one.
0
 

Author Comment

by:gopher_49
ID: 16237602
NJComputerNetworks,

I'm referring to the MX record on my local network.  I only want to change how the computer inside my perimiter network resolve the MX record.  The external DNS resolution (for internet queries) is fine...  
0
 

Author Comment

by:gopher_49
ID: 16237707
Pino,

I only have a zone for drexel.com.  Should I create a zone for drexchem.com also?
0
 
LVL 33

Assisted Solution

by:NJComputerNetworks
NJComputerNetworks earned 400 total points
ID: 16237989
Yes, you would need to create a zone for drexchem.com if you want to control records in the drexchem.com namespace locally (internally).

Once you do this, you will have to create an MX record in this new zone.

Also, you should add a new DNS Suffix for all of you clients...  drexchem.com.  You can do this in TCP/IP properties of any machine.  Click the DNs tab.

A DNS suffix will automatically append the FQDN name to each lookup...

for example,

if you have DREXCHEM.com and Drexel.com listed as DNS suffixes on each clients...this behavior will occur...

When the client searches for server1...both drexel.com and drexchem.com will be appended automatically in the search.  So, server1.drexel.com and server1.drexchem.com will be searched for...  
0
 

Author Comment

by:gopher_49
ID: 16238102
I created a zone called 'drexchem.com'.  I also created a A record and a MX record.  When I do a nslookup type for a MX record for the domain drexchem.com the server IP address is returned.  I thought this would fix a problem I'm having sending emails out through my front end server, however it did not, regardless, I have the MX record created so that's one less thing to worry about.  I posted my original problem in the Exchange section, hopefully it will be resolved there.  For now, creating the drexchem.com zone allowed me to properly resolve the MX and A record.

thanks
0
 
LVL 7

Expert Comment

by:Giuseppe "Pino" De Francesco
ID: 16238178
Yep, you have to create the zone in your DNS servers as Primary Standard Zone (in one of them) and as Secondary Standard Zone (pointing to the primary as Master) in your secondary DNS server. CAREFUL to add the domain also in the "DNS Domain" of the Forwarders tab of the Properties page of your servers, and for this  UNcheck the setting "Do not use recursion for this domain" and add as forwarders your external DNS servers.

Cheers
Pino
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I've always wanted to allow a user to have a printer no matter where they login. The steps below will show you how to achieve just that. In this Article I'll show how to deploy printers automatically with group policy and then using security fil…
On July 14th 2015, Windows Server 2003 will become End of Support, leaving hundreds of thousands of servers around the world that still run this 12 year old operating system vulnerable and potentially out of compliance in many organisations around t…
this video summaries big data hadoop online training demo (http://onlineitguru.com/big-data-hadoop-online-training-placement.html) , and covers basics in big data hadoop .
Integration Management Part 2

873 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question