• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 12902
  • Last Modified:

Windows XP Pro unable to browse lan

3/20/06
12:10pm

LAN with mostly Win98 SE pc's
four servers - all stand alone servers, no PDC/BDC's
servers are three W2K, one W2K3
all pc's are members of the same workgroup "xyzgroup"

we have started adding XP Pro SP2 pc's to the LAN. Everything seems to work fine except - none of the XP's can browse network neighborhood/places
"xyzgroup is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.
The specified server cannot perform the requested operation"

the w2k servers browser OK, the win98 se pc's browse OK, only the xp's have this problem.
same problem is there even logged on as local xp admin.
network resources can be accessed directly such as \\computer\share or by mapping a drive.

Only problem occurs when clicking My Network Places, so we are unable to browse the lan.

Windows firewall is off/disabled, no other firewall-type apps are installed, Norton AV scan is clean (these are all new fresh installs, five new pc's with xp pro sp2).

Something is wrong with network browsing, maybe xp can not get a browse list from the master or backup browser? but all other pc's are able to browse fine!

Ideas?

George




0
George46227
Asked:
George46227
  • 13
  • 7
  • 5
  • +3
5 Solutions
 
cyan990Commented:
HI,

Couple suggestions for you....

1.  Verify that all the machines are on the same subnet.  (Incorrect Subnet masks can make this happen.)
2.  Does the Windows XP boxes have an account name that is corresponding to one on the server?  If not, make one and logon witht that       account and try to browse.
3.  If you're using DNS, make sure that the new computers have correct dns entries.
4.  Make sure that the workstation/server service is started.


Cheers,

Cyan990
0
 
George46227Author Commented:
3/20/06
1:40pm

cyan990

1. ip subnets are masks are OK
2. yes account name matches, otherwise mapping the network drive would fail since the shares are secured
3. dns not used
4. workstation/server service - you mean on the XP machine itself or on the file servers?

George
0
 
bmoebCommented:
If you can't see other computers but you can map the other computers' shared folder using UNC (\\computername\sharedfolder), this may be master browser issue. You may want to disable master browser on XP machine.  Check the event viewer it probably has some errors.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
bmoebCommented:
location >  Administrative Tools>Services, to stop the Computer Browser.
0
 
cyan990Commented:
Hi,

To clairfy, the workstation/server services would be on he XP box not the server.  This article http://fhctech.org/fhc/networking/xpclient.htm show how to enable NetBIOS over TCP/IP.  This would be the NEXT thing I would try.

Cheers,

Cyan990
0
 
cyan990Commented:
Oops,

Forgot to mention...once enabling NetBIOS...reboot your XP boxes :)

Cyan990
0
 
JimsZCommented:
Is there a wins server?   Also, verify that the account you are using has the authorization to log onto the servers.  Probably either a netbios issue or security issue.  Windows XP always tries to use the local logon name when logging into network shares so if the user/password is different on the shares, go into control panel, then usernames and passwords and put the user/password in for the shares in question
0
 
harryballzCommented:
This is a SP2 bug...90% of the time its 1 of these 2 tweaks.

On the XP PRO box:

1. Click Start, click Run, type gpedit.msc

2. Navigate to:
Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment

3. In the right pane, double click "Deny access to this computer from the network" option. Remove all users or group from the list.

4. In the right pane, double click "Access this computer from the network" option. Add the user account or group to the access list and test the issue.

If this doesn't help, try the following step.

Step 2. Check the related registry key on the problematic machine

1. Click Start, click Run, type regedit

2. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

3. Make sure the value data of RestrictAnonymous is 0
If this is not the case, please set it to 0 and reboot to check the effect.
0
 
George46227Author Commented:
3/20/06
3:00pm

A lot of the answers are confusing because they don't refer to which machine to perform the re-configuration on - or they refer to changes on the xp workstation vs. the file server, which seems counter-intuitive.

My guess is the xp machine is trying to get a browse list from a master browser but can't for some reason, so it seems the re-config should be done on the w2k file servers? This sounds like a browser-election issue - I assume a W2K/W2K3 server would take election priority over a XP Pro station?


1. bmoeb: event viewer did not have browser errors. Disable master browser - on xp workstation or on the file servers? how to disable master browser, do you have a link on how to? did you really mean to stop the computer browser service on the xp - won't this prevent lan browsing completely?

2. cyan990: I have already checked NetBIOS, it is enabled.

3. JimsZ: there is no WINS server. Authorization is OK because they are able to map drives to a shared folder on one of the file servers.

4. harryballz: do you mean to change the policy on the xp workstation or the file server? the problem is the xp pc's can not browse the lan, w2k and w98 are able to browse the LAN. What user would I add to the "access this computer from the network"? - I am trying to browse the LAN from the xp workstation, not trying to access the XP workstation from the LAN. For RestrictAnonymous=0 do you mean on the file server on the xp workstation?
 
Thanks for all replies
George
0
 
harryballzCommented:
Like I stated the XP PRO box has the bug...  :-)
0
 
bmoebCommented:
Disable the master browser on the xp workstation
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters IsDomainMaster=FALSE
 
You will still be able to browse the network with this off.

or go to administrative tools > services > computer browser change it to manual /disable it if you like then stop it.  



0
 
dhoustonieCommented:
Have you disabled Simple File Sharing on the Windows XP machines?
Sometimes this can be a problem for accessing Windows XP Machines form the network.

In Windows Explorer - Tools - Folder Options - View - Down at the botom deselect Simple File Sharing


David
0
 
George46227Author Commented:
3/23/06
3:55pm

tried all suggestions but still not working.

did find a microsoft article KB 889320 which might be the fix - XP SP2 Browsing issue related to disabling the firewall
unfortunately the hotfix is not available (new browser.dll) - I have to call Microsoft Product Support to get it!

George

0
 
dhoustonieCommented:
do you have KB number?
A call to pss is free if it is for a patch that is known, you just need to tell them that what the patch number is.
So give them a call and tell us how it goes.
Regards,
David
0
 
harryballzCommented:
Hey George,

Somewhere in there you are being denied to browse from local policy...it's just a tweak from 1 to 0 somewhere!  Your so close.

Under gpedit.msc was...

Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment

... blank???  Did you remove EVERYONE?

Also, were these new PC's upgraded from SP1 (or XP) to SP2?  Or did they come from factory already with SP2?
0
 
George46227Author Commented:
3/24/06
11:00am

summary of attempted fixes:
1. Simple FIle Sharing change to disabled
2. IsDomainMaster=FALSE verified
3. Services > Computer Browser > tried it ON and OFF
4. RestrictAnonymous verified = 0
5. Deny Access to this computer policy verified = only Support_388945a0 listed
6. Access this computer policy verified = Backup Operators, Everyone, Power Users, Users, Administrators
7. machines are on same ip subnet = verified
8. XP machine is logged on with an account that has access to the servers = verified ( user can access the servers with \\computername or \\ip_address or mapped drive but can not browse network places; also verified by logging on to the XP machine with an account which is a server admin )
9. Workstation and server service started = verified

still no browsing

the KB article is 889320, the hotfix is a updated browser.dll version 5.1.2600.2586 77,824 bytes 12/20/04
I have not had a chance to install the file ( I got it from a web site posted by someone who got it from MS ), MS warns the hotfix "may be unstable, may crash the machine, etc.", so I am being cautious to install it.

George
0
 
George46227Author Commented:
3/24/06
11:20am

I don't know if it came with SP2 loaded vs. upgraded to SP2, I only have remote access to the machine.

George
0
 
dhoustonieCommented:
Do you have Virtual Pc or Vmware that you can install a virtual machine on and try testing it out there?

David
Ps, call MS they will give you the patch for free rather then risking software downloaded from a third party.
0
 
bmoebCommented:
I would try one more thing,  have you tried sharing a folder on the xp machine to see if the other pc's can see it? Or to see if your machine shows up?  I have seen things where I ran through the wizard to share a folder (on the machine that couldnt get out) that corrected networking issues similar to this before.  It can't hurt.
what happens when you run the net view command?  does anything show up?  can you do a net view /domain:wkgpname?
If not it should give an error that you could probably look up.



0
 
George46227Author Commented:
3/24/06
1:55pm

I can net view \\computername to Windows98 pc's OK, when I try to net view to one of the w2k/w2k3 servers I get a similar error as in Network Places - like "Access Denied".

George
0
 
George46227Author Commented:
3/24/06
2:20pm

Did I mention - the w2k server  CAN see the XP machine in Network Places, also the XP machine shows up in net view /domain:myworkgroup. But not the other way around - XP machine can not see anybody in Network Places.

George
0
 
bmoebCommented:
Does teh xp machine see itself if you share a folder?
0
 
harryballzCommented:
Ahhhh you are taking over an existing setup.  The previous admin may have allowed/denied network access via Group Policy.  I would take a good look at how Group Policy is applied to the OU's.  Did teh last admin document anything??? Especially if these are all new machines to the network...look there.

My other thought is if the machines had any viruses lately the newest generation of these are "un-registering" .dlls (can't do Windows Update etc...)  To fix that just re-register the .dll's

Start> Run and type REGSVR32 SOFTPUB.DLL
Start> Run and type REGSVR32 INITPKI.DLL
Start> Run and type REGSVR32 MSSIP32.DLL
Start> Run and type REGSVR32 WINTRUST.DLL

*Sometimes you might not have one and it just won’t show up.
0
 
George46227Author Commented:
3/24/06
4:00pm

No group policy (domain-based), no domain controllers, just some stand-alone file servers.

George
0
 
harryballzCommented:
Hey George,

Your comment about net view domain through me...

Then it must just be a local security policy on the PC or an unregistered .dll

Does Windows Update work? Does Search work? These are all symtoms of the same problem.

Did you re-register those .dll's ???

WE WILL FIND THIS! :-)
0
 
George46227Author Commented:
4/5/06
3:30pm

UPDATE

I installed the new browser.dll from the MS Hotfix -
no change, same error

I did share a folder on one of the XP machines - same problem. In other words XP #1 can connect to the shared folder on XP #2 but XP #1 can NOT see XP #2 in My Network Places, can not see any machines in My Network Places, can only connect with start - run  \\anymachine (XP or 98 or w2k OS, all the same), map drives also work using \\machinename\sharename but not browsing.

George
0
 
George46227Author Commented:
4/5/06
3:40pm

Yes, the search function works using Explorer (from inside Explorer, that's the only way I have used it - searching for files works normally).

George
0
 
harryballzCommented:
Hey George :-)  Thought you FDISK'd it by now!

It has to be a bad local policy fragment...on the problamatic PC make sure to remove EVERYTHING under "Deny Access. to this.." by

Start> Run>  gpedit.msc

Navigate down to:
Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment
(On the right pane double click "Deny access to this computer from the network" option. Remove ALL users and groups)

Then while still there double click "Access this computer from the network" option. Add the user account or group to the access list and test the issue. (try adding Everyone group first)

Reboot
0
 
George46227Author Commented:
4/11/06
2:30pm

harryballz:
your suggestion of 4/6/06 is the same one I had tried previously - see my response on 3/24/06. But - there is one account in the "Deny Access to this computer" - "Support_388945a0". I can't imagine that this account could have anything to do with it! Have you heard anything about it?

This is going slowly because I don't have easy access to the machine - it is remote to me, I can't work on it easily but I do still need to figure this out because ALL the xp machines on the network are having this problem ( so I am told ), I have only worked on one of the problem machines.

thanks
George


0
 
harryballzCommented:
YES!

Remove everything that blocks access!

You are the first person I've seen that has come to EE and asked for help but wont take it.  I don't know why you are making it so hard on yourself.  You clients must be so frustrated by now.

Best of luck George
0
 
George46227Author Commented:
4/11/06
4:35pm

harrybalz:

as i said I do not have easy access to the machine so I can only try the fix next time I visit the location - or if the user allows remote access (this particular user keeps turning his firewall back on which blocks me - I have to call him to arrange access but he is difficult to get to by phone/voice mail).

I will try to remove the account as soon as I get a chance.

George
0
 
George46227Author Commented:
5/8/06
5:25pm

I will close the question. I have not been able to try the latest suggestion because the machine is not available to me at this time. I did find a KB article that described the problem and obtained a copy of the browser.dll file and installed it (copied it into the correct folder) but this did not fix the problem - however I got the file from a web page instead of the official Microsoft hotfix (you have to call Product Services to get the fix) so maybe the file I used was not good.
I will give points based on quick responses, effort, and quality of the response:

cyan90 125 points
bmoeb 125 points
JimsZ 50 points
harrybalz 150 points
dhoustonie early 50 points

George
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 13
  • 7
  • 5
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now