enableing server side includes

I just setup a new linux server and for some reason apache isn't allowing server side includes to work. how do I enable this?
battalionAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

periwinkleCommented:
You should look into your Apache configuration file (httpd.conf).

Look for a line which starts:

AllowOverride (...)

AllowOverride controls which options the .htaccess in directories can override.  It can be set to All, or any combination of Options, FileInfo, AuthConfig and Limit.

For example:

AllowOverride All

You can set this by default, or by individual VirtualHost containers.

Additionally, the name of the .htaccess file is controlled by the AccessFileName directive;  typically, it's set as follows:

AccessFileName .htaccess
battalionAuthor Commented:
below is the setup for my httpd.conf file.

NameVirtualHost 10.1.6.201:80
<Directory "/web/Intranet">
    AllowOverride All
    allow from all
    Options +Indexes
</Directory>
<VirtualHost 10.1.6.201:80>

    DocumentRoot /web/Intranet    
    ServerName intranet
</VirtualHost>
periwinkleCommented:
I'd put the AllowOverride All in the VirtualHost container, too.  Is there an AccessFileName directive?
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

caterham_wwwCommented:
did you enable

AddType text/html .shtml
AddOutputFilter INCLUDES .shtml

in your httpd.conf, too? May be just uncomment both lines in your httpd.conf.
battalionAuthor Commented:
they are uncommented
periwinkleCommented:
My apologies - clearly I read the question and then answered another.  You want server side includes to work.

That requires not AllowOverrides (which is what enables .htaccess files), but the following:

Options Includes

Change your Options statement to:

Options Includes +Indexes

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
periwinkleCommented:
I'm so glad to have helped - sorry for the initial miscue!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Languages and Standards

From novice to tech pro — start learning today.