XP Can't See Samba Server

I've researched here and at Samba.org trying to setup my Linux box to be a SMB server and attach my XP client to it. Using smbclient on the Linux box, everything seems to be OK. On the XP side, I can ping the Linux box both by IP and by name but when I try to search for the computer in the Network Neighborhood, XP claims it's not there. Also when I issue the following from the XP command prompt, windows says a network path can't be found -- even if I JUST pinged the box!
Here's the command:
net use h: \\fiatlux\RCHRISMON /user:rchrismon

I think it's an XP issue but I don't really know. Here's my smb.conf:
# Samba config file created using SWAT
# from 0.0.0.0 (0.0.0.0)
# Date: 2006/03/18 18:29:28

# Global parameters
[global]
      workgroup = FRACTALDATA
      netbios aliases = fiatlux
      security = SHARE
      null passwords = Yes
      guest account = rchrismon
      unix password sync = Yes
      log level = 4
      log file = /var/log/samba/%m.log
      max log size = 50
      server signing = auto
      keepalive = 15
      socket options = TCP_NODELAY SO_SNDBUF=8192 SO_RCVBUF=8192
      printcap name = /etc/printcap
      logon drive = h:
      logon home = \\netbiosname\%U
      domain master = No
      dns proxy = No
      wins support = Yes
      ldap ssl = no
      preload = global homes printers RCHRISMON FD_HPK60
      default service = RCHRISMON
      idmap uid = 16777216-33554431
      idmap gid = 16777216-33554431
      winbind enum users = No
      winbind enum groups = No
      winbind trusted domains only = Yes
      path = /var/spool/samba/
      read only = No
      guest ok = Yes
      cups options = raw
      printer name = FD_HPK60
      case sensitive = No
      msdfs proxy = no

[homes]
      comment = Home Directories
      valid users = %S
      create mask = 0600
      directory mask = 0700
      browseable = No

[printers]
      comment = All Printers
      printable = Yes
      use client driver = Yes
      browseable = No

[RCHRISMON]
      comment = Randy's Linux home directory
      path = /home/rchrismon/
      force user = rchrismon
      force group = rchrismon
      guest ok = No
      case sensitive = Yes
      hide dot files = No
      set directory = Yes
      delete readonly = Yes

[FD_HPK60]
      comment = Network Printer
      printable = Yes
      printer name = officejet-k60--1
Any help would be greatly appreciated.
Randy
rchrismonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rchrismonAuthor Commented:
Some additional information:
I'm using XP Pro so that's not the issue. Nevertheless, I still think it's an XP issue rather than a Linux or smb.conf issue. Testparm shows no errors and I can use smbclient on the Linux box to browse the share. I'm flat stumped.
Any help appreciated.
Thanks.
Randy
0
rindiCommented:
Try connecting to the linux box by using it'sw ip address and not the name.
0
xDamoxCommented:
Hi,

Check your iptables and make sure they are not blocking the samba port.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rchrismonAuthor Commented:
It was, indeed, the firewall settings. I had to hunt around to figure out where to change the settings -- seems like there used to be a firewall configuration utility on one of the menus but I couldn't find it. Finally used the authorizations tool which seemed to take care of it.
Thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.