SMTP Gateway cannot relay email to Exchange 2003 Server

I have a SMTP gateway (192.168.50.3) that cannot relay email to my Exchange SMTP Virtual Server (192.168.50.2).  My Exchange Virtual Server does not allow for anonymous authentication.  I do have my the SMTP gateway listed in the list of computers that are allowed to relay through my Exchange Virtual Server, but I also have "Allow all computers that successful authenticate to relay, regardless of the list above" check marked.  The Exchange Virtual Server allows any computer to connect to it.  

When I allow anonymous authentication, the SMTP gateway can relay messages to the Exchange SMTP Virtual Server just fine.  How do I setup the Exchange SMTP Virtual Server to not allow anonymous authentication but allow the SMTP gateway to relay messages?



mnmorencyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

flyguybobCommented:
Double-check your Default SMTP Virtual Server Settings.  Access Tab, Relay button
Ensure that the radio button you have setup says "Only the list below" and not "All except the list below"
The "Allow all computers..." checkbox should not make a difference in this instance as the relay is not authenticating.
Personally, I leave the anonymous access checkbox checked on my front-ends so that servers, on the Internet, can send messages to me.
mnmorencyAuthor Commented:
The Relay button is set to "Only the list below".  The specific LAN IP is added to the list "192.168.1.53" and the Exchange Virtual Servier still does not want to relay for the SMTP Gateway.
flyguybobCommented:
Unless you have re-iped the servers, can you list 192.168.50.3?
If I am not mistaken, unless you are authenticating with a user account, a group account, or a certificate, anonymous access has to be enabled.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
flyguybobCommented:
I don't think that I answered the question, but I am interested in the disposition of the question.  Anonymous access has to be on unless the system is authenticating.  However, anonymous access does not mean that the system can be used as a relay unless other conditions are met...conditions that have already been addressed by mnmorency.

Bob
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.