Cannot install OS to hard drive

Hello good folks,

After a system meltdown i am trying to install xp on a brand new seagate ATA100 drive.
I can boot from the XP disk, partition and format but when the computer reboots for the first time i get an error message:

A disk read error occured
Ctrl + alt + del to reboot.

Any ideas to throw my way so i can first install the new drive and then recover the info from the old dead drive?
When i return home i will run the seagate disk install wizard from their site to check for error although iw ould assume that the xp install disk checks for errors before writing to the new drive.
LVL 5
d3xt3rAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

d3xt3rAuthor Commented:
I am beginning to think this is a mbr issue. When i return home i will try fdisk /mbr
to see if i have any hoy.
0
pubmarcCommented:
It sounds like you new drive has bad blocks on it.  Unfortuantely it is not all that uncommon for a drive to be bad out of the box.  You may want to just make sure that the system is not trying to boot off of any of your other drives. (ie. CD, Floppy, or any USB drives that you may have)

But It is probably a bad drive.
0
d3xt3rAuthor Commented:
Does the xp installation not check the disk before installation and report bad blocks?

While it does seem that is the problem what concerns me is that there is no problem copying files to HD during install, its only upon first reboot that the problem arises.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

stevew1Commented:
What kind of system are you installing in? I doubt that it is bad blocks, could be something to do with the partition size that you have setup on the new drive. How was your old drive setup and what size was it and what size is your new drive?  http://www.smartcomputing.com/techsupport/detail.aspx?guid=&ErrorID=23373  Take a look at this link it may apply in this situation.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
d3xt3rAuthor Commented:
The system is a foxconn mobo with 512Mb generic RAM. Tried setting up partitions as follows.

c:   Label=system 15Gb
d: Label=storage 50 Gb
e: Label=recovery 15Gb

I have tried FAT32 and NTFS with no joy. I'll have a read of this link.
0
rindiCommented:
Get the UBCD, it has many usefull tools on it, including the seatools with which you can test the HD, and if it errors out you can apply for a warranty replacement. Another test on the CD you should test your system with is memtest86+, as this can often be caused by bad RAM.

http://ultimatebootcd.com
0
cods69Commented:
Rindi is correct re seatools for Seagate drives.

For any SMART capable drive I suggest SmartMonTools http://smartmontools.sourceforge.net/
It is a basic but excellent utility for checking SMART status on any drive in the system.
I run it from a batch file to send a report for 4 drives to 1 text file.
Basically you can run it with something like....
smartctl -a /dev/hda > HDSTATUS.TXT
Then just check the report for "SMART overall-health self-assessment test result: PASSED", or further down the report check the "WHEN_FAILED" column for any alerts.
0
d3xt3rAuthor Commented:
Thanks. Rindi i had downloaded the diskwizard from seagates website and will run this when i return home this evening.
I have twice downloaded the UBD in the past and failed to boot from both. Will give it another go from another computer.

cods69 i like the idea you've presented. I run linux/xp  on my home machine and am familiar with batch files. While it is no use to me with this problem i will no doubt use this in the future.

I'll report back tomorrow with a list of what i have tried and what worked. It has to. (something WILL work .... the client needs the system back urgently complete with lost info) I really really hate letting any box get the better of me.
0
rindiCommented:
If the UBCD didn't boot either your PC can't boot from CD? Check that option in the BIOS, you should be able to set the boot sequence to boot from CD first. If this isn't the issue you may not have burnt the CD correctly. You can download the UBCD as an exe or zip file. Both are compressed and you first need to extract the iso image from those files. If you got the exe file first run it on a windoze machine and the iso will extract. Now if you are using nero, open "recorder", then select "Burn Image" and then select the iso file that just got extracted, then burn. You should rather burn it to CD-R and not to CD-RW, they are much more reliable. Also don't burn at top speed. The UBCD isn't that large, so even if you burn it slowly it still won't take that much time.
0
f-kingIT support technicianCommented:
Hi
Looks more like a bios setting than anything else ,I have seen this on compaq pc´s when I had to change the hardrive setting from auto in the bios to LBA and then save and exit ,rerun the setup and then it worked.

hope this helps
0
maduropaCommented:
You have setup the partitions yourself or by the OS?
try to install with only one partition present,
also check with fdisk if the right partition is active.
For safety you may'also drop your first partition-size under the 8 GB
0
pubmarcCommented:
If you do a quick format on the drive when  you install windows, then it does absolutly no scan on the hard drive.  If you do a full format it will do a partial scan of the drive while it is formatting, but it still is not a block by block scan.  You should get the diagnostic utility from the hard drive manufacturer and run a complete hard disk scan.
0
d3xt3rAuthor Commented:
Thanks for all your help. Problem has been overcome. Not sure which step fixed it and didn't have time to isolate.

1. Downloaded and ran diskwizard from seagates website which zero filled the drive.
2. Booted to bios and reset to factory.
3. Booted to WinME bootdisk and reset mbr
4. used fdisk to partition and format
5. Installed WinME (same original problem)
6. Used Partition magic to partition and format
7. Same original problem
8. Booted from xp disk and created just one 6Gb partition
9. Windows installed part way and gave me an error: UNMOUNTABLE VOLUME
10. Swapped out IDE cable
11 Joy Joy Joy

Hoepfully someone can use this information (prob best carried out in reverse order) to help themselves in the future.
I'll divide points up appropriately, thanks again.
0
pubmarcCommented:
Bad cable i'm sure
0
d3xt3rAuthor Commented:
It appears so, although the same cable had been used for over a year without a hitch. (I rebuilt their system 12 months ago)
My only theory as to what may have caused it is a power surge.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.